summaryrefslogtreecommitdiffstats
path: root/abs/core/pam/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/pam/PKGBUILD')
-rw-r--r--abs/core/pam/PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/abs/core/pam/PKGBUILD b/abs/core/pam/PKGBUILD
index 63108ea..05f8837 100644
--- a/abs/core/pam/PKGBUILD
+++ b/abs/core/pam/PKGBUILD
@@ -1,35 +1,33 @@
-# $Id: PKGBUILD 29514 2009-03-09 17:33:55Z tpowa $
-# Maintainer: judd <jvinet@zeroflux.org>
+# $Id: PKGBUILD 96216 2010-10-19 11:54:04Z allan $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
pkgname=pam
-pkgver=1.0.4
+pkgver=1.1.3
pkgrel=1
pkgdesc="PAM (Pluggable Authentication Modules) library"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.kernel.org/pub/linux/libs/pam/"
-groups=('base')
-depends=('glibc' 'db>=4.7' 'cracklib')
+depends=('glibc' 'db' 'cracklib')
makedepends=('flex')
backup=(etc/security/{access.conf,group.conf,limits.conf,namespace.conf,namespace.init,pam_env.conf,time.conf} etc/pam.d/other etc/default/passwd etc/environment)
-source=(http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2 \
- ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2/pam_unix2-2.6.tar.bz2 \
+source=(http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2
+ ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2/pam_unix2-2.6.tar.bz2
other)
options=('!libtool' '!emptydirs')
-md5sums=('189171821b56aaf791cc890d0707ea82'
- 'e2788389a6c59224110a45fcff30e02b'
- '6e6c8719e5989d976a14610f340bd33a')
build() {
cd $srcdir/Linux-PAM-$pkgver
./configure --sysconfdir=/etc DESTDIR=$pkgdir --libdir=/lib
- make || return 1
+ make
make INSTALL=/bin/install DESTDIR=$pkgdir install
install -D -m644 ../other $pkgdir/etc/pam.d/other
# build pam_unix2 module
# source ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2
cd $srcdir/pam_unix2-2.6
./configure
- make || return 1
+ make
make DESTDIR=$pkgdir install
# add the realtime permissions for audio users
sed -i 's|# End of file||' $pkgdir/etc/security/limits.conf
@@ -49,3 +47,6 @@ _EOT
# set unix_chkpwd uid
chmod +s $pkgdir/sbin/unix_chkpwd
}
+md5sums=('6db7fcb5db6253350e3a4648ceac40e7'
+ 'e2788389a6c59224110a45fcff30e02b'
+ '6e6c8719e5989d976a14610f340bd33a')