summaryrefslogtreecommitdiffstats
path: root/abs/core/pango/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/pango/PKGBUILD')
-rw-r--r--abs/core/pango/PKGBUILD45
1 files changed, 22 insertions, 23 deletions
diff --git a/abs/core/pango/PKGBUILD b/abs/core/pango/PKGBUILD
index ab1f03c..39a38a0 100644
--- a/abs/core/pango/PKGBUILD
+++ b/abs/core/pango/PKGBUILD
@@ -1,40 +1,39 @@
-# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=pango
-pkgver=1.38.1
+pkgver=1.42.4
pkgrel=1
+epoch=1
pkgdesc="A library for layout and rendering of text"
-arch=('i686' 'x86_64')
-license=('LGPL')
-depends=('libthai' 'cairo' 'libxft' 'harfbuzz')
-makedepends=('harfbuzz' 'fontconfig' 'cairo' 'libxft' 'libthai' 'gobject-introspection' 'help2man')
-checkdepends=('ttf-dejavu')
-install=pango.install
-source=(http://download.gnome.org/sources/${pkgname}/${pkgver:0:4}/${pkgname}-${pkgver}.tar.xz)
-url="http://www.pango.org/"
-sha256sums=('1320569f6c6d75d6b66172b2d28e59c56ee864ee9df202b76799c4506a214eb7')
+url="https://www.pango.org/"
+arch=(x86_64)
+license=(LGPL)
+depends=(libthai cairo libxft harfbuzz fribidi)
+makedepends=(gobject-introspection help2man gtk-doc git meson)
+checkdepends=(ttf-dejavu cantarell-fonts)
+_commit=a6a89818246b0b14c0fe3d00d6120929fc0a11d9 # tags/1.42.4^0
+source=("git+https://gitlab.gnome.org/GNOME/pango.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
prepare() {
- cd ${pkgname}-${pkgver}
+ cd $pkgname
}
build() {
- cd ${pkgname}-${pkgver}
-
- rm -f pango-view/pango-view.1.in
-
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --with-included-modules=basic-fc
- make
+ arch-meson $pkgname build -D enable_docs=true
+ ninja -C build
}
check() {
- cd ${pkgname}-${pkgver}
- make -k check || :
+ meson test -C build
}
package() {
- cd ${pkgname}-${pkgver}
- make -j1 DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" meson install -C build
+ rm -r "$pkgdir"/usr/{lib,share}/installed-tests
}