summaryrefslogtreecommitdiffstats
path: root/abs/core/parted/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/parted/PKGBUILD')
-rw-r--r--abs/core/parted/PKGBUILD36
1 files changed, 15 insertions, 21 deletions
diff --git a/abs/core/parted/PKGBUILD b/abs/core/parted/PKGBUILD
index 77539f2..4cb5d0b 100644
--- a/abs/core/parted/PKGBUILD
+++ b/abs/core/parted/PKGBUILD
@@ -1,36 +1,30 @@
-# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Aaron Griffin <aaron@archlinux.org>
pkgname=parted
-pkgver=3.2
-pkgrel=6
+pkgver=3.3
+pkgrel=2
pkgdesc="A program for creating, destroying, resizing, checking and copying partitions"
arch=('x86_64')
license=('GPL3')
-url="http://www.gnu.org/software/parted/parted.html"
-depends=('device-mapper')
+url='https://www.gnu.org/software/parted/parted.html'
+depends=('device-mapper' 'util-linux-libs')
makedepends=('pkg-config')
-validpgpkeys=('1B49F933916A37A3F45A1812015F4DD4A70FB705') # Phillip Susi <psusi@ubuntu.com>
-source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig}
- 'parted-735669-fat16-crash-v1.patch')
-sha256sums=('858b589c22297cacdf437f3baff6f04b333087521ab274f7ab677cb8c6bb78e4'
- 'SKIP'
- '3cbf31765b1653609a4c95687b91e34dd57ad3498d5d02019c966bd46d25d100')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- patch -Np1 -i "${srcdir}/parted-735669-fat16-crash-v1.patch"
-}
+validpgpkeys=('1B49F933916A37A3F45A1812015F4DD4A70FB705' # Phillip Susi <psusi@ubuntu.com>
+ 'B4C6B451E4FA8B4232CA191E117E8C168EFE3A7F') # Brian C. Lane <bcl@redhat.com>
+source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig})
+sha256sums=('57e2b4bd87018625c515421d4524f6e3b55175b472302056391c5f7eccb83d44'
+ 'SKIP')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr \
- --sbindir=/usr/bin \
- --disable-debug \
- --disable-rpath
+ # Do *not* add --disable-debug, it prevents building fatresize
+ # https://github.com/ya-mouse/fatresize/issues/9
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --disable-rpath
make
}