summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-capture-tiny/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-capture-tiny/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-capture-tiny/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-capture-tiny/PKGBUILD b/abs/core/perl_modules/perl-capture-tiny/PKGBUILD
new file mode 100644
index 0000000..a0987b3
--- /dev/null
+++ b/abs/core/perl_modules/perl-capture-tiny/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 167936 2012-10-03 22:20:09Z heftig $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Caleb Cushing <xenoterracide@gmail.com>
+
+pkgname=perl-capture-tiny
+_realname=Capture-Tiny
+pkgver=0.20
+pkgrel=1
+pkgdesc="Capture STDOUT and STDERR from Perl, XS or external programs"
+arch=(any)
+license=(PerlArtistic GPL)
+depends=(perl)
+url="http://search.cpan.org/dist/Capture-Tiny"
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/$_realname-$pkgver.tar.gz")
+md5sums=('cd7aab9f3bccefc76c7d4f0455c55d35')
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}