summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-http-negotiate/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-http-negotiate/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-http-negotiate/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-http-negotiate/PKGBUILD b/abs/core/perl_modules/perl-http-negotiate/PKGBUILD
new file mode 100644
index 0000000..850f45a
--- /dev/null
+++ b/abs/core/perl_modules/perl-http-negotiate/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer : Justin "juster" Davis <jrcd83@gmail.com>
+# Generator : pbjam 0.01
+# $Id: PKGBUILD 150643 2012-02-19 01:27:33Z allan $
+
+pkgname=perl-http-negotiate
+pkgver=6.01
+pkgrel=1
+pkgdesc="choose a variant to serve"
+arch=(any)
+license=(PerlArtistic GPL)
+options=('!emptydirs')
+depends=('perl>=5.8.8' 'perl-http-message')
+makedepends=()
+checkdepends=()
+conflicts=('perl-libwww<6')
+url=http://search.cpan.org/dist/HTTP-Negotiate
+source=(http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/HTTP-Negotiate-6.00.tar.gz)
+md5sums=('f2d89957d1c4f62a86f18b08e07c2328')
+sha512sums=('d608fa0a9a0866c5d934561ea1a13844bab0d27d4ac332f5174e19c768e01675c6562d6bc4c4e4a5530c5a83de8b1edefa002ce42534217eba5a6d4edd779e74')
+_distdir="${srcdir}/HTTP-Negotiate-6.00"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ cd "$_distdir"
+ make test
+ )
+}
+
+package() {
+ cd "$_distdir"
+ make DESTDIR="$pkgdir" install
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: