summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-io-tty/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-io-tty/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-io-tty/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-io-tty/PKGBUILD b/abs/core/perl_modules/perl-io-tty/PKGBUILD
new file mode 100644
index 0000000..540af17
--- /dev/null
+++ b/abs/core/perl_modules/perl-io-tty/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 71803 2012-06-02 10:31:14Z bluewind $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Charles Mauch <cmauch@gmail.com>
+
+pkgname=perl-io-tty
+pkgver=1.10
+pkgrel=2
+pkgdesc="Provide an interface to TTYs and PTYs"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/dist/IO-Tty/"
+license=("GPL" "PerlArtistic")
+depends=('glibc')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/IO-Tty-$pkgver.tar.gz")
+md5sums=('46baec86a145e57f0ec661fa412b097c')
+
+build() {
+ cd $srcdir/IO-Tty-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+package(){
+ cd $srcdir/IO-Tty-$pkgver
+ make install DESTDIR=$pkgdir
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}