summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-params-util/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-params-util/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-params-util/PKGBUILD49
1 files changed, 26 insertions, 23 deletions
diff --git a/abs/core/perl_modules/perl-params-util/PKGBUILD b/abs/core/perl_modules/perl-params-util/PKGBUILD
index 415ad58..0b17b67 100644
--- a/abs/core/perl_modules/perl-params-util/PKGBUILD
+++ b/abs/core/perl_modules/perl-params-util/PKGBUILD
@@ -1,43 +1,46 @@
-# Maintainer: Justin Davis (juster) <jrcd83@gmail.com>
-# $Id: PKGBUILD 72466 2012-06-15 00:05:46Z juster $
+# $Id$
+# Maintainer: Jonathan Steel <jsteel at aur.archlinux.org>
+# Contributor: Justin Davis (juster) <jrcd83@gmail.com>
pkgname=perl-params-util
pkgver=1.07
-pkgrel=1
+pkgrel=8
pkgdesc='Simple, compact and correct param-checking functions'
-arch=(i686 x86_64)
-license=(PerlArtistic GPL)
-options=(!emptydirs)
-depends=('perl>=5.5.30')
-url=https://metacpan.org/release/Params-Util
+arch=('x86_64')
+url="https://metacpan.org/release/Params-Util"
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+options=('!emptydirs')
source=("http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Params-Util-$pkgver.tar.gz")
-md5sums=(02db120c0eef87aae1830cc62bdec37b)
-sha512sums=(ff471b01b33414fc5e1c68d97c21171a95d3418c33e3c45f9910cc768898690e35051506a83ad9403a200336654c14b8efc9d471c4b3fe3321047a7603d6fd56)
-_dir="$srcdir/Params-Util-$pkgver"
+sha256sums=('30f1ec3f2cf9ff66ae96f973333f23c5f558915bb6266881eac7423f52d7c76c')
-build()
-(
- cd "$_dir"
+build() {
+ cd "$srcdir/Params-Util-$pkgver"
export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
unset PERL5LIB PERL_MM_OPT
/usr/bin/perl Makefile.PL
make
-)
+}
-check()
-(
- cd "$_dir"
+check() {
+ cd "$srcdir/Params-Util-$pkgver"
export PERL_MM_USE_DEFAULT=1
unset PERL5LIB
make test
-)
+}
-package()
-(
- cd "$_dir"
+package() {
+ cd "$srcdir/Params-Util-$pkgver"
make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
-)
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+ _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+ _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+ depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
+}
# Local Variables:
# mode: shell-script