summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-test-exception/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-test-exception/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-test-exception/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-test-exception/PKGBUILD b/abs/core/perl_modules/perl-test-exception/PKGBUILD
new file mode 100644
index 0000000..ccf2bc6
--- /dev/null
+++ b/abs/core/perl_modules/perl-test-exception/PKGBUILD
@@ -0,0 +1,26 @@
+# This PKGBUILD was autocreated. See http://xtermin.us/archperl/ for details
+# Maintainer: Charles Mauch <cmauch@gmail.com>
+
+pkgname=perl-test-exception
+pkgver=0.31
+pkgrel=1
+pkgdesc="Perl/CPAN Module Test::Exception : Functions for testing exceptionbased code"
+arch=("any")
+url="http://search.cpan.org/~adie/"
+license=("GPL" "Artistic")
+makedepends=("perl-sub-uplevel")
+depends=("perl-sub-uplevel")
+source=("http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/Test-Exception-$pkgver.tar.gz")
+md5sums=('adb57ca7614d15e5b307bf5e024b35a8')
+
+build() {
+ cd $srcdir/Test-Exception-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+package() {
+ cd $srcdir/Test-Exception-$pkgver
+ make install DESTDIR=$pkgdir
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}