summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-text-patch/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-text-patch/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-text-patch/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-text-patch/PKGBUILD b/abs/core/perl_modules/perl-text-patch/PKGBUILD
new file mode 100644
index 0000000..d7751e4
--- /dev/null
+++ b/abs/core/perl_modules/perl-text-patch/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 125357 2011-05-26 06:26:28Z angvp $
+# Maintainer: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: Caleb Cushing <xenoterracide@gmail.com>
+pkgname=perl-text-patch
+_realname=Text-Patch
+pkgver=1.8
+pkgrel=1
+pkgdesc="Patches text with given patch"
+arch=(any)
+license=(PerlArtistic GPL)
+depends=(perl)
+url='http://search.cpan.org/dist/$_realname'
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/C/CA/CADE/$_realname-$pkgver.tar.gz")
+md5sums=('ad5e453d5ba3b48afd8163114d0fee1c')
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}