summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-time-modules/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-time-modules/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-time-modules/PKGBUILD39
1 files changed, 21 insertions, 18 deletions
diff --git a/abs/core/perl_modules/perl-time-modules/PKGBUILD b/abs/core/perl_modules/perl-time-modules/PKGBUILD
index 6911ebc..fd41453 100644
--- a/abs/core/perl_modules/perl-time-modules/PKGBUILD
+++ b/abs/core/perl_modules/perl-time-modules/PKGBUILD
@@ -1,25 +1,28 @@
-# Contributor: Your Name <your_email@foobar.org>
+# $Id: PKGBUILD 62353 2012-01-19 16:06:20Z seblu $
+# Maintainer: Sébastien Luttringer <seblu@aur.archlinux.org>
+# Contributor: Alessandro Sagratini <ale_sagra at hotmail dot com>
+# Contributor: Philippe LUC <philfifi@gmail.com>
+
pkgname=perl-time-modules
-pkgver=2006.0814
+pkgver=2011.0517
pkgrel=1
-pkgdesc="Parses Date strings"
+pkgdesc='Perl time related module'
url="http://search.cpan.org/~muir/Time-modules-$pkgver/"
-depends=(perl)
-license="GPL"
+license=('GPL' 'PerlArtistic')
options=('!emptydirs')
-arch=('i686')
-source=(http://search.cpan.org/CPAN/authors/id/M/MU/MUIR/modules/Time-modules-$pkgver.tar.gz)
-md5sums=('790c6739f601b85654fac9ee516b18d8')
+arch=('any')
+source=("http://search.cpan.org/CPAN/authors/id/M/MU/MUIR/modules/Time-modules-$pkgver.tar.gz")
+md5sums=('67204ebc06211a877665765f91dc4e51')
build() {
- cd $startdir/src/Time-modules-$pkgver
- eval `perl -V:archname`
- /usr/bin/perl Makefile.PL \
- INSTALLARCHLIB=/usr/lib/perl5/current/${archname} \
- INSTALLSITELIB=/usr/lib/perl5/site_perl/current \
- INSTALLSITEARCH=/usr/lib/perl5/site_perl/current/${archname}
- /usr/bin/make || return 1
- /usr/bin/make DESTDIR=$startdir/pkg install
- /usr/bin/find $startdir/pkg -name '.packlist' -exec rm '{}' \;
- /usr/bin/find $startdir/pkg -name '*.pod' -exec rm '{}' \;
+ cd Time-modules-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd Time-modules-$pkgver
+ make install DESTDIR="$pkgdir/"
}
+
+# vim:set ts=2 sw=2 ft=sh et: