summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-variable-magic/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-variable-magic/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-variable-magic/PKGBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-variable-magic/PKGBUILD b/abs/core/perl_modules/perl-variable-magic/PKGBUILD
new file mode 100644
index 0000000..e13315d
--- /dev/null
+++ b/abs/core/perl_modules/perl-variable-magic/PKGBUILD
@@ -0,0 +1,55 @@
+# $Id$
+# Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
+# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Contributor: Justin Davis <jrcd83@gmail.com>
+
+pkgname="perl-variable-magic"
+_cpanname="Variable-Magic"
+pkgver=0.62
+pkgrel=1
+pkgdesc="Associate user-defined magic to variables from Perl."
+arch=("x86_64")
+license=("PerlArtistic" "GPL")
+options=("!emptydirs")
+depends=("perl")
+url="http://search.cpan.org/dist/$_cpanname"
+source=("http://search.cpan.org/CPAN/authors/id/V/VP/VPIT/$_cpanname-$pkgver.tar.gz")
+
+# Function to change to the working directory and set
+# environment variables to override undesired options.
+prepareEnvironment() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ export \
+ PERL_MM_USE_DEFAULT="1" \
+ PERL_AUTOINSTALL="--skipdeps" \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir//\'/\\\'}'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir//\'/\\\'}'" \
+ MODULEBUILDRC="/dev/null"
+}
+sha256sums=('3f9a18517e33f006a9c2fc4f43f01b54abfe6ff2eae7322424f31069296b615c')
+
+build() {
+ prepareEnvironment
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepareEnvironment
+ make test
+}
+
+package() {
+ prepareEnvironment
+ make install
+
+ # Remove "perllocal.pod" and ".packlist".
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+ _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+ _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+ depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
+}