summaryrefslogtreecommitdiffstats
path: root/abs/core/php/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/php/PKGBUILD')
-rw-r--r--abs/core/php/PKGBUILD81
1 files changed, 35 insertions, 46 deletions
diff --git a/abs/core/php/PKGBUILD b/abs/core/php/PKGBUILD
index 7ba2398..fc39bef 100644
--- a/abs/core/php/PKGBUILD
+++ b/abs/core/php/PKGBUILD
@@ -23,19 +23,18 @@ pkgname=('php'
'php-sqlite'
'php-tidy'
'php-xsl')
-pkgver=5.6.17
+pkgver=5.6.26
pkgrel=1
arch=('i686' 'x86_64')
license=('PHP')
url='http://www.php.net'
makedepends=('apache' 'c-client' 'postgresql-libs' 'libldap' 'postfix'
'sqlite' 'unixodbc' 'net-snmp' 'libzip' 'enchant' 'file' 'freetds'
- 'libmcrypt' 'tidyhtml' 'aspell' 'libltdl' 'gd' 'icu'
+ 'libmcrypt' 'tidy' 'aspell' 'libltdl' 'gd' 'icu'
'curl' 'libxslt' 'openssl' 'db' 'gmp' 'systemd')
-checkdepends=('procps-ng')
source=("http://www.php.net/distributions/${pkgbase}-${pkgver}.tar.xz"
"http://www.php.net/distributions/${pkgbase}-${pkgver}.tar.xz.asc"
- 'php.ini.patch' 'apache.conf' 'php-fpm.conf.in.patch'
+ 'php.ini.patch' 'linhes.ini' 'apache.conf' 'php-fpm.conf.in.patch'
'logrotate.d.php-fpm' 'php-fpm.service' 'php-fpm.tmpfiles')
validpgpkeys=('6E4F6AB321FDC07F2C332E3AC2BF0BC433CFC8B3'
'0BD78B5F97500D450838F95DFE857D9A90D90EC1')
@@ -48,20 +47,25 @@ prepare() {
# Just because our Apache 2.4 is configured with a threaded MPM by default does not mean we want to build a ZTS PHP.
# Let's supress this behaviour and build a SAPI that works fine with the prefork MPM.
sed '/APACHE_THREADED_MPM=/d' -i sapi/apache2handler/config.m4 -i configure
+
+ # Allow php-tidy to compile with tidy-html5
+ sed 's/buffio\.h/tidybuffio\.h/' -i ext/tidy/tidy.c
}
build() {
local _phpconfig="--srcdir=../${pkgbase}-${pkgver} \
--config-cache \
--prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc/php \
+ --sysconfdir=/etc/${pkgbase} \
--localstatedir=/var \
+ --libdir=/usr/lib/${pkgbase} \
+ --datarootdir=/usr/share/${pkgbase} \
+ --datadir=/usr/share/${pkgbase} \
+ --program-suffix=${pkgbase#php} \
--with-layout=GNU \
- --with-config-file-path=/etc/php \
- --with-config-file-scan-dir=/etc/php/conf.d \
+ --with-config-file-path=/etc/${pkgbase} \
+ --with-config-file-scan-dir=/etc/${pkgbase}/conf.d \
--disable-rpath \
- --mandir=/usr/share/man \
--without-pear \
"
@@ -100,7 +104,7 @@ build() {
--with-imap=shared \
--with-kerberos=/usr \
--with-jpeg-dir=/usr \
- --with-vpx-dir=/usr \
+ --with-vpx-dir=no \
--with-ldap=shared \
--with-ldap-sasl \
--with-libzip \
@@ -112,6 +116,7 @@ build() {
--with-mysqli=shared,mysqlnd \
--with-openssl=shared \
--with-pcre-regex=/usr \
+ --with-pdo-dblib=shared,/usr \
--with-pdo-mysql=shared,mysqlnd \
--with-pdo-odbc=shared,unixODBC,/usr \
--with-pdo-pgsql=shared \
@@ -128,17 +133,15 @@ build() {
--with-zlib \
"
- EXTENSION_DIR=/usr/lib/php/modules
- export EXTENSION_DIR
- PEAR_INSTALLDIR=/usr/share/pear
- export PEAR_INSTALLDIR
+ export EXTENSION_DIR=/usr/lib/${pkgbase}/modules
+ export PEAR_INSTALLDIR=/usr/share/${pkgbase}/pear
cd ${srcdir}/${pkgbase}-${pkgver}
# php
- mkdir ${srcdir}/build-php
+ mkdir -p ${srcdir}/build-php
cd ${srcdir}/build-php
- ln -s ../${pkgbase}-${pkgver}/configure
+ ln -sf ../${pkgbase}-${pkgver}/configure
./configure ${_phpconfig} \
--disable-cgi \
--with-readline \
@@ -148,7 +151,7 @@ build() {
# cgi and fcgi
# reuse the previous run; this will save us a lot of time
- cp -a ${srcdir}/build-php ${srcdir}/build-cgi
+ cp -Ta ${srcdir}/build-php ${srcdir}/build-cgi
cd ${srcdir}/build-cgi
./configure ${_phpconfig} \
--disable-cli \
@@ -157,7 +160,7 @@ build() {
make
# apache
- cp -a ${srcdir}/build-php ${srcdir}/build-apache
+ cp -Ta ${srcdir}/build-php ${srcdir}/build-apache
cd ${srcdir}/build-apache
./configure ${_phpconfig} \
--disable-cli \
@@ -166,7 +169,7 @@ build() {
make
# fpm
- cp -a ${srcdir}/build-php ${srcdir}/build-fpm
+ cp -Ta ${srcdir}/build-php ${srcdir}/build-fpm
cd ${srcdir}/build-fpm
./configure ${_phpconfig} \
--disable-cli \
@@ -177,7 +180,7 @@ build() {
make
# embed
- cp -a ${srcdir}/build-php ${srcdir}/build-embed
+ cp -Ta ${srcdir}/build-php ${srcdir}/build-embed
cd ${srcdir}/build-embed
./configure ${_phpconfig} \
--disable-cli \
@@ -186,7 +189,7 @@ build() {
make
# phpdbg
- cp -a ${srcdir}/build-php ${srcdir}/build-phpdbg
+ cp -Ta ${srcdir}/build-php ${srcdir}/build-phpdbg
cd ${srcdir}/build-phpdbg
./configure ${_phpconfig} \
--disable-cli \
@@ -197,7 +200,8 @@ build() {
make
# pear
- cp -a ${srcdir}/build-php ${srcdir}/build-pear
+ sed -i 's#@$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d#@$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -p $(bindir)/php$(program_suffix) -d#' ${srcdir}/php-${pkgver}/pear/Makefile.frag
+ cp -Ta ${srcdir}/build-php ${srcdir}/build-pear
cd ${srcdir}/build-pear
./configure ${_phpconfig} \
--disable-cgi \
@@ -208,24 +212,6 @@ build() {
make
}
-check() {
- # tests on i686 fail
- [[ $CARCH == 'i686' ]] && return
-
- cd ${srcdir}/build-php
-
- export REPORT_EXIT_STATUS=1
- export NO_INTERACTION=1
- export SKIP_ONLINE_TESTS=1
- export SKIP_SLOW_TESTS=1
-
- sapi/cli/php -n \
- ${srcdir}/${pkgbase}-${pkgver}/run-tests.php -n -P \
- ${srcdir}/${pkgbase}-${pkgver}/{Zend,ext/{date,pcre,spl,standard},sapi/cli}
-
- echo
-}
-
package_php() {
pkgdesc='An HTML-embedded scripting language'
depends=('pcre' 'libxml2' 'curl' 'libzip' 'php-gd' 'php-mcrypt')
@@ -234,19 +220,20 @@ package_php() {
cd ${srcdir}/build-php
make -j1 INSTALL_ROOT=${pkgdir} install
- install -d -m755 ${pkgdir}/usr/share/pear
+
# install php.ini
install -D -m644 ${srcdir}/${pkgbase}-${pkgver}/php.ini-production ${pkgdir}/etc/php/php.ini
install -d -m755 ${pkgdir}/etc/php/conf.d/
+ install -D -m644 ${srcdir}/linhes.ini ${pkgdir}/etc/php/conf.d/linhes.ini
# remove static modules
rm -f ${pkgdir}/usr/lib/php/modules/*.a
# remove modules provided by sub packages
rm -f ${pkgdir}/usr/lib/php/modules/{enchant,gd,imap,intl,ldap,mcrypt,mssql,odbc,pdo_odbc,pgsql,pdo_pgsql,pspell,snmp,sqlite3,pdo_sqlite,tidy,xsl}.so
+
# remove empty directory
rmdir ${pkgdir}/usr/include/php/include
- # fix broken link
- ln -sf phar.phar ${pkgdir}/usr/bin/phar
+
}
package_php-cgi() {
@@ -260,6 +247,7 @@ package_php-apache() {
pkgdesc='Apache SAPI for PHP'
depends=('php' 'apache')
backup=('etc/httpd/conf/extra/php5_module.conf')
+ install='php-apache.install'
install -D -m755 ${srcdir}/build-apache/libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so
install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf
@@ -394,7 +382,7 @@ package_php-sqlite() {
package_php-tidy() {
pkgdesc='tidy module for PHP'
- depends=('php' 'tidyhtml')
+ depends=('php' 'tidy')
install -D -m755 ${srcdir}/build-php/modules/tidy.so ${pkgdir}/usr/lib/php/modules/tidy.so
}
@@ -405,9 +393,10 @@ package_php-xsl() {
install -D -m755 ${srcdir}/build-php/modules/xsl.so ${pkgdir}/usr/lib/php/modules/xsl.so
}
-md5sums=('5e080e4b7df5db24f1b64313f8114bd8'
+md5sums=('c51e9115263b4d63ef8f68935cefd7d4'
'SKIP'
- '943f882a55c0a6a7b3e5616c7dbbd7a8'
+ 'd425c0a09f7b46814e2695471b38c529'
+ '4ecf586ef1597aa5eb977573954b5d21'
'dec2cbaad64e3abf4f0ec70e1de4e8e9'
'16b5e2e4da59f15bea4c2db78a7bc8dc'
'25bc67ad828e8147a817410b68d8016c'