summaryrefslogtreecommitdiffstats
path: root/abs/core/pkcs11-helper/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/pkcs11-helper/PKGBUILD')
-rw-r--r--abs/core/pkcs11-helper/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/core/pkcs11-helper/PKGBUILD b/abs/core/pkcs11-helper/PKGBUILD
new file mode 100644
index 0000000..8356766
--- /dev/null
+++ b/abs/core/pkcs11-helper/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer:
+# Contributor: Stanislaw Datskevich <me a nek0 net>
+# Contributor: Gregor Robinson <gregor@fiatflux.co.uk>
+# Contributor: Martin Perner <martin dot perner at gmail dot com>
+
+pkgname=pkcs11-helper
+pkgver=1.25.1
+pkgrel=1
+pkgdesc="A library that simplifies the interaction with PKCS11 providers for end-user applications using a simple API and optional OpenSSL engine"
+arch=('x86_64')
+url='https://github.com/OpenSC/pkcs11-helper'
+license=(GPL BSD)
+depends=('gnutls' 'nss' 'openssl')
+source=("https://github.com/OpenSC/${pkgname}/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('10dd8a1dbcf41ece051fdc3e9642b8c8111fe2c524cb966c0870ef3413c75a77')
+
+build() {
+ cd pkcs11-helper-$pkgver
+ libtoolize
+ aclocal
+ autoheader
+ automake --add-missing
+ autoreconf -v
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd pkcs11-helper-$pkgver
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname/
+ install -D -m0644 COPYING* "$pkgdir"/usr/share/licenses/$pkgname/
+}
+