summaryrefslogtreecommitdiffstats
path: root/abs/core/pkg-config
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/pkg-config')
-rw-r--r--abs/core/pkg-config/PKGBUILD32
-rw-r--r--abs/core/pkg-config/autoconf-2.66.patch12
2 files changed, 44 insertions, 0 deletions
diff --git a/abs/core/pkg-config/PKGBUILD b/abs/core/pkg-config/PKGBUILD
new file mode 100644
index 0000000..9c671df
--- /dev/null
+++ b/abs/core/pkg-config/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 85540 2010-07-15 04:44:14Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Committer: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=pkg-config
+pkgver=0.25
+pkgrel=2
+pkgdesc="A system for managing library compile/link flags"
+arch=('i686' 'x86_64')
+url="http://pkgconfig.freedesktop.org/wiki/"
+license=('GPL')
+groups=('base-devel')
+depends=('glibc')
+provides=("pkgconfig=${pkgver}")
+conflicts=('pkgconfig')
+replaces=('pkgconfig')
+source=(http://pkgconfig.freedesktop.org/releases/${pkgname}-${pkgver}.tar.gz
+ autoconf-2.66.patch)
+md5sums=('a3270bab3f4b69b7dc6dbdacbcae9745'
+ '0fbfc1a5088f792bbeec7b5090e449f1')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np1 -i $srcdir/autoconf-2.66.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/abs/core/pkg-config/autoconf-2.66.patch b/abs/core/pkg-config/autoconf-2.66.patch
new file mode 100644
index 0000000..14cabdf
--- /dev/null
+++ b/abs/core/pkg-config/autoconf-2.66.patch
@@ -0,0 +1,12 @@
+diff -Naur pkg-config-0.25-old//pkg.m4 pkg-config-0.25/pkg.m4
+--- pkg-config-0.25-old//pkg.m4 2009-12-07 06:39:02.000000000 +1000
++++ pkg-config-0.25/pkg.m4 2010-07-15 14:44:37.466942978 +1000
+@@ -135,7 +135,7 @@
+ Consider adjusting the PKG_CONFIG_PATH environment variable if you
+ installed software in a non-standard prefix.
+
+-_PKG_TEXT])dnl
++_PKG_TEXT])[]dnl
+ ])
+ elif test $pkg_failed = untried; then
+ AC_MSG_RESULT([no])