summaryrefslogtreecommitdiffstats
path: root/abs/core/plymouth
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/plymouth')
-rw-r--r--abs/core/plymouth/PKGBUILD168
-rw-r--r--abs/core/plymouth/__changelog4
-rw-r--r--abs/core/plymouth/encrypt_hook13
-rw-r--r--abs/core/plymouth/encrypt_hook.patch19
-rw-r--r--abs/core/plymouth/encrypt_install5
-rw-r--r--abs/core/plymouth/encrypt_install.patch15
-rw-r--r--abs/core/plymouth/plymouth-0.8.8.tar.bz2bin1143549 -> 0 bytes
-rw-r--r--abs/core/plymouth/plymouth-pid.patch33
-rw-r--r--abs/core/plymouth/plymouth-update-initrd.patch12
-rw-r--r--abs/core/plymouth/plymouth.functions9
-rw-r--r--abs/core/plymouth/plymouth.initcpio_install6
-rw-r--r--abs/core/plymouth/plymouth.install49
-rw-r--r--abs/core/plymouth/slim-plymouth.service13
-rw-r--r--abs/core/plymouth/systemd-unit-dir.patch11
-rw-r--r--abs/core/plymouth/udevadm.patch11
15 files changed, 143 insertions, 225 deletions
diff --git a/abs/core/plymouth/PKGBUILD b/abs/core/plymouth/PKGBUILD
index 34c40c5..6126d4f 100644
--- a/abs/core/plymouth/PKGBUILD
+++ b/abs/core/plymouth/PKGBUILD
@@ -1,130 +1,118 @@
-# Maintainer: M0Rf30 <morfeo89@hotmail.it>
-# Contributor: PirateJonno <j@skurvy.no-ip.org>
-# Contributor: Det <nimetonmaili at gmail dot com>
-# Contributor: Biginoz <biginoz _at_ free _point_ fr>
-# Based on plymouth-git: http://aur.archlinux.org/packages.php?ID=26117
-
pkgname=plymouth
-pkgver=0.8.8
-pkgrel=3
-pkgdesc="A graphical boot splash screen with kernel mode-setting support"
+pkgver=0.8.8.52.g37d2e40
+pkgrel=4
+pkgdesc="A graphical boot splash screen with kernel mode-setting support (Git version)"
+url="http://cgit.freedesktop.org/cgit/plymouth/"
arch=('i686' 'x86_64')
-url="http://freedesktop.org/wiki/Software/Plymouth"
license=('GPL')
-depends=('libdrm' 'pango' 'gtk2')
+depends=('libdrm' 'pango' 'v86d')
+makedepends=('git' 'docbook-xsl')
+optdepends=('ttf-dejavu')
options=('!libtool' '!emptydirs')
-install=${pkgname}.install
-backup=('etc/plymouth/plymouthd.conf')
+install=$pkgname.install
+groups=('base')
provides=('plymouth')
-conflicts=('plymouth-git')
-source=("http://www.freedesktop.org/software/$pkgname/releases/$pkgname-$pkgver.tar.bz2"
- 'arch-logo.png'
- "http://projects.archlinux.org/svntogit/packages.git/plain/cryptsetup/repos/core-i686/encrypt_hook"
- 'encrypt_hook.patch'
- "http://projects.archlinux.org/svntogit/packages.git/plain/cryptsetup/repos/core-i686/encrypt_install"
- 'encrypt_install.patch'
+conflicts=('plymouth')
+backup=('etc/plymouth/plymouthd.conf')
+
+source=('git://anongit.freedesktop.org/plymouth'
+ 'arch-logo.png'
+ 'encrypt_hook'
+ 'encrypt_install'
'gdm-plymouth.service'
'kdm-plymouth.service'
'kdm-unpatched-plymouth.service'
- 'lightdm-plymouth.service'
'lxdm-plymouth.service'
+ 'lightdm-plymouth.service'
+ 'slim-plymouth.service'
'plymouth.functions'
+ "$pkgname.install"
'plymouth.initcpio_hook'
'plymouth.initcpio_install'
- 'plymouth-pid.patch'
'plymouth-quit.service'
'plymouth-set-default-theme.in.patch'
'plymouth-update-initrd.patch'
'plymouthd.conf'
- 'system-release'
- 'systemd-unit-dir.patch'
- 'udevadm.patch'
-)
+ 'system-release')
+
+pkgver() {
+ cd "$srcdir"/${pkgname%%-*}
+ git describe --always | sed 's/-/./g'
+}
+prepare() {
+ cd "$srcdir"/${pkgname%%-*}
+
+ patch -Np0 -i ../plymouth-set-default-theme.in.patch
+ patch -Np0 -i ../plymouth-update-initrd.patch
+
+ sed -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:g' \
+ -i src/libply-splash-graphics/ply-image.c
+
+ test -f Makefile && make distclean
+
+ return 0
+}
build() {
-
- cd $srcdir
- msg "Applying Patches..."
-
- msg2 "Fixing encrypt HOOK"
- #patch -p0 -i encrypt_hook.patch --follow-symlinks
- #patch -p0 -i encrypt_install.patch --follow-symlinks
-
-
- cd $srcdir/$pkgname-$pkgver
- msg2 "Setting a human-readable error for '# plymouth-set-default-theme -R'"
- patch -p0 -i ../plymouth-set-default-theme.in.patch
-
- msg2 "Fixing updating initrd"
- patch -p0 -i ../plymouth-update-initrd.patch
-
- msg2 "Changing PID file to /run/plymouth.pid"
- patch -p1 -i ../plymouth-pid.patch
-
- msg2 "Changing udevadm path"
- patch -p1 -i ../udevadm.patch
-
- msg2 "Changing SYSTEMD_UNIT_DIR to /usr/lib/systemd/system/"
- patch -p0 -i ../systemd-unit-dir.patch
-
- sed -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:g' \
- -i src/libply-splash-graphics/ply-image.c
-
- msg "Starting make..."
-
- ./configure --prefix=/usr --exec-prefix=/usr --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib --libexecdir=/usr/lib \
- --enable-tracing \
- --without-rhgb-compat-link \
- --with-gdm-autostart-file=yes \
- --with-logo=/usr/share/plymouth/arch-logo.png \
- --with-background-start-color-stop=0x000000 \
- --with-background-end-color-stop=0x4D4D4D \
- --enable-systemd-integration \
- --without-system-root-install
-
- make
+ cd "$srcdir"/${pkgname%%-*}
+
+ ./autogen.sh --prefix=/usr \
+ --exec-prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --sbindir=/usr/bin \
+ --enable-drm-renderer \
+ --enable-tracing \
+ --enable-pango \
+ --with-gdm-autostart-file=yes \
+ --with-logo=/usr/share/plymouth/arch-logo.png \
+ --with-background-start-color-stop=0x000000 \
+ --with-background-end-color-stop=0x4D4D4D \
+ --without-rhgb-compat-link \
+ --without-system-root-install
+
+ make
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd "$srcdir"/${pkgname%%-*}
make DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir/arch-logo.png" "$pkgdir/usr/share/plymouth/arch-logo.png"
- install -Dm644 ../../encrypt_hook "$pkgdir/usr/lib/initcpio/hooks/plymouth-encrypt"
- install -Dm644 ../../encrypt_install "$pkgdir/usr/lib/initcpio/install/plymouth-encrypt"
- install -Dm644 "$srcdir/plymouth.functions" "$pkgdir/etc/rc.d/functions.d/plymouth.functions"
- install -Dm644 "$srcdir/plymouth.initcpio_hook" "$pkgdir/usr/lib/initcpio/hooks/plymouth"
+ install -Dm644 "$srcdir/arch-logo.png" "$pkgdir/usr/share/plymouth/arch-logo.png"
+ install -Dm644 "$srcdir/encrypt_hook" "$pkgdir/usr/lib/initcpio/hooks/plymouth-encrypt"
+ install -Dm644 "$srcdir/encrypt_install" "$pkgdir/usr/lib/initcpio/install/plymouth-encrypt"
+ install -Dm644 "$srcdir/plymouth.functions" "$pkgdir/etc/rc.d/functions.d/plymouth.functions"
+ install -Dm644 "$srcdir/plymouth.initcpio_hook" "$pkgdir/usr/lib/initcpio/hooks/plymouth"
install -Dm644 "$srcdir/plymouth.initcpio_install" "$pkgdir/usr/lib/initcpio/install/plymouth"
- install -Dm644 "$srcdir/plymouthd.conf" "$pkgdir/etc/plymouth/plymouthd.conf"
- install -Dm644 "$srcdir/system-release" "$pkgdir/etc/system-release"
+ install -Dm644 "$srcdir/plymouthd.conf" "$pkgdir/etc/plymouth/plymouthd.conf"
+ install -Dm644 "$srcdir/system-release" "$pkgdir/etc/system-release"
# Plymouth<->systemd integration, including units for DMs
- for i in {{gdm,kdm{,-unpatched},lightdm,lxdm}-plymouth,plymouth-quit}.service; do
+ for i in {{gdm,kdm{,-unpatched},lxdm,slim,lightdm}-plymouth,plymouth-quit}.service; do
install -Dm644 "$srcdir/$i" "$pkgdir/usr/lib/systemd/system/$i"
done
+
}
-
-md5sums=('38f5e613e5ab17806b950cee2d0d0d4e'
+md5sums=('SKIP'
'65fa2763d5c9bb9f80973ea5e6e3db3e'
- 'c970831d733ca42e20415005967e7843'
- '59f703eafd1aee4ca5782a523d412a46'
- '21c45f9cab3e0b5165f68358884fbd0f'
- 'cdee5ae4c4087181e80fe14061b7d604'
+ '79613b70a0a0be4c33978ef37c30f00a'
+ '65eb269910f1b81e3f0970af456394ca'
'34d0ed7bbcb3d0ea498de24bc17b2ee9'
'75ec0ac73eb9a1e3f6104df64520d431'
'ceec65ce58accdb270f3eaa23d794b4a'
- 'e6d573b1913f3aa020cbde3863ee80f0'
'62c3b4e894330a2ca4c2b8fbcaba083c'
- 'a1763999bc3282771e712765c9427d77'
+ 'e6d573b1913f3aa020cbde3863ee80f0'
+ '225b953976e1c824f62ba406a63c18c7'
+ 'f0110fba1e77cd22c32d1727399d0b8a'
+ '95e987cfbc2d30a2cea215394eb9ac20'
'4f3be343eea9956bbc94d615d5f41def'
- 'e606ce14ceace727c2f13758e371a4ed'
- '761f5090dc999e50b4572138347c775b'
+ '7f21ba9a85733ff945c23012cff55a89'
'3bb0b8008edfad9e23703674341766a0'
'42fddd683720dbacbe6e30b4b7892f3c'
- 'c2a0cf5a499d6c14723461166a24ede7'
+ '412a1a89ca960370071746b0af8c0ac5'
'37479b134827dc307b3c55bfb2711e99'
- 'ab8a557d10f74bec5c94ed6cae34729c'
- '30acbfc7722fb62ee464b8fec32b5cfd'
- '89014b04513d61e0085e7a0c9924c183')
+ 'ab8a557d10f74bec5c94ed6cae34729c')
diff --git a/abs/core/plymouth/__changelog b/abs/core/plymouth/__changelog
index 21edf18..6b8e8c1 100644
--- a/abs/core/plymouth/__changelog
+++ b/abs/core/plymouth/__changelog
@@ -1,2 +1,4 @@
+pulled from AUR plymouth-git 12/3/13
removed systemd as a dep
-
+removed --enable-systemd configure option
+add v86d as dep
diff --git a/abs/core/plymouth/encrypt_hook b/abs/core/plymouth/encrypt_hook
index 11db344..a3dcda1 100644
--- a/abs/core/plymouth/encrypt_hook
+++ b/abs/core/plymouth/encrypt_hook
@@ -1,4 +1,4 @@
-#!/usr/bin/ash
+#!/bin/bash
run_hook() {
modprobe -a -q dm-crypt >/dev/null 2>&1
@@ -74,13 +74,10 @@ EOF
fi
# Ask for a passphrase
if [ ${dopassphrase} -gt 0 ]; then
- echo ""
+ echo
echo "A password is required to access the ${cryptname} volume:"
-
- #loop until we get a real password
- while ! eval cryptsetup luksOpen ${resolved} ${cryptname} ${cryptargs} ${CSQUIET}; do
- sleep 2;
- done
+ plymouth ask-for-password --prompt="Password for ${cryptname} volume" --dont-pause-progress --number-of-tries=5 --command="/sbin/cryptsetup luksOpen --key-file=- ${cryptdev} ${cryptname} ${CSQUIET}"
+ sleep 2
fi
if [ -e "/dev/mapper/${cryptname}" ]; then
if [ ${DEPRECATED_CRYPT} -eq 1 ]; then
@@ -135,5 +132,3 @@ EOF
fi
rm -f ${ckeyfile}
}
-
-# vim: set ft=sh ts=4 sw=4 et:
diff --git a/abs/core/plymouth/encrypt_hook.patch b/abs/core/plymouth/encrypt_hook.patch
deleted file mode 100644
index a00a160..0000000
--- a/abs/core/plymouth/encrypt_hook.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- encrypt_hooka 2012-07-15 11:17:04.000000000 +0300
-+++ encrypt_hook 2012-07-15 11:32:59.258648852 +0300
-@@ -73,13 +73,10 @@
- fi
- # Ask for a passphrase
- if [ ${dopassphrase} -gt 0 ]; then
-- echo ""
-+ echo
- echo "A password is required to access the ${cryptname} volume:"
--
-- #loop until we get a real password
-- while ! eval cryptsetup luksOpen ${resolved} ${cryptname} ${cryptargs} ${CSQUIET}; do
-- sleep 2;
-- done
-+ plymouth ask-for-password --prompt="Password for ${cryptname} volume" --dont-pause-progress --number-of-tries=5 --command="/sbin/cryptsetup luksOpen --key-file=- ${cryptdev} ${cryptname} ${CSQUIET}"
-+ sleep 2
- fi
- if [ -e "/dev/mapper/${cryptname}" ]; then
- if [ ${DEPRECATED_CRYPT} -eq 1 ]; then
diff --git a/abs/core/plymouth/encrypt_install b/abs/core/plymouth/encrypt_install
index 38e5ddc..5258a0b 100644
--- a/abs/core/plymouth/encrypt_install
+++ b/abs/core/plymouth/encrypt_install
@@ -18,6 +18,11 @@ build() {
add_file "/usr/lib/udev/rules.d/13-dm-disk.rules"
add_file "/usr/lib/udev/rules.d/95-dm-notify.rules"
add_file "/usr/lib/initcpio/udev/11-dm-initramfs.rules" "/usr/lib/udev/rules.d/11-dm-initramfs.rules"
+ add_binary "/usr/lib/plymouth/label.so"
+ add_binary "/usr/lib/plymouth/text.so"
+ add_file "/usr/share/fonts/TTF/DejaVuSans.ttf"
+ add_file "/etc/fonts/fonts.conf"
+ add_file "/etc/fonts/conf.d/60-latin.conf"
add_runscript
}
diff --git a/abs/core/plymouth/encrypt_install.patch b/abs/core/plymouth/encrypt_install.patch
deleted file mode 100644
index d3a42b9..0000000
--- a/abs/core/plymouth/encrypt_install.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- encrypt_install 2012-07-15 11:45:14.644764564 +0300
-+++ encrypt_installnew 2012-07-15 11:46:29.239269291 +0300
-@@ -18,6 +18,12 @@
- add_file "/usr/lib/udev/rules.d/13-dm-disk.rules"
- add_file "/usr/lib/udev/rules.d/95-dm-notify.rules"
- add_file "/usr/lib/initcpio/udev/11-dm-initramfs.rules" "/usr/lib/udev/rules.d/11-dm-initramfs.rules"
-+ add_binary "/usr/lib/plymouth/label.so"
-+ add_binary "/usr/lib/plymouth/text.so"
-+ add_file "/usr/share/fonts/TTF/DejaVuSans.ttf"
-+ add_file "/etc/fonts/fonts.conf"
-+ add_file "/etc/fonts/conf.d/60-latin.conf"
-+ add_file "/usr/lib/pango/1.6.0/modules/pango-basic-x.so"
-
- add_runscript
- }
diff --git a/abs/core/plymouth/plymouth-0.8.8.tar.bz2 b/abs/core/plymouth/plymouth-0.8.8.tar.bz2
deleted file mode 100644
index bf8c051..0000000
--- a/abs/core/plymouth/plymouth-0.8.8.tar.bz2
+++ /dev/null
Binary files differ
diff --git a/abs/core/plymouth/plymouth-pid.patch b/abs/core/plymouth/plymouth-pid.patch
deleted file mode 100644
index 3f141b0..0000000
--- a/abs/core/plymouth/plymouth-pid.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/systemd-units/systemd-ask-password-plymouth.service.in 2012-09-26 18:50:53.000000000 +0200
-+++ b/systemd-units/systemd-ask-password-plymouth.service.in 2012-10-28 23:12:04.295327564 +0100
-@@ -6,7 +6,7 @@
- After=plymouth-start.service
- Before=shutdown.target
- ConditionKernelCommandLine=!plymouth.enable=0
--ConditionPathExists=/run/plymouth/pid
-+ConditionPathExists=/run/plymouth.pid
-
- [Service]
- ExecStart=/bin/systemd-tty-ask-password-agent --watch --plymouth
---- a/systemd-units/systemd-ask-password-plymouth.path.in 2012-09-26 18:50:53.000000000 +0200
-+++ b/systemd-units/systemd-ask-password-plymouth.path.in 2012-10-28 23:11:54.348555717 +0100
-@@ -6,7 +6,7 @@
- After=plymouth-start.service
- Before=basic.target shutdown.target
- ConditionKernelCommandLine=!plymouth.enable=0
--ConditionPathExists=/run/plymouth/pid
-+ConditionPathExists=/run/plymouth.pid
-
- [Path]
- DirectoryNotEmpty=/run/systemd/ask-password
---- a/systemd-units/plymouth-start.service.in 2012-09-26 18:50:53.000000000 +0200
-+++ b/systemd-units/plymouth-start.service.in 2012-10-28 23:11:35.731982414 +0100
-@@ -7,7 +7,7 @@
- ConditionKernelCommandLine=!plymouth.enable=0
-
- [Service]
--ExecStart=@PLYMOUTH_DAEMON_DIR@/plymouthd --mode=boot --pid-file=@plymouthruntimedir@/pid --attach-to-session
-+ExecStart=@PLYMOUTH_DAEMON_DIR@/plymouthd --mode=boot --pid-file=/run/plymouth.pid --attach-to-session
- ExecStartPost=-/bin/udevadm settle --timeout=30 --exit-if-exists=/sys/class/drm/card0/dev ; /bin/udevadm settle --timeout=30 --exit-if-exists=/sys/class/graphics/fb0/dev ; @PLYMOUTH_CLIENT_DIR@/plymouth show-splash
- Type=forking
- KillMode=none
diff --git a/abs/core/plymouth/plymouth-update-initrd.patch b/abs/core/plymouth/plymouth-update-initrd.patch
index 648c874..c307199 100644
--- a/abs/core/plymouth/plymouth-update-initrd.patch
+++ b/abs/core/plymouth/plymouth-update-initrd.patch
@@ -1,8 +1,8 @@
---- scripts/plymouth-update-initrd.old
-+++ scripts/plymouth-update-initrd
+--- scripts/plymouth-update-initrd.old 2013-10-27 17:02:15.200368142 +0900
++++ scripts/plymouth-update-initrd 2013-10-27 17:02:57.686768138 +0900
@@ -1,2 +1,4 @@
- #!/bin/bash
--mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r)
-+find /etc/mkinitcpio.d/ -name \*.preset -a \! -name example.preset | while read p; do
-+ mkinitcpio -p $p
+#!/bin/bash
+-dracut -f /boot/initramfs-$(uname -r).img $(uname -r)
++find /etc/mkinitcpio.d/ -name \*.preset -a \! -name example.preset | while read p; do
++ mkinitcpio -p $p
+done
diff --git a/abs/core/plymouth/plymouth.functions b/abs/core/plymouth/plymouth.functions
index cfaa19b..b866643 100644
--- a/abs/core/plymouth/plymouth.functions
+++ b/abs/core/plymouth/plymouth.functions
@@ -1,4 +1,3 @@
-#!/bin/bash
if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
ply_client() { /usr/bin/plymouth --ping && /usr/bin/plymouth "$@"; }
@@ -21,8 +20,7 @@ if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
}
stat_fail() {
- #JM remove client quitting
- #ply_client --quit
+ ply_client --quit
std_stat_fail "$@"
}
@@ -41,7 +39,7 @@ if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
ply_quit_boot
[[ $(ps h $(cat /tmp/plymouthd)) ]] && kill -9 $(cat /tmp/plymouthd)
}
-# JM add_hook shutdown_poweroff ply_quit_shutdown
+ add_hook shutdown_poweroff ply_quit_shutdown
# start plymouth at the beginning of rc.shutdown
ply_shutdown_start(){
@@ -61,8 +59,7 @@ if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
# don't get killed by kill_all
add_omit_pids `cat /tmp/plymouthd`
}
-#remove shutdown hook so plymouth doesn't start
-#JM add_hook shutdown_start ply_shutdown_start
+ add_hook shutdown_start ply_shutdown_start
fi
# vim: set ts=2 sw=2 ft=sh noet:
diff --git a/abs/core/plymouth/plymouth.initcpio_install b/abs/core/plymouth/plymouth.initcpio_install
index 16048f1..22cc298 100644
--- a/abs/core/plymouth/plymouth.initcpio_install
+++ b/abs/core/plymouth/plymouth.initcpio_install
@@ -4,11 +4,11 @@ build() {
DATADIR="/usr/share"
PLYMOUTH_LOGO_FILE="${DATADIR}/plymouth/arch-logo.png"
- PLYMOUTH_THEME_NAME="$(/usr/sbin/plymouth-set-default-theme)"
+ PLYMOUTH_THEME_NAME="$(/usr/bin/plymouth-set-default-theme)"
PLYMOUTH_MODULE_NAME="$(grep "ModuleName *= *" ${DATADIR}/plymouth/themes/${PLYMOUTH_THEME_NAME}/${PLYMOUTH_THEME_NAME}.plymouth | sed 's/ModuleName *= *//')"
PLYMOUTH_PLUGIN_PATH="$(plymouth --get-splash-plugin-path)"
- add_binary /usr/sbin/plymouthd
+ add_binary /usr/bin/plymouthd
add_binary /usr/bin/plymouth
add_file ${DATADIR}/plymouth/themes/text/text.plymouth
@@ -47,7 +47,7 @@ build() {
add_binary "$(readlink -e /lib/libnss_files.so.2)"
add_file /lib/libnss_files.so.2
- SCRIPT='plymouth'
+ add_runscript
}
help() {
diff --git a/abs/core/plymouth/plymouth.install b/abs/core/plymouth/plymouth.install
index aafcca8..99aa7ee 100644
--- a/abs/core/plymouth/plymouth.install
+++ b/abs/core/plymouth/plymouth.install
@@ -1,43 +1,50 @@
post_install() {
-cat <<EOT
+cat <<EOF
+
+===========
-==================================================================================
1. To make Plymouth work:
- 1.1. Add "plymouth" to HOOKS after "base" and "udev" in /etc/mkinitcpio.conf
- 1.2. Add 'quiet splash' to the grub command line
- 1.3. Rebuild your initrd image (# mkinitcpio -p [kernel preset name]).
+ 1.1. Add "plymouth" to HOOKS after "base" and "udev" in /etc/mkinitcpio.conf
+ 1.2. Add 'quiet splash' to the grub command line
+ 1.3. Rebuild your initrd image (# mkinitcpio -p [kernel preset name]).
E.g.: sudo mkinitcpio -p linux
+
+===========
2. To enable encryption, replace "encrypt" with "plymouth-encrypt" in
mkinitcpio.conf and rebuild your initrd image.
+
+===========
-3. You will also need to rebuild your initrd image every time you change your theme
- (the default is set as 'spinfinity').
+3. You will also need to rebuild your initrd image every time you change your
+ theme (the default is set as 'spinfinity').
To list all plymouth themes:
plymouth-set-default-theme -l
- To change theme:
- # plymouth-set-default-theme <theme>
-
- To rebuild initrd image:
- # mkinitcpio -p linux
+ To change theme and rebuild initrd image:
+ # plymouth-set-default-theme -R <theme>
+
+===========
4. For Smooth Transition to Display Manager you have to:
- 4.1. See the Wiki Page (link in 5) to prepare your Display Manager
- 4.2. Disable your Display Manager Unit
- E.g. : systemctl disable kdm.service
- 4.3. Enable the respective DM-plymouth Unit (GDM,KDM,Lightdm,LXDM units provided)
- E.g. : systemctl enable kdm-plymouth.service
+ 4.1. See the Wiki Page (link in 5) to prepare your Display Manager
+ 4.2. Disable your Display Manager Unit
+ E.g. : # systemctl disable kdm.service
+ 4.3. Enable the respective DM-plymouth Unit (GDM, KDM, LXDM units provided)
+ E.g. : # systemctl enable kdm-plymouth.service
+
+===========
5. For more information please visit the Wiki page:
https://wiki.archlinux.org/index.php/Plymouth
+
+===========
-OBS. If you have any leftover "kill Plymouth" lines in /etc/rc.local or ~/.xinitrc
- they are no longer required.
-==================================================================================
+OBS. If you have any leftover "kill Plymouth" lines in /etc/rc.local or
+~/.xinitrc they are no longer required.
-EOT
+EOF
}
post_upgrade() {
diff --git a/abs/core/plymouth/slim-plymouth.service b/abs/core/plymouth/slim-plymouth.service
new file mode 100644
index 0000000..8806c7d
--- /dev/null
+++ b/abs/core/plymouth/slim-plymouth.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=SLiM Simple Login Manager
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
+
+[Service]
+ExecStart=/usr/bin/slim -nodaemon
+StandardOutput=syslog
+
+[Install]
+Alias=display-manager.service
diff --git a/abs/core/plymouth/systemd-unit-dir.patch b/abs/core/plymouth/systemd-unit-dir.patch
deleted file mode 100644
index 7058c8f..0000000
--- a/abs/core/plymouth/systemd-unit-dir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2012-06-12 17:19:48.903409717 +0300
-+++ configure.ac 2012-06-12 17:20:01.916743217 +0300
-@@ -254,7 +254,7 @@
-
- if test x$enable_systemd_integration = xyes; then
- AC_DEFINE(PLY_ENABLE_SYSTEMD_INTEGRATION, 1, [Coordinate boot up with systemd])
-- SYSTEMD_UNIT_DIR=/lib/systemd/system
-+ SYSTEMD_UNIT_DIR=/usr/lib/systemd/system
- AC_SUBST(SYSTEMD_UNIT_DIR)
- fi
-
diff --git a/abs/core/plymouth/udevadm.patch b/abs/core/plymouth/udevadm.patch
deleted file mode 100644
index aa01e00..0000000
--- a/abs/core/plymouth/udevadm.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/systemd-units/plymouth-start.service.in 2012-09-26 18:50:53.000000000 +0200
-+++ b/systemd-units/plymouth-start.service.in 2012-11-01 00:12:35.186732840 +0100
-@@ -8,7 +8,7 @@
-
- [Service]
- ExecStart=@PLYMOUTH_DAEMON_DIR@/plymouthd --mode=boot --pid-file=/run/plymouth.pid --attach-to-session
--ExecStartPost=-/bin/udevadm settle --timeout=30 --exit-if-exists=/sys/class/drm/card0/dev ; /bin/udevadm settle --timeout=30 --exit-if-exists=/sys/class/graphics/fb0/dev ; @PLYMOUTH_CLIENT_DIR@/plymouth show-splash
-+ExecStartPost=-/usr/bin/udevadm settle --timeout=30 --exit-if-exists=/sys/class/drm/card0/dev ; /usr/bin/udevadm settle --timeout=30 --exit-if-exists=/sys/class/graphics/fb0/dev ; @PLYMOUTH_CLIENT_DIR@/plymouth show-splash
- Type=forking
- KillMode=none
- SendSIGKILL=no