summaryrefslogtreecommitdiffstats
path: root/abs/core/python-decorator
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python-decorator')
-rw-r--r--abs/core/python-decorator/LICENSE.txt26
-rw-r--r--abs/core/python-decorator/PKGBUILD30
2 files changed, 0 insertions, 56 deletions
diff --git a/abs/core/python-decorator/LICENSE.txt b/abs/core/python-decorator/LICENSE.txt
deleted file mode 100644
index a6a4929..0000000
--- a/abs/core/python-decorator/LICENSE.txt
+++ /dev/null
@@ -1,26 +0,0 @@
-Copyright (c) 2007, Michele Simionato
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are
-met:
-
- Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
- Redistributions in bytecode form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in
- the documentation and/or other materials provided with the
- distribution.
-
- THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
- "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
- LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
- A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
- HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
- INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
- BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
- OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
- ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
- TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
- USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
- DAMAGE.
diff --git a/abs/core/python-decorator/PKGBUILD b/abs/core/python-decorator/PKGBUILD
deleted file mode 100644
index e933da0..0000000
--- a/abs/core/python-decorator/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Maintainer: Thomas Dziedzic < gostrc at gmail >
-# Contributor: Pierre Chapuis <catwell at archlinux dot us>
-
-pkgname=python-decorator
-pkgver=3.2.0
-pkgrel=2
-pkgdesc='Python Decorator module'
-arch=('any')
-url='http://pypi.python.org/pypi/decorator'
-license=('BSD')
-depends=('python2')
-source=("http://pypi.python.org/packages/source/d/decorator/decorator-${pkgver}.tar.gz"
- 'LICENSE.txt')
-md5sums=('6208cd51365083c168ab3a04426a646b'
- '0ca76d2c707f09dbb04acc425ea1a08b')
-
-build() {
- cd decorator-${pkgver}
-
- python2 setup.py build
-}
-
-package() {
- cd decorator-${pkgver}
-
- python2 setup.py install --root=${pkgdir} --optimize=1
-
- install -D -m644 ${srcdir}/LICENSE.txt \
- ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-}