summaryrefslogtreecommitdiffstats
path: root/abs/core/python-numpy/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python-numpy/PKGBUILD')
-rw-r--r--abs/core/python-numpy/PKGBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/abs/core/python-numpy/PKGBUILD b/abs/core/python-numpy/PKGBUILD
deleted file mode 100644
index 3dc66a0..0000000
--- a/abs/core/python-numpy/PKGBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# $Id: PKGBUILD 95257 2010-10-17 20:17:04Z ibiru $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
-# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
-
-pkgname=python-numpy
-pkgver=1.5.0
-pkgrel=2
-pkgdesc="Scientific tools for Python"
-arch=('i686' 'x86_64')
-license=('custom')
-url="http://numpy.scipy.org/"
-depends=('lapack' 'python2')
-makedepends=('python-nose' 'gcc-fortran')
-optdepends=('python-nose: test suite')
-source=(http://downloads.sourceforge.net/numpy/numpy-${pkgver}.tar.gz)
-md5sums=('3a8bfdc434df782d647161c48943ee09')
-
-build() {
- cd "${srcdir}/numpy-${pkgver}"
-
- export Atlas=None
- export LDFLAGS="$LDFLAGS -shared"
- python2 setup.py config_fc --fcompiler=gnu95 build
-}
-
-package() {
- cd "${srcdir}/numpy-${pkgver}"
- python2 setup.py config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}"
-
- install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- $(find $pkgdir -name '*.py')
-}
-