summaryrefslogtreecommitdiffstats
path: root/abs/core/python2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python2/PKGBUILD')
-rw-r--r--abs/core/python2/PKGBUILD34
1 files changed, 15 insertions, 19 deletions
diff --git a/abs/core/python2/PKGBUILD b/abs/core/python2/PKGBUILD
index aabe74a..fee49e7 100644
--- a/abs/core/python2/PKGBUILD
+++ b/abs/core/python2/PKGBUILD
@@ -1,18 +1,17 @@
-# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Jason Chu <jason@archlinux.org>
pkgname=python2
-pkgver=2.7.14
+pkgver=2.7.18
pkgrel=2
_pybasever=2.7
pkgdesc="A high-level scripting language"
arch=('x86_64')
license=('PSF')
-url="http://www.python.org/"
-depends=('bzip2' 'gdbm' 'openssl' 'zlib' 'expat' 'sqlite' 'libffi')
+url="https://www.python.org/"
+depends=('bzip2' 'expat' 'gdbm' 'libffi' 'libnsl' 'libxcrypt' 'openssl' 'sqlite' 'zlib')
makedepends=('tk' 'bluez-libs')
checkdepends=('gdb' 'file' 'xorg-server-xvfb')
optdepends=('tk: for IDLE'
@@ -20,16 +19,19 @@ optdepends=('tk: for IDLE'
'python2-pip')
conflicts=('python<3')
source=("https://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz"{,.asc}
- descr_ref.patch fix-profile-task.patch)
-sha512sums=('78310b0be6388ffa15f29a80afb9ab3c03a572cb094e9da00cfe391afadb51696e41f592eb658d6a31a2f422fdac8a55214a382cbb8cfb43d4a127d5b35ea7f9'
+ mtime-workaround.patch)
+sha512sums=('a7bb62b51f48ff0b6df0b18f5b0312a523e3110f49c3237936bfe56ed0e26838c0274ff5401bda6fc21bf24337477ccac49e8026c5d651e4b4cafb5eb5086f6c'
'SKIP'
- '2e16eb23eb402dbe921c09bce99b400c10939114b4a1ded0e94a744d8cb66427947bc8d07c4fb054f9fe0906d10d1da509fc2273fd136225c0f019cc43dd045d'
- '5d7b47bfa9f13cf5fb827546189d823033278f96866366fca5257aaf819c92ffb26e2116426c84ab78d9ae3178eebb591fa4b2f22cfc2725e3e3e795fdb5c2b6')
+ '4e761cfd57791e8b72ecdf84c2e03875bf074311130eea5b8e97409fa304fa3468dbd359a511c4e9978e686e662c58054b4174d3e73f845fa9ded2e83a3a8076')
validpgpkeys=('C01E1CAD5EA2C4F0B8E3571504C367C218ADD4FF') # Benjamin Peterson
prepare() {
cd Python-${pkgver}
+ # makepkg will touch all files to $SOURCE_DATE_EPOCH which will break pyc file's mtime check.
+ # workaround this by touching them to $SOURCE_DATE_EPOCH before running compileall.
+ patch -p0 -i ../mtime-workaround.patch
+
# Temporary workaround for FS#22322
# See http://bugs.python.org/issue10835 for upstream report
sed -i "/progname =/s/python/python${_pybasever}/" Python/pythonrun.c
@@ -55,13 +57,6 @@ prepare() {
# Workaround asdl_c.py/makeopcodetargets.py errors after we touched the shebangs
touch Include/Python-ast.h Python/Python-ast.c Python/opcode_targets.h
-
- # FS#48761
- # http://bugs.python.org/issue25750
- patch -Np1 -i ../descr_ref.patch
-
- # Backport from Python 3.x
- patch -Np2 -i ../fix-profile-task.patch
}
build() {
@@ -84,13 +79,14 @@ build() {
}
check() {
- # Since 2.7.13,
- # test_replace_overflow (present in test_bytes, test_str, test_string, test_unicode, test_userstring) segfault on i686
- # test_bigrepeat (present in test_tuple) segfault on i686
+ # Since 2.7.14 with latest xvfb
+ # test_idle, test_tk, test_ttk_guionly: segfaults
+ # Since 2.7.15: test_ctypes
+ # test_ftplib test_imaplib test_urllib2_localnet: krb5 errors
cd Python-${pkgver}
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
- xvfb-run "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_bytes test_str test_string test_tuple test_unicode test_userstring
+ xvfb-run "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_idle test_tk test_ttk_guionly test_ctypes test_ssl test_ftplib test_imaplib test_urllib2_localnet
}
package() {