summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/pyqt/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/pyqt/PKGBUILD')
-rw-r--r--abs/core/python_modules/pyqt/PKGBUILD77
1 files changed, 49 insertions, 28 deletions
diff --git a/abs/core/python_modules/pyqt/PKGBUILD b/abs/core/python_modules/pyqt/PKGBUILD
index 8488d62..669bc4c 100644
--- a/abs/core/python_modules/pyqt/PKGBUILD
+++ b/abs/core/python_modules/pyqt/PKGBUILD
@@ -1,34 +1,39 @@
-# $Id$
-# Maintainer:
-# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# $Id: PKGBUILD 163679 2012-07-17 18:11:04Z andrea $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
pkgbase=pyqt
-pkgname=('pyqt' 'python2-pyqt')
-pkgver=4.8.6
+pkgname=('pyqt-common' 'python2-pyqt')
+pkgver=4.9.4
pkgrel=2
arch=('i686' 'x86_64')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
-makedepends=('qt' 'python-sip' 'dbus-python' 'python2-sip' 'phonon'
- 'python-opengl' 'qt-assistant-compat' 'qtwebkit')
-source=("http://riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${pkgver}.tar.gz")
-md5sums=('9bfd7b08b8e438b83cc50d5c58191f97')
+makedepends=('qt' 'python2-sip'
+ 'python-opengl' 'qt-assistant-compat' 'qtwebkit' 'python2-dbus')
+source=("http://riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${pkgver}.tar.gz"
+ 'fix-pyuic4.patch')
+md5sums=('a0b6a820633366365af5124ddbd059c7'
+ '097651aea0bafded5abdfd6d62afd2ad')
build() {
- cd "${srcdir}"
+ # FS#30728
+ cd "${srcdir}"/PyQt-x11-gpl-${pkgver}
+ patch -p1 -i "${srcdir}"/fix-pyuic4.patch
+ cd ..
+
cp -r PyQt-x11-gpl-${pkgver} Py2Qt-x11-gpl-${pkgver}
- cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
- python configure.py \
- --confirm-license \
- --qsci-api
+ #cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
+ #python configure.py \
+ # --confirm-license \
+ # --qsci-api
# Thanks Gerardo for the rpath fix
- find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
+ #find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
- make
+ #make
### Python2 version ###
cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
@@ -43,36 +48,52 @@ build() {
make
}
+package_pyqt-common(){
+ pkgdesc="Common PyQt files shared between pyqt and python2-pyqt"
+
+ cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
+ make -C pyrcc DESTDIR="${pkgdir}" install
+ make -C pylupdate DESTDIR="${pkgdir}" install
+ make -C designer INSTALL_ROOT="${pkgdir}" install
+
+ install -Dm644 PyQt4.api "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt4.api
+}
+
package_pyqt(){
- pkgdesc="A set of Python bindings for the Qt toolkit"
- depends=('qtwebkit' 'python-sip')
+ pkgdesc="A set of Python 3.x bindings for the Qt toolkit"
+ depends=('qtwebkit' 'python-sip' 'python-dbus' 'pyqt-common')
optdepends=('phonon: enable audio and video in PyQt applications'
'qscintilla: QScintilla API'
'qt-assistant-compat: add PyQt online help in Qt Assistant')
- replaces=('python-qt')
- provides=('python-qt')
-
+
cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+
+ # Provided by pyqt-common
+ rm "${pkgdir}"/usr/bin/{pylupdate4,pyrcc4}
+ rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpythonplugin.so
+ rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt4.api
}
package_python2-pyqt(){
- pkgdesc="PyQt: A set of Python2 bindings for the Qt toolkit"
- depends=('pyqt' 'python2-sip' 'dbus-python')
+ pkgdesc="A set of Python 2.x bindings for the Qt toolkit"
+ depends=('qtwebkit' 'python2-sip' 'python2-dbus' 'pyqt-common')
optdepends=('phonon: enable audio and video in PyQt applications'
'python-opengl: enable OpenGL 3D graphics in PyQt applications'
'qscintilla: QScintilla API'
'qt-assistant-compat: add PyQt online help in Qt Assistant')
- replaces=('python2-qt')
provides=('python2-qt')
cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
- # Provided by pyqt
- rm ${pkgdir}/usr/bin/{pylupdate4,pyrcc4,pyuic4}
- rm ${pkgdir}/usr/lib/qt/plugins/designer/libpythonplugin.so
- rm ${pkgdir}/usr/share/qt/qsci/api/python/PyQt4.api
+ # Fix conflicts with pyqt
+ mv "${pkgdir}"/usr/bin/{,python2-}pyuic4
+
+ # Provided by pyqt-common
+ rm "${pkgdir}"/usr/bin/{pylupdate4,pyrcc4}
+ rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpythonplugin.so
+ rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt4.api
}