summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-beautifulsoup4/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/PKGBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
deleted file mode 100644
index e5eba14..0000000
--- a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# $Id: PKGBUILD 73500 2012-07-08 17:25:45Z dwallace $
-# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
-# Contributor: Giovanni Scafora <giovanni@archlinux.org>
-
-pkgbase=python-beautifulsoup4
-pkgname=('python2-beautifulsoup4' 'python-beautifulsoup4')
-pkgver=4.1.1
-pkgrel=2
-pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
-arch=('any')
-url="http://www.crummy.com/software/BeautifulSoup/index.html"
-license=('PSF')
-#makedepends=('python-distribute' 'python2-distribute')
-makedepends=('python2-distribute')
-source=("http://www.crummy.com/software/BeautifulSoup/bs4/download/${pkgver%\.*}/${pkgbase#*-}-${pkgver}.tar.gz")
-md5sums=('fccee58b4d914fb489385d672fe89f43')
-
-build() {
- cd "${srcdir}"
- cp -a beautifulsoup4-${pkgver}{,-python2}
-
- # Build python 3 module
- cd "${srcdir}/beautifulsoup4-${pkgver}"
- python setup.py build
-
- # Build python 2 module
- cd "${srcdir}/beautifulsoup4-${pkgver}-python2"
- python2 setup.py build
-}
-
-package_python2-beautifulsoup4() {
- depends=('python2-distribute')
- optdepends=('python2-chardet: universal encoding detector'
- 'python2-lxml: pythonic binding for the libxml2 and libxslt libraries')
-
- cd "${srcdir}/beautifulsoup4-${pkgver}-python2"
- python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
-
- rm -rf ${pkgdir}/usr/lib/python2.7/site-packages/bs4/tests
-}
-
-package_python-beautifulsoup4() {
-# depends=('python-distribute')
- optdepends=('python-chardet: universal encoding detector'
- 'python-lxml: pythonic binding for the libxml2 and libxslt libraries')
-
- cd "${srcdir}/beautifulsoup4-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
-
- rm -rf ${pkgdir}/usr/lib/python3.2/site-packages/bs4/{__pycache__,tests,builder/__pycache__}
-}