summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-distribute/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-distribute/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-distribute/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/abs/core/python_modules/python-distribute/PKGBUILD b/abs/core/python_modules/python-distribute/PKGBUILD
index 625bcf7..5627eb7 100644
--- a/abs/core/python_modules/python-distribute/PKGBUILD
+++ b/abs/core/python_modules/python-distribute/PKGBUILD
@@ -2,14 +2,14 @@
# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
# Contributor: Sebastien Binet <binet@farnsworth>
pkgbase=python-distribute
-pkgname=('python-distribute' 'python2-distribute')
+pkgname=('python2-distribute')
pkgver=0.6.27
-pkgrel=2
+pkgrel=1
pkgdesc="Easily build and distribute Python packages"
arch=('any')
license=('PSF')
url="http://pypi.python.org/pypi/distribute"
-makedepends=('python' 'python2')
+makedepends=('python2')
source=(http://pypi.python.org/packages/source/d/distribute/distribute-${pkgver}.tar.gz
distribute-python2_and_3.patch)
sha1sums=('cebaaf91938581cb8c4a2f708f2b3e770232d3a5'
@@ -23,9 +23,9 @@ build() {
cp -a distribute-${pkgver}{,-python2}
- # Build python 3 module
+ ## Build python 3 module
cd distribute-${pkgver}
- python setup.py build
+ # python setup.py build
# python setup.py test
# Build python 2 module
@@ -38,14 +38,14 @@ build() {
}
package_python-distribute() {
- depends=('python>=3.2')
+ # depends=('python>=3.2')
cd "${srcdir}/distribute-${pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}
package_python2-distribute() {
- depends=('python2>=2.6')
+ depends=('python2>=2.7')
provides=('setuptools')
conflicts=('setuptools')