summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-distribute/distribute-python2_and_3.patch')
-rw-r--r--abs/core/python_modules/python-distribute/distribute-python2_and_3.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch b/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch
new file mode 100644
index 0000000..2c51100
--- /dev/null
+++ b/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch
@@ -0,0 +1,36 @@
+diff -Naur distribute-0.6.27.ori/distribute.egg-info/entry_points.txt distribute-0.6.27/distribute.egg-info/entry_points.txt
+--- distribute-0.6.27.ori/distribute.egg-info/entry_points.txt 2012-05-18 15:46:04.000000000 -0400
++++ distribute-0.6.27/distribute.egg-info/entry_points.txt 2012-05-22 18:14:17.443383039 -0400
+@@ -11,6 +11,8 @@
+ install_egg_info = setuptools.command.install_egg_info:install_egg_info
+ alias = setuptools.command.alias:alias
+ easy_install = setuptools.command.easy_install:easy_install
++easy_install-2.7 = setuptools.command.easy_install:main
++easy_install-3.2 = setuptools.command.easy_install:main
+ install_scripts = setuptools.command.install_scripts:install_scripts
+ bdist_wininst = setuptools.command.bdist_wininst:bdist_wininst
+ bdist_egg = setuptools.command.bdist_egg:bdist_egg
+diff -Naur distribute-0.6.27.ori/distribute_setup.py distribute-0.6.27/distribute_setup.py
+--- distribute-0.6.27.ori/distribute_setup.py 2012-05-18 15:45:03.000000000 -0400
++++ distribute-0.6.27/distribute_setup.py 2012-05-22 18:14:17.443383039 -0400
+@@ -299,8 +299,7 @@
+ log.warn('Could not find the install location')
+ return
+ pyver = '%s.%s' % (sys.version_info[0], sys.version_info[1])
+- setuptools_file = 'setuptools-%s-py%s.egg-info' % \
+- (SETUPTOOLS_FAKED_VERSION, pyver)
++ setuptools_file = 'setuptools-%s.egg-info' % SETUPTOOLS_FAKED_VERSION
+ pkg_info = os.path.join(placeholder, setuptools_file)
+ if os.path.exists(pkg_info):
+ log.warn('%s already exists', pkg_info)
+diff -Naur distribute-0.6.27.ori/setup.py distribute-0.6.27/setup.py
+--- distribute-0.6.27.ori/setup.py 2012-05-18 15:19:51.000000000 -0400
++++ distribute-0.6.27/setup.py 2012-05-22 18:14:17.443383039 -0400
+@@ -100,6 +100,7 @@
+ finally:
+ f.close()
+
++console_scripts = ["easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3]]
+
+ # if we are installing Distribute using "python setup.py install"
+ # we need to get setuptools out of the way