summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-html5lib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-html5lib/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-html5lib/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-html5lib/PKGBUILD b/abs/core/python_modules/python-html5lib/PKGBUILD
new file mode 100644
index 0000000..0ef62da
--- /dev/null
+++ b/abs/core/python_modules/python-html5lib/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: Erol V. Aktay <e.aktay@gmail.com>
+# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgbase=python-html5lib
+pkgname=('python2-html5lib')
+pkgver=0.999999999
+pkgrel=2
+arch=('any')
+url="https://github.com/html5lib"
+license=('MIT')
+makedepends=('python2' 'unzip' 'python2-webencodings')
+checkdepends=('python2-six' 'python2-pytest' 'python2-lxml' 'python2-mock')
+source=($pkgbase-$pkgver.tar.gz::https://github.com/html5lib/html5lib-python/archive/${pkgver}.tar.gz
+ LICENSE)
+md5sums=('a81446ef3ce3ef18f5e8e242b7072b83'
+ '838c366f69b72c5df05c96dff79b35f2')
+
+package_python-html5lib() {
+pkgdesc="A Python HTML parser/tokenizer based on the WHATWG HTML5 spec"
+depends=('python' 'python-six' 'python-webencodings')
+ cd ${srcdir}/html5lib-python-${pkgver}
+
+ python3 setup.py install --root=${pkgdir}
+ install -Dm755 $srcdir/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+package_python2-html5lib() {
+depends=('python2' 'python2-six' 'python2-webencodings')
+pkgdesc="A Python2 HTML parser/tokenizer based on the WHATWG HTML5 spec"
+ cd ${srcdir}/html5lib-python-${pkgver}
+
+ python2 setup.py install --root=${pkgdir}
+ install -Dm755 $srcdir/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+check() {
+ cd ${srcdir}/html5lib-python-${pkgver}/html5lib/tests
+
+# nosetests2
+
+# nosetests
+}