summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-lxml/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-lxml/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-lxml/PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/abs/core/python_modules/python-lxml/PKGBUILD b/abs/core/python_modules/python-lxml/PKGBUILD
index f939617..b38d024 100644
--- a/abs/core/python_modules/python-lxml/PKGBUILD
+++ b/abs/core/python_modules/python-lxml/PKGBUILD
@@ -3,17 +3,17 @@
pkgbase=python-lxml
pkgname=('python-lxml' 'python2-lxml' 'python-lxml-docs')
-pkgver=4.3.0
-pkgrel=1
+pkgver=4.6.1
+pkgrel=3
arch=('x86_64')
license=('BSD' 'custom')
-url="http://lxml.de/"
-makedepends=('libxslt' 'python-setuptools' 'python2-setuptools' 'epydoc' 'python2-pygments'
- 'python2-docutils' 'cython' 'cython2')
+url="https://lxml.de/"
+makedepends=('libxslt' 'python-setuptools' 'python2-setuptools' 'python-pygments'
+ 'python-sphinx' 'python-sphinx_rtd_theme' 'cython' 'cython2')
checkdepends=('python-cssselect' 'python2-cssselect' 'python-html5lib' 'python2-html5lib'
'python-beautifulsoup4' 'python2-beautifulsoup4')
source=("https://github.com/lxml/lxml/archive/lxml-$pkgver.tar.gz")
-sha512sums=('3739e243b543e8a5f678aaca19fe1b5be21351c343065fe8e52709523d4e27dbd5c846c0681473b9612fd73af6a4d04ec21c6834e53680410cab854b7f7f1675')
+sha512sums=('3cc917e7535ac1be3db8939f72846313267c8b1f0adccc92a2155a160ed7299d0def718bdae1379e42398ca1b959b1130505597febca00f02cb87c8666f1f1c3')
prepare() {
mv lxml-lxml-$pkgver lxml-$pkgver
@@ -26,20 +26,20 @@ prepare() {
build() {
cd "$srcdir"/lxml-$pkgver
python setup.py build
+ make html
cd "$srcdir"/lxml-$pkgver-py2
python2 setup.py build
- make PYTHON=python2 html
}
check() {
# TODO: Find a sane way to skip inplace build
cd "$srcdir"/lxml-$pkgver
- make PYTHON=python test || warning "Tests failed"
+ make PYTHON=python test
cd "$srcdir"/lxml-$pkgver-py2
- make PYTHON=python2 test || warning "Tests failed"
+ make PYTHON=python2 test
}
package_python-lxml() {
@@ -84,7 +84,7 @@ package_python-lxml-docs() {
pkgdesc="Python binding for the libxml2 and libxslt libraries (docs)"
options=('docs')
- cd lxml-$pkgver-py2
+ cd lxml-$pkgver
install -d "$pkgdir"/usr/share/doc/$pkgbase
cp -r doc/html "$pkgdir"/usr/share/doc/$pkgbase