summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-notify/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-notify/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-notify/PKGBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/abs/core/python_modules/python-notify/PKGBUILD b/abs/core/python_modules/python-notify/PKGBUILD
index 47c25e5..ad9a615 100644
--- a/abs/core/python_modules/python-notify/PKGBUILD
+++ b/abs/core/python_modules/python-notify/PKGBUILD
@@ -1,25 +1,38 @@
-# $Id: PKGBUILD 82 2009-07-17 19:56:55Z aaron $
+# $Id: PKGBUILD 148890 2012-02-05 11:54:24Z ibiru $
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
# Contributor: Mario Danic <mario.danic@gmail.com>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
-
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=python-notify
pkgver=0.1.1
-pkgrel=8
+pkgrel=11
pkgdesc="Python bindings for libnotify"
arch=('i686' 'x86_64')
url="http://www.galago-project.org/"
license=('GPL')
-depends=('pygtk>=2.22.0' 'libnotify>=0.4.5')
+depends=('pygtk>=2.22.0' 'libnotify>=0.7.1')
makedepends=('pkgconfig' 'python2')
options=(!libtool)
-source=(http://www.galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz)
-md5sums=('8f0ef0939cc8edd2efd896ce5ba80cf4')
+source=(http://www.galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz
+ libnotify07.patch
+ notify-python-0.1.1-fix-GTK-symbols.patch)
+md5sums=('8f0ef0939cc8edd2efd896ce5ba80cf4'
+ 'b40c4542575d5aef559908fe60a21634'
+ 'c6922028da5951e69a6a0167bdb4461c')
build() {
cd ${srcdir}/notify-python-${pkgver}
+
+ patch -Np1 -i ${srcdir}/libnotify07.patch
+ patch -Np1 -i ${srcdir}/notify-python-0.1.1-fix-GTK-symbols.patch
+
./configure --prefix=/usr
+
+ # WARNING - we touch src/pynotify.override in build because upstream did not rebuild pynotify.c
+ # from the input definitions, this forces pynotify.c to be regenerated, at some point this can be removed
+ touch src/pynotify.override
+
make clean
make
}