summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-pysqlite/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-pysqlite/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-pysqlite/PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/abs/core/python_modules/python-pysqlite/PKGBUILD b/abs/core/python_modules/python-pysqlite/PKGBUILD
index 4a45ba5..0302233 100644
--- a/abs/core/python_modules/python-pysqlite/PKGBUILD
+++ b/abs/core/python_modules/python-pysqlite/PKGBUILD
@@ -1,21 +1,26 @@
-# $Id: PKGBUILD 89652 2010-09-02 20:47:02Z remy $
+# $Id: PKGBUILD 155872 2012-04-08 07:25:46Z remy $
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Aaron Griffin <aaron@archlinux.org>
-# Contributor: Aaron Griffin <aaron@archlinux.org>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
-
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=python-pysqlite
-pkgver=2.6.0
-pkgrel=3
+pkgver=2.6.3
+pkgrel=2
pkgdesc="A Python DB-API 2.0 interface for the SQLite embedded relational database engine"
license=('custom')
arch=('i686' 'x86_64')
url="http://code.google.com/p/pysqlite/"
-depends=('python2' 'sqlite3')
+depends=('python2' 'sqlite')
replaces=('pysqlite2')
source=(http://pysqlite.googlecode.com/files/pysqlite-${pkgver}.tar.gz \
setup.cfg)
-md5sums=('fc92618b3b39d02e6ff10dc467c36640'
- '86dd356c65afd14a22f2f8f64a26441e')
+md5sums=('711afa1062a1d2c4a67acdf02a33d86e'
+ '86dd356c65afd14a22f2f8f64a26441e')
+
+check() {
+ cd ${pkgdir}/usr/lib/python2.7/site-packages
+ python2 -c "from pysqlite2 import test; test.test()"
+}
+
build() {
cd ${srcdir}/pysqlite-${pkgver}
cp ${srcdir}/setup.cfg .