summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-requests/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-requests/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-requests/PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/abs/core/python_modules/python-requests/PKGBUILD b/abs/core/python_modules/python-requests/PKGBUILD
index e791c7b..eee0bf0 100644
--- a/abs/core/python_modules/python-requests/PKGBUILD
+++ b/abs/core/python_modules/python-requests/PKGBUILD
@@ -1,10 +1,9 @@
-# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgbase=python-requests
pkgname=('python-requests' 'python2-requests')
-pkgver=2.18.4
+pkgver=2.25.0
pkgrel=1
pkgdesc="Python HTTP for Humans"
arch=('any')
@@ -12,16 +11,16 @@ url="http://python-requests.org"
license=('Apache')
makedepends=('python-setuptools' 'python2-setuptools' 'python-chardet' 'python2-chardet'
'python-urllib3' 'python2-urllib3' 'python-idna' 'python2-idna')
-checkdepends=('python-pytest-httpbin' 'python2-pytest-httpbin' 'python-pytest-mock'
- 'python2-pytest-mock' 'python-pysocks' 'python2-pysocks')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/kennethreitz/requests/archive/v$pkgver.tar.gz"
+checkdepends=('python-pytest-httpbin' 'python-pytest-mock' 'python-pysocks' 'python-pyopenssl')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/psf/requests/archive/v$pkgver.tar.gz"
certs.patch)
-sha512sums=('8ca20fe18d13b8c62977be0c51617f2ae8618d3d002ad4dc554362828855db7359274efbff0cd13e8c5699508913e91205cffcf306221a70321e74ac10b2d4d7'
+sha512sums=('f60d8dbbc7aaebaedc7647ab2cec1fffd01547ea3340b91d9c7fea51fde4cb932aaf81e3b8aac9f4be11243e4fc44c8266a69db5f52c4eb2afb1b7714c150b95'
'424a3bb01b23409284f6c9cd2bc22d92df31b85cfd96e1d1b16b5d68adeca670dfed4fff7977d8b10980102b0f780eacc465431021fcd661f3a17168a02a39a3')
prepare() {
cd "$srcdir"/requests-$pkgver
sed -e '/certifi/d' \
+ -e "s/,<.*'/'/" \
-i setup.py
patch -p1 -i "$srcdir"/certs.patch
@@ -39,11 +38,10 @@ build() {
}
check() {
- cd "$srcdir"/requests-$pkgver
- py.test tests
+ # Seems to be a problem about pytest-httpbin
- cd "$srcdir"/requests-$pkgver-py2
- py.test2 tests
+ cd requests-$pkgver
+ pytest tests --deselect tests/test_requests.py::TestRequests::test_https_warnings
}
package_python-requests() {