summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-soupsieve/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-soupsieve/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-soupsieve/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-soupsieve/PKGBUILD b/abs/core/python_modules/python-soupsieve/PKGBUILD
new file mode 100644
index 0000000..8b65574
--- /dev/null
+++ b/abs/core/python_modules/python-soupsieve/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python-soupsieve
+pkgver=2.0.1
+pkgrel=3
+pkgdesc="A CSS4 selector implementation for Beautiful Soup"
+url="https://github.com/facelessuser/soupsieve"
+license=('MIT')
+arch=('any')
+depends=('python')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-beautifulsoup4' 'python-html5lib' 'python-lxml')
+source=("https://github.com/facelessuser/soupsieve/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('f4ef4deee81bb31952e1d3216250712f09b425e7a2253e15bd1b38cb74b680e421e7d086a8770737898f6b57867f07f2dd07b8a98108d05e338bce92b274b85f')
+
+build() {
+ cd soupsieve-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd soupsieve-$pkgver
+ pytest
+}
+
+package() {
+ cd soupsieve-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.md
+}