summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-sphinx/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-sphinx/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-sphinx/PKGBUILD173
1 files changed, 43 insertions, 130 deletions
diff --git a/abs/core/python_modules/python-sphinx/PKGBUILD b/abs/core/python_modules/python-sphinx/PKGBUILD
index cab258e..33328d1 100644
--- a/abs/core/python_modules/python-sphinx/PKGBUILD
+++ b/abs/core/python_modules/python-sphinx/PKGBUILD
@@ -1,150 +1,63 @@
-# $Id$
# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
# Contributor: SĂ©bastien Luttringer
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Fabio Volpe <volpefabio@gmail.com>
-pkgbase=python-sphinx
-pkgname=('python-sphinx' 'python2-sphinx')
-pkgver=1.7.0
-pkgrel=1
-
+pkgname=python-sphinx
+pkgver=3.2.1
+pkgrel=3
+pkgdesc='Python documentation generator'
arch=('any')
-url='http://sphinx.pocoo.org/'
+url=http://www.sphinx-doc.org/
license=('BSD')
-
-makedepends=(
- 'python-setuptools'
- 'python-docutils'
- 'python-jinja'
- 'python-pygments'
- 'python-six'
- 'python-imagesize'
- 'python-sphinxcontrib-websupport'
- 'python-sqlalchemy'
- 'python-whoosh'
- 'python2-setuptools'
- 'python2-docutils'
- 'python2-jinja'
- 'python2-pygments'
- 'python2-six'
- 'python2-imagesize'
- 'python2-sphinxcontrib-websupport'
- 'python2-sqlalchemy'
- 'python2-whoosh'
- 'python2-typing'
-)
-
-checkdepends=(
- 'texlive-latexextra'
- 'python-nose' 'python2-nose'
- 'python-snowballstemmer' 'python2-snowballstemmer'
- 'python-babel' 'python2-babel'
- 'python-sphinx-alabaster-theme' 'python2-sphinx-alabaster-theme'
- 'python-sphinx_rtd_theme' 'python2-sphinx_rtd_theme'
- 'python-mock' 'python2-mock'
- 'python-html5lib' 'python2-html5lib'
- 'python-requests' 'python2-requests'
- 'python2-pytest' 'python-pytest'
- 'python2-enum34'
- 'python-sphinxcontrib-websupport' 'python2-sphinxcontrib-websupport'
- 'imagemagick' 'librsvg'
-)
-
-source=("https://pypi.org/packages/source/S/Sphinx/Sphinx-$pkgver.tar.gz"{,.asc})
-
-validpgpkeys=('8A11B79A5D0D749A66F0A030102C2C17498D6B9E'
- 'E9BEABB07E7B9CC3F56E62C91425F8CE5EBA0E07')
-md5sums=('7d6d8226148378875986310aea68702e'
- 'SKIP')
+depends=('python-babel'
+ 'python-docutils'
+ 'python-imagesize'
+ 'python-jinja'
+ 'python-pygments'
+ 'python-requests'
+ 'python-setuptools'
+ 'python-snowballstemmer'
+ 'python-sphinx-alabaster-theme'
+ 'python-sphinxcontrib-'{{apple,dev,html}help,jsmath,qthelp,serializinghtml})
+checkdepends=('cython'
+ 'imagemagick' 'librsvg'
+ 'python-html5lib'
+ 'python-pytest'
+ 'texlive-fontsextra' 'texlive-latexextra')
+optdepends=('imagemagick: for ext.imgconverter'
+ 'texlive-latexextra: for generation of PDF documentation')
+source=("https://pypi.org/packages/source/S/Sphinx/Sphinx-$pkgver.tar.gz"{,.asc}
+ $pkgname-pygments-2.7.patch::https://github.com/sphinx-doc/sphinx/commit/85b24a2e88ea.patch)
+sha256sums=('321d6d9b16fa381a5306e5a0b76cd48ffbc588e6340059a729c6fdd66087e0e8'
+ 'SKIP'
+ '6b790f4b3b540924a6a7861452fcbac8123f1e0a6c1765f5caafd7cb94fcecec')
+validpgpkeys=('8A11B79A5D0D749A66F0A030102C2C17498D6B9E' # Takeshi KOMIYA
+ 'E9BEABB07E7B9CC3F56E62C91425F8CE5EBA0E07') # Takayuki Shimizukawa
prepare() {
- # souce duplication is required because makefile modify source code
- # setyp.py --build tricks don't works well
- cp -a Sphinx-$pkgver Sphinx-${pkgver}2
- # change python2 interpreter
- find Sphinx-${pkgver}2 -type f -exec \
- sed -i '1s,^#! \?/usr/bin/\(env \|\)python$,#!/usr/bin/python2,' {} \;
- # change sphinx-binaries name in source code
- find Sphinx-${pkgver}2 -type f -name '*.py' -exec \
- sed -ri 's,(sphinx-(:?build|apidoc|autogen|quickstart)),\12,' {} \;
+ cd Sphinx-$pkgver
+
+ # Fix test failure with pygments 2.7
+ patch -Np1 -i ../$pkgname-pygments-2.7.patch
}
build() {
- msg2 'Python 3 version'
- cd "$srcdir"/Sphinx-$pkgver
- make PYTHON=python3 build
-
- msg2 'Python 2 version'
- cd "$srcdir"/Sphinx-${pkgver}2
- make PYTHON=python2 build
+ cd Sphinx-$pkgver
+ make build
}
-#check() {
-# msg2 'Python 3 version'
-# cd "$srcdir"/Sphinx-$pkgver
-# LC_ALL="en_US.UTF-8" make PYTHON=python3 test
-# rm -r tests
-#
-# msg2 'Python 2 version'
-# cd "$srcdir"/Sphinx-${pkgver}2
-# LC_ALL="en_US.UTF-8" make PYTHON=python2 test
-# rm -r tests
-#}
-
-package_python-sphinx() {
- pkgdesc='Python3 documentation generator'
- depends=(
- 'python-setuptools'
- 'python-jinja'
- 'python-pygments'
- 'python-docutils'
- 'python-sphinx_rtd_theme'
- 'python-sphinx-alabaster-theme'
- 'python-babel'
- 'python-snowballstemmer'
- 'python-six'
- 'python-imagesize'
- 'python-requests'
- 'python-sphinxcontrib-websupport'
- 'python-sqlalchemy'
- 'python-whoosh'
- )
- optdepends=('texlive-latexextra: for generation of PDF documentation'
- 'imagemagick: ext.imageconverter')
-
+check() {
cd Sphinx-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
-
- install -Dm644 "$srcdir"/Sphinx-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/python-sphinx/LICENSE
+ LC_ALL="en_US.UTF-8" make test
+ rm -r tests
}
-package_python2-sphinx() {
- pkgdesc='Python2 documentation generator'
- depends=(
- 'python2-setuptools'
- 'python2-jinja'
- 'python2-pygments'
- 'python2-docutils'
- 'python2-sphinx_rtd_theme'
- 'python2-sphinx-alabaster-theme'
- 'python2-babel'
- 'python2-snowballstemmer'
- 'python2-six'
- 'python2-imagesize'
- 'python2-requests'
- 'python2-sphinxcontrib-websupport'
- 'python2-sqlalchemy'
- 'python2-whoosh'
- 'python2-typing'
- )
- optdepends=('texlive-latexextra: for generation of PDF documentation'
- 'imagemagick: ext.imageconverter')
-
- cd Sphinx-${pkgver}2
- python2 setup.py install --root="$pkgdir" --optimize=1
-
- install -Dm644 "$srcdir"/Sphinx-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/python2-sphinx/LICENSE
+package() {
+ cd Sphinx-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
}
# vim:set ts=2 sw=2 et: