summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD b/abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD
new file mode 100644
index 0000000..ac87604
--- /dev/null
+++ b/abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+
+_name=sphinxcontrib-htmlhelp
+pkgname=python-sphinxcontrib-htmlhelp
+pkgver=1.0.3
+pkgrel=3
+pkgdesc='Sphinx extension which renders HTML help files'
+arch=('any')
+url=https://github.com/sphinx-doc/sphinxcontrib-htmlhelp
+license=('BSD')
+makedepends=('python-setuptools')
+checkdepends=('python-html5lib' 'python-pytest' 'python-sphinx')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e8f5bb7e31b2dbb25b9cc435c8ab7a79787ebf7f906155729338f3156d93659b')
+
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd $_name-$pkgver
+ pytest
+}
+
+package() {
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}
+
+# vim:set ts=2 sw=2 et: