summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/PKGBUILD51
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/__changelog2
-rw-r--r--abs/core/python_modules/python-distribute/PKGBUILD54
-rw-r--r--abs/core/python_modules/python-distribute/__changelog2
-rw-r--r--abs/core/python_modules/python-distribute/distribute-python2_and_3.patch36
-rw-r--r--abs/core/python_modules/python-libconcord/PKGBUILD22
6 files changed, 167 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
new file mode 100644
index 0000000..e5eba14
--- /dev/null
+++ b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 73500 2012-07-08 17:25:45Z dwallace $
+# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+pkgbase=python-beautifulsoup4
+pkgname=('python2-beautifulsoup4' 'python-beautifulsoup4')
+pkgver=4.1.1
+pkgrel=2
+pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
+arch=('any')
+url="http://www.crummy.com/software/BeautifulSoup/index.html"
+license=('PSF')
+#makedepends=('python-distribute' 'python2-distribute')
+makedepends=('python2-distribute')
+source=("http://www.crummy.com/software/BeautifulSoup/bs4/download/${pkgver%\.*}/${pkgbase#*-}-${pkgver}.tar.gz")
+md5sums=('fccee58b4d914fb489385d672fe89f43')
+
+build() {
+ cd "${srcdir}"
+ cp -a beautifulsoup4-${pkgver}{,-python2}
+
+ # Build python 3 module
+ cd "${srcdir}/beautifulsoup4-${pkgver}"
+ python setup.py build
+
+ # Build python 2 module
+ cd "${srcdir}/beautifulsoup4-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python2-beautifulsoup4() {
+ depends=('python2-distribute')
+ optdepends=('python2-chardet: universal encoding detector'
+ 'python2-lxml: pythonic binding for the libxml2 and libxslt libraries')
+
+ cd "${srcdir}/beautifulsoup4-${pkgver}-python2"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ rm -rf ${pkgdir}/usr/lib/python2.7/site-packages/bs4/tests
+}
+
+package_python-beautifulsoup4() {
+# depends=('python-distribute')
+ optdepends=('python-chardet: universal encoding detector'
+ 'python-lxml: pythonic binding for the libxml2 and libxslt libraries')
+
+ cd "${srcdir}/beautifulsoup4-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ rm -rf ${pkgdir}/usr/lib/python3.2/site-packages/bs4/{__pycache__,tests,builder/__pycache__}
+}
diff --git a/abs/core/python_modules/python-beautifulsoup4/__changelog b/abs/core/python_modules/python-beautifulsoup4/__changelog
new file mode 100644
index 0000000..1cdf6fa
--- /dev/null
+++ b/abs/core/python_modules/python-beautifulsoup4/__changelog
@@ -0,0 +1,2 @@
+9/3/12 - chw
+commented python-distribute as dep since we don't include python3. Built with mp.py --pkg=python2-beautisoup4.
diff --git a/abs/core/python_modules/python-distribute/PKGBUILD b/abs/core/python_modules/python-distribute/PKGBUILD
new file mode 100644
index 0000000..625bcf7
--- /dev/null
+++ b/abs/core/python_modules/python-distribute/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id: PKGBUILD 159385 2012-05-22 22:16:56Z stephane $
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Sebastien Binet <binet@farnsworth>
+pkgbase=python-distribute
+pkgname=('python-distribute' 'python2-distribute')
+pkgver=0.6.27
+pkgrel=2
+pkgdesc="Easily build and distribute Python packages"
+arch=('any')
+license=('PSF')
+url="http://pypi.python.org/pypi/distribute"
+makedepends=('python' 'python2')
+source=(http://pypi.python.org/packages/source/d/distribute/distribute-${pkgver}.tar.gz
+ distribute-python2_and_3.patch)
+sha1sums=('cebaaf91938581cb8c4a2f708f2b3e770232d3a5'
+ '9c19c12edac507b0f76696d282b9831c4b653a7e')
+build() {
+ cd "${srcdir}"
+
+ pushd distribute-${pkgver}
+ patch -Np1 -i ../distribute-python2_and_3.patch
+ popd
+
+ cp -a distribute-${pkgver}{,-python2}
+
+ # Build python 3 module
+ cd distribute-${pkgver}
+ python setup.py build
+# python setup.py test
+
+ # Build python 2 module
+ cd ../distribute-${pkgver}-python2
+
+ sed -i -e "s|^#\!.*/usr/bin/python|#!/usr/bin/python2|" setuptools/tests/test_resources.py
+
+ python2 setup.py build
+# python2 setup.py test
+}
+
+package_python-distribute() {
+ depends=('python>=3.2')
+
+ cd "${srcdir}/distribute-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+package_python2-distribute() {
+ depends=('python2>=2.6')
+ provides=('setuptools')
+ conflicts=('setuptools')
+
+ cd "${srcdir}/distribute-${pkgver}-python2"
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+}
diff --git a/abs/core/python_modules/python-distribute/__changelog b/abs/core/python_modules/python-distribute/__changelog
new file mode 100644
index 0000000..837fd43
--- /dev/null
+++ b/abs/core/python_modules/python-distribute/__changelog
@@ -0,0 +1,2 @@
+9/3/12
+For python2-distribute, change dep to python2.6.
diff --git a/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch b/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch
new file mode 100644
index 0000000..2c51100
--- /dev/null
+++ b/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch
@@ -0,0 +1,36 @@
+diff -Naur distribute-0.6.27.ori/distribute.egg-info/entry_points.txt distribute-0.6.27/distribute.egg-info/entry_points.txt
+--- distribute-0.6.27.ori/distribute.egg-info/entry_points.txt 2012-05-18 15:46:04.000000000 -0400
++++ distribute-0.6.27/distribute.egg-info/entry_points.txt 2012-05-22 18:14:17.443383039 -0400
+@@ -11,6 +11,8 @@
+ install_egg_info = setuptools.command.install_egg_info:install_egg_info
+ alias = setuptools.command.alias:alias
+ easy_install = setuptools.command.easy_install:easy_install
++easy_install-2.7 = setuptools.command.easy_install:main
++easy_install-3.2 = setuptools.command.easy_install:main
+ install_scripts = setuptools.command.install_scripts:install_scripts
+ bdist_wininst = setuptools.command.bdist_wininst:bdist_wininst
+ bdist_egg = setuptools.command.bdist_egg:bdist_egg
+diff -Naur distribute-0.6.27.ori/distribute_setup.py distribute-0.6.27/distribute_setup.py
+--- distribute-0.6.27.ori/distribute_setup.py 2012-05-18 15:45:03.000000000 -0400
++++ distribute-0.6.27/distribute_setup.py 2012-05-22 18:14:17.443383039 -0400
+@@ -299,8 +299,7 @@
+ log.warn('Could not find the install location')
+ return
+ pyver = '%s.%s' % (sys.version_info[0], sys.version_info[1])
+- setuptools_file = 'setuptools-%s-py%s.egg-info' % \
+- (SETUPTOOLS_FAKED_VERSION, pyver)
++ setuptools_file = 'setuptools-%s.egg-info' % SETUPTOOLS_FAKED_VERSION
+ pkg_info = os.path.join(placeholder, setuptools_file)
+ if os.path.exists(pkg_info):
+ log.warn('%s already exists', pkg_info)
+diff -Naur distribute-0.6.27.ori/setup.py distribute-0.6.27/setup.py
+--- distribute-0.6.27.ori/setup.py 2012-05-18 15:19:51.000000000 -0400
++++ distribute-0.6.27/setup.py 2012-05-22 18:14:17.443383039 -0400
+@@ -100,6 +100,7 @@
+ finally:
+ f.close()
+
++console_scripts = ["easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3]]
+
+ # if we are installing Distribute using "python setup.py install"
+ # we need to get setuptools out of the way
diff --git a/abs/core/python_modules/python-libconcord/PKGBUILD b/abs/core/python_modules/python-libconcord/PKGBUILD
new file mode 100644
index 0000000..fb638f8
--- /dev/null
+++ b/abs/core/python_modules/python-libconcord/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id$
+# Maintainers:
+# Andreas Baumann <abaumann@yahoo.com>
+# Guillaume DUMOULIN <guillaume.dumoulin@gmail.com>
+# Contributor: elsixdiab
+pkgname=python-libconcord
+_pkgsrcname=concordance
+pkgver=0.23
+pkgrel=3
+pkgdesc="This software will allow you to program your Logitech Harmony universal remote control"
+url="http://www.phildev.net/harmony/index.shtml"
+license="GPL"
+arch=('any')
+depends=('libconcord=0.23' 'python2')
+source=("http://downloads.sourceforge.net/${_pkgsrcname}/${_pkgsrcname}-${pkgver}.tar.bz2")
+md5sums=('d7400d5b351b195b63adfafae68be3d8')
+build() {
+ cd $srcdir/${_pkgsrcname}-${pkgver}/libconcord/bindings/python/
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+