summaryrefslogtreecommitdiffstats
path: root/abs/core/qt5/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/qt5/PKGBUILD')
-rw-r--r--abs/core/qt5/PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/abs/core/qt5/PKGBUILD b/abs/core/qt5/PKGBUILD
index 5b87698..8d7bfcb 100644
--- a/abs/core/qt5/PKGBUILD
+++ b/abs/core/qt5/PKGBUILD
@@ -30,7 +30,7 @@ pkgname=('qt5-3d'
'qt5-x11extras'
'qt5-xmlpatterns')
pkgver=5.5.1
-pkgrel=9
+pkgrel=10
arch=('i686' 'x86_64')
url='http://www.qt.io/developers'
license=('GPL3' 'LGPL' 'FDL' 'custom')
@@ -72,6 +72,10 @@ prepare() {
sed -e 's/contains(WEBENGINE_CONFIG, proprietary_codecs): //' \
-e '/use_system_ffmpeg=0"/a GYP_ARGS += "-Duse_system_yasm=1"' \
-i qtwebengine/src/core/gyp_run.pro
+
+ sed -i 's/libsystemd-journal/libsystemd/g' \
+ qtbase/src/corelib/global/global.pri \
+ qtbase/config.tests/unix/journald/journald.pro
}
build() {
@@ -146,7 +150,7 @@ package_qt5-base() {
'qtchooser' 'libinput' 'libsm' 'libxkbcommon-x11')
optdepends=('qt5-svg: to use SVG icon themes'
'postgresql-libs: PostgreSQL driver'
- 'libmysqlclient: MariaDB driver'
+ 'libmysqlclient: mysql DB driver'
'unixodbc: ODBC driver'
'libfbclient: Firebird/iBase driver'
'mtdev: evdev plugin'