summaryrefslogtreecommitdiffstats
path: root/abs/core/qt5/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/qt5/PKGBUILD')
-rw-r--r--abs/core/qt5/PKGBUILD575
1 files changed, 575 insertions, 0 deletions
diff --git a/abs/core/qt5/PKGBUILD b/abs/core/qt5/PKGBUILD
new file mode 100644
index 0000000..d16e001
--- /dev/null
+++ b/abs/core/qt5/PKGBUILD
@@ -0,0 +1,575 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgbase=qt5
+pkgname=('qt5-3d'
+ 'qt5-base'
+ 'qt5-canvas3d'
+ 'qt5-connectivity'
+ 'qt5-declarative'
+ 'qt5-doc'
+ 'qt5-enginio'
+ 'qt5-graphicaleffects'
+ 'qt5-imageformats'
+ 'qt5-location'
+ 'qt5-multimedia'
+ 'qt5-quick1'
+ 'qt5-quickcontrols'
+ 'qt5-script'
+ 'qt5-sensors'
+ 'qt5-serialport'
+ 'qt5-svg'
+ 'qt5-tools'
+ 'qt5-translations'
+ 'qt5-wayland'
+ 'qt5-webchannel'
+ 'qt5-webengine'
+ 'qt5-webkit'
+ 'qt5-websockets'
+ 'qt5-x11extras'
+ 'qt5-xmlpatterns')
+pkgver=5.5.1
+pkgrel=9
+arch=('i686' 'x86_64')
+url='http://www.qt.io/developers'
+license=('GPL3' 'LGPL' 'FDL' 'custom')
+makedepends=('libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms'
+ 'mesa' 'at-spi2-core' 'alsa-lib' 'gst-plugins-base-libs' 'libjpeg-turbo' 'cups'
+ 'hicolor-icon-theme' 'desktop-file-utils' 'postgresql-libs' 'nss'
+ 'libmariadbclient' 'sqlite' 'unixodbc' 'libfbclient' 'libmng' 'python2' 'ruby'
+ 'gperf' 'libxslt' 'libxcomposite' 'fontconfig' 'bluez-libs' 'openal' 'gtk2'
+ 'libxkbcommon-x11' 'mtdev' 'harfbuzz' 'libwebp' 'leveldb' 'geoclue' 'pciutils'
+ 'libinput' 'yasm' 'git')
+groups=('qt' 'qt5')
+_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
+source=("http://download.qt-project.org/official_releases/qt/${pkgver%.*}/${pkgver}/single/${_pkgfqn}.tar.xz"
+ 'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qdbusviewer.desktop')
+md5sums=('c2a249e8795d45200d997d96860d0353'
+ 'b2897dd6a2967bccf8f10e397aafee55'
+ '76e150b20178d2d43801f7367232e5f7'
+ '188da8f4c87316e730ebf1c6217bf5a0'
+ '322b419b16c75d4de0ee7ad0a246caa1')
+
+prepare() {
+ cd ${_pkgfqn}
+
+ # Build qmake using Arch {C,LD}FLAGS
+ # This also sets default {C,CXX,LD}FLAGS for projects built using qmake
+ sed -i -e "s|^\(QMAKE_CFLAGS_RELEASE.*\)|\1 ${CFLAGS}|" \
+ qtbase/mkspecs/common/gcc-base.conf
+ sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
+ qtbase/mkspecs/common/g++-unix.conf
+
+ # Use python2 for Python 2.x
+ find . -name '*.py' -exec sed -i \
+ 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
+ # in qtwebengine there are still a lot of relative calls which need a workaround
+ mkdir "${srcdir}"/python2-path
+ ln -s /usr/bin/python2 "${srcdir}"/python2-path/python
+
+ # Try to enable proprietary_codecs and use some system yasm
+ sed -e 's/contains(WEBENGINE_CONFIG, proprietary_codecs): //' \
+ -e '/use_system_ffmpeg=0"/a GYP_ARGS += "-Duse_system_yasm=1"' \
+ -i qtwebengine/src/core/gyp_run.pro
+}
+
+build() {
+ cd ${_pkgfqn}
+
+ export QTDIR="${srcdir}"/${_pkgfqn}
+ export LD_LIBRARY_PATH="${QTDIR}"/qtbase/lib:"${QTDIR}"/qttools/lib:"${LD_LIBRARY_PATH}"
+ export QT_PLUGIN_PATH="${QTDIR}"/qtbase/plugins
+
+ # python2 workaround
+ export PATH="${srcdir}/python2-path:$PATH"
+
+ # FS#38796
+ [[ "${CARCH}" = "i686" ]] && SSE2="-no-sse2"
+
+ PYTHON=/usr/bin/python2 ./configure -confirm-license -opensource \
+ -prefix /usr \
+ -bindir /usr/lib/qt/bin \
+ -docdir /usr/share/doc/qt \
+ -headerdir /usr/include/qt \
+ -archdatadir /usr/lib/qt \
+ -datadir /usr/share/qt \
+ -sysconfdir /etc/xdg \
+ -examplesdir /usr/share/doc/qt/examples \
+ -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
+ -system-sqlite \
+ -openssl-linked \
+ -nomake examples \
+ -no-rpath \
+ -optimized-qmake \
+ -dbus-linked \
+ -system-harfbuzz \
+ -journald \
+ -libinput ${SSE2}
+
+ make
+
+ # Fix docs build when qt is not installed
+ sed -i "s|/usr/lib/qt/bin/qdoc|${QTDIR}/qtbase/bin/qdoc|g" \
+ "${QTDIR}"/qtbase/qmake/Makefile.qmake-docs
+ find "${QTDIR}" -name Makefile \
+ -exec sed -i "s|/usr/lib/qt/bin/qdoc|${QTDIR}/qtbase/bin/qdoc|g" {} +
+ sed -i "s|/usr/lib/qt/bin/qhelpgenerator|${QTDIR}/qttools/bin/qhelpgenerator|g" \
+ "${QTDIR}"/qtbase/qmake/Makefile.qmake-docs
+ find "${QTDIR}" -name Makefile \
+ -exec sed -i "s|/usr/lib/qt/bin/qhelpgenerator|${QTDIR}/qttools/bin/qhelpgenerator|g" {} +
+ sed -i "s|/usr/lib/qt/bin/qhelpgenerator|${QTDIR}/qttools/bin/qhelpgenerator|g" \
+ qtwebkit/Source/Makefile.api
+ find "${QTDIR}" -name Makefile \
+ -exec sed -i "s|/usr/lib/qt/bin/qmlplugindump|${QTDIR}/qtdeclarative/bin/qmlplugindump|g" {} +
+
+ make docs
+}
+
+package_qt5-3d() {
+ pkgdesc='C++ and QML APIs for easy inclusion of 3D graphics'
+ depends=('qt5-declarative')
+ license=('LGPL')
+
+ cd ${_pkgfqn}/qt3d
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+}
+
+package_qt5-base() {
+ pkgdesc='A cross-platform application and UI framework'
+ depends=('libjpeg-turbo' 'xcb-util-keysyms' 'libgl' 'dbus' 'fontconfig' 'systemd'
+ 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu'
+ 'qtchooser' 'libinput' 'libsm' 'libxkbcommon-x11')
+ optdepends=('qt5-svg: to use SVG icon themes'
+ 'postgresql-libs: PostgreSQL driver'
+ 'libmariadbclient: MariaDB driver'
+ 'unixodbc: ODBC driver'
+ 'libfbclient: Firebird/iBase driver'
+ 'mtdev: evdev plugin'
+ 'gtk2: GTK2 plugin')
+ conflicts=('qt')
+
+ cd ${_pkgfqn}/qtbase
+ make INSTALL_ROOT="${pkgdir}" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Fix wrong qmake path in pri file
+ sed -i "s|${srcdir}/${_pkgfqn}/qtbase|/usr|" \
+ "${pkgdir}"/usr/lib/qt/mkspecs/modules/qt_lib_bootstrap_private.pri
+
+ # Useful symlinks
+ install -d "${pkgdir}"/usr/bin
+ for b in "${pkgdir}"/usr/lib/qt/bin/*; do
+ ln -s /usr/lib/qt/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ done
+}
+
+package_qt5-canvas3d() {
+ pkgdesc='A JavaScript 3D rendering API for Qt Quick'
+ depends=('qt5-declarative')
+ license=('LGPL')
+
+ cd ${_pkgfqn}/qtcanvas3d
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+}
+
+package_qt5-connectivity() {
+ pkgdesc='Provides access to Bluetooth hardware'
+ depends=('qt5-declarative' 'bluez-libs')
+
+ cd ${_pkgfqn}/qtconnectivity
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-declarative() {
+ pkgdesc='Classes for QML and JavaScript languages'
+ depends=('qt5-xmlpatterns')
+ conflicts=('qt')
+
+ cd ${_pkgfqn}/qtdeclarative
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Useful symlinks
+ install -d "${pkgdir}"/usr/bin
+ for b in "${pkgdir}"/usr/lib/qt/bin/*; do
+ ln -s /usr/lib/qt/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ done
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-doc() {
+ pkgdesc='A cross-platform application and UI framework (Documentation)'
+ depends=('qt5-base')
+# arch=('any')
+ conflicts=('qt-doc')
+ replaces=('qt-doc')
+ provides=('qt-doc')
+ options=('docs' '!emptydirs')
+ groups=()
+
+ cd ${_pkgfqn}
+ make INSTALL_ROOT="${pkgdir}" install_docs
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-enginio() {
+ pkgdesc='A Backend-as-a-Service solution to ease the backend development for connected and data-driven application'
+ depends=('qt5-declarative')
+
+ cd ${_pkgfqn}/qtenginio
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-graphicaleffects() {
+ pkgdesc='Graphical effects for use with Qt Quick 2'
+ depends=('qt5-declarative')
+
+ cd ${_pkgfqn}/qtgraphicaleffects
+ make INSTALL_ROOT="${pkgdir}" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-imageformats() {
+ pkgdesc='Plugins for additional image formats: TIFF, MNG, TGA, WBMP'
+ depends=('qt5-base' 'jasper' 'libmng' 'libwebp')
+ conflicts=('qt')
+
+ cd ${_pkgfqn}/qtimageformats
+ make INSTALL_ROOT="${pkgdir}" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-location() {
+ pkgdesc='Provides access to position, satellite and area monitoring classes'
+ depends=('qt5-declarative' 'geoclue')
+
+ cd ${_pkgfqn}/qtlocation
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-multimedia() {
+ pkgdesc='Classes for audio, video, radio and camera functionality'
+ depends=('qt5-declarative' 'gst-plugins-base-libs' 'openal')
+ optdepends=('gst-plugins-bad: Qt MediaService plugin')
+ conflicts=('qt')
+
+ cd ${_pkgfqn}/qtmultimedia
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-quick1() {
+ pkgdesc='Qt Declarative is provided for Qt 4 compatibility'
+ depends=('qt5-webkit' 'qt5-script')
+ conflicts=('qt')
+
+ cd ${_pkgfqn}/qtquick1
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Useful symlinks
+ install -d "${pkgdir}"/usr/bin
+ for b in "${pkgdir}"/usr/lib/qt/bin/*; do
+ ln -s /usr/lib/qt/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ done
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-quickcontrols() {
+ pkgdesc='Reusable Qt Quick based UI controls to create classic desktop-style user interfaces'
+ depends=('qt5-declarative')
+ license=('LGPL')
+
+ cd ${_pkgfqn}/qtquickcontrols
+ make INSTALL_ROOT="${pkgdir}" install
+}
+
+package_qt5-script() {
+ pkgdesc='Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility'
+ depends=('qt5-base')
+ conflicts=('qt')
+
+ cd ${_pkgfqn}/qtscript
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-sensors() {
+ pkgdesc='Provides access to sensor hardware and motion gesture recognition'
+ depends=('qt5-declarative')
+
+ cd ${_pkgfqn}/qtsensors
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-serialport() {
+ pkgdesc='Provides access to hardware and virtual serial ports'
+ depends=('qt5-base')
+
+ cd ${_pkgfqn}/qtserialport
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-svg() {
+ pkgdesc='Classes for displaying the contents of SVG files'
+ depends=('qt5-base')
+ conflicts=('qt')
+
+ cd ${_pkgfqn}/qtsvg
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-tools() {
+ pkgdesc='A cross-platform application and UI framework (Development Tools, QtHelp)'
+ depends=('qt5-webkit' 'desktop-file-utils' 'qt5-translations' 'hicolor-icon-theme'
+ 'xdg-utils')
+ optdepends=('qt5-doc: documentation')
+ install='qt5-tools.install'
+ conflicts=('qt')
+ options=('staticlibs') # libQt5UiTools builds as static only$
+
+ cd ${_pkgfqn}/qttools
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # install missing icons and desktop files
+ for icon in src/linguist/linguist/images/icons/linguist-*-32.png ; do
+ size=$(echo $(basename ${icon}) | cut -d- -f2)
+ install -p -D -m644 ${icon} \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/linguist.png"
+ done
+
+ install -D -m644 src/assistant/assistant/images/assistant.png \
+ "${pkgdir}/usr/share/icons/hicolor/32x32/apps/assistant.png"
+ install -D -m644 src/assistant/assistant/images/assistant-128.png \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/assistant.png"
+ install -D -m644 src/designer/src/designer/images/designer.png \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/QtProject-designer.png"
+ install -D -m644 src/qdbus/qdbusviewer/images/qdbusviewer.png \
+ "${pkgdir}/usr/share/icons/hicolor/32x32/apps/qdbusviewer.png"
+ install -D -m644 src/qdbus/qdbusviewer/images/qdbusviewer-128.png \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/qdbusviewer.png"
+ install -d "${pkgdir}/usr/share/applications"
+ install -m644 "${srcdir}"/{linguist,designer,assistant,qdbusviewer}.desktop \
+ "${pkgdir}/usr/share/applications/"
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Useful symlinks
+ install -d "${pkgdir}"/usr/bin
+ for b in "${pkgdir}"/usr/lib/qt/bin/*; do
+ ln -s /usr/lib/qt/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ done
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-translations() {
+ pkgdesc='A cross-platform application and UI framework (Translations)'
+ depends=('qt5-base')
+ conflicts=('qt')
+
+ cd ${_pkgfqn}/qttranslations
+ make INSTALL_ROOT="${pkgdir}" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-wayland() {
+ pkgdesc='Provides APIs for Wayland'
+ depends=('qt5-base' 'libxcomposite')
+
+ cd ${_pkgfqn}/qtwayland
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-webchannel() {
+ pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients'
+ depends=('qt5-declarative')
+
+ cd ${_pkgfqn}/qtwebchannel
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-webengine() {
+ pkgdesc='Provides support for web applications using the Chromium browser project'
+ depends=('qt5-webchannel' 'qt5-location' 'nss' 'libxtst' 'libxcursor' 'libxrandr' 'alsa-lib' 'libxcomposite')
+ license=('LGPL')
+
+ cd ${_pkgfqn}/qtwebengine
+ make INSTALL_ROOT="${pkgdir}" install
+
+ rm -rf "${pkgdir}"/usr/share/doc
+}
+
+package_qt5-webkit() {
+ pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
+ depends=('qt5-sensors' 'qt5-location' 'qt5-webchannel' 'gst-plugins-base' 'libxslt'
+ 'libxcomposite' 'libwebp')
+ optdepends=('gst-plugins-good: Webm codec support')
+ license=('GPL3' 'LGPL' 'FDL')
+
+ cd ${_pkgfqn}/qtwebkit
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Fix wrong path in pc file
+ perl -pi -e "s, -L${srcdir}/?\S+,,g" "${pkgdir}"/usr/lib/pkgconfig/Qt5WebKit.pc
+}
+
+package_qt5-websockets() {
+ pkgdesc='Provides WebSocket communication compliant with RFC 6455'
+ depends=('qt5-declarative')
+
+ cd ${_pkgfqn}/qtwebsockets
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-x11extras() {
+ pkgdesc='Provides platform-specific APIs for X11'
+ depends=('qt5-base')
+
+ cd ${_pkgfqn}/qtx11extras
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}
+
+package_qt5-xmlpatterns() {
+ pkgdesc='Support for XPath, XQuery, XSLT and XML schema validation'
+ depends=('qt5-base')
+ conflicts=('qt')
+
+ cd ${_pkgfqn}/qtxmlpatterns
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Useful symlinks
+ install -d "${pkgdir}"/usr/bin
+ for b in "${pkgdir}"/usr/lib/qt/bin/*; do
+ ln -s /usr/lib/qt/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ done
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}