summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
l---------abs/core/runit-scripts/runit-scripts-2.1.1-22.src.tar.gz1
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/lighttpd/run7
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mythexport/finish4
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mythexport/run10
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/smartd/run11
6 files changed, 24 insertions, 11 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index f6cace4..828e54c 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=2.1.1
-pkgrel=22
+pkgrel=25
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runit-scripts-2.1.1-22.src.tar.gz b/abs/core/runit-scripts/runit-scripts-2.1.1-22.src.tar.gz
deleted file mode 120000
index 9fba9d2..0000000
--- a/abs/core/runit-scripts/runit-scripts-2.1.1-22.src.tar.gz
+++ /dev/null
@@ -1 +0,0 @@
-/data/pkg_repo/packages/runit-scripts-2.1.1-22.src.tar.gz \ No newline at end of file
diff --git a/abs/core/runit-scripts/runitscripts/services/lighttpd/run b/abs/core/runit-scripts/runitscripts/services/lighttpd/run
index 798690c..f9c574d 100755
--- a/abs/core/runit-scripts/runitscripts/services/lighttpd/run
+++ b/abs/core/runit-scripts/runitscripts/services/lighttpd/run
@@ -4,5 +4,10 @@ export TERM=linux
. /etc/rc.d/functions
stat_runit "Starting lighttpd"
+if [ ! -d /var/run/lighttpd ] ; then
+ mkdir -p /var/run/lighttpd
+ chown http /var/run/lighttpd
+fi
-exec /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
+# Using -angel to start lighttpd allows lighttpd to accept signals
+exec /usr/sbin/lighttpd-angel -D -f /etc/lighttpd/lighttpd.conf
diff --git a/abs/core/runit-scripts/runitscripts/services/mythexport/finish b/abs/core/runit-scripts/runitscripts/services/mythexport/finish
new file mode 100755
index 0000000..b7fa7a6
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/mythexport/finish
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+# runit only knows about the run script wrapper, so kill the daemon ourselves
+ kill `pidof -o %PPID -x /usr/bin/mythexport-daemon` >/dev/null 2>&1
diff --git a/abs/core/runit-scripts/runitscripts/services/mythexport/run b/abs/core/runit-scripts/runitscripts/services/mythexport/run
new file mode 100755
index 0000000..45f77fd
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/mythexport/run
@@ -0,0 +1,10 @@
+#!/bin/bash
+
+/sbin/chpst -u mythtv /usr/bin/mythexport-daemon
+
+PID=`pidof -o %PPID -x /usr/bin/mythexport-daemon`
+
+# Wait until daemon dies, else runit can't supervise us
+ while [ "`pidof -o %PPID -x /usr/bin/mythexport-daemon`" == "$PID" ]; do
+ sleep 2
+ done
diff --git a/abs/core/runit-scripts/runitscripts/services/smartd/run b/abs/core/runit-scripts/runitscripts/services/smartd/run
index 15ed769..b8eafb6 100755
--- a/abs/core/runit-scripts/runitscripts/services/smartd/run
+++ b/abs/core/runit-scripts/runitscripts/services/smartd/run
@@ -3,11 +3,6 @@
. /etc/rc.conf
. /etc/rc.d/functions
- stat_runit "Starting smartd"
- /usr/sbin/smartd -n -c /etc/smartd.conf -q never &>/dev/null
- if [ $? -ne 0 ]; then
- stat_fail
- else
- add_daemon smartd
- stat_done
- fi
+stat_runit "Starting smartd"
+
+ exec /usr/sbin/smartd -n -c /etc/smartd.conf -q never &>/dev/null