summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD4
-rwxr-xr-xabs/core/runit-scripts/runit.install6
-rwxr-xr-xabs/core/runit-scripts/runitscripts/16
-rwxr-xr-xabs/core/runit-scripts/runitscripts/36
-rw-r--r--abs/core/runit-scripts/runitscripts/services/irexec/run14
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mythexpress/run2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/pwrstatd/run8
-rw-r--r--abs/core/runit-scripts/runitscripts/services/xvnc/run17
8 files changed, 58 insertions, 5 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index fd78f72..de02476 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
-pkgver=8.2
-pkgrel=3
+pkgver=8.3
+pkgrel=6
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runit.install b/abs/core/runit-scripts/runit.install
index 4ec6a9f..3cf5036 100755
--- a/abs/core/runit-scripts/runit.install
+++ b/abs/core/runit-scripts/runit.install
@@ -39,6 +39,12 @@ post_upgrade(){
then
rm -r /etc/sv/lircd
fi
+
+ # add irexec
+ if [ -e /service/remotes ] && [ ! -e /service/irexec ]
+ then
+ add_service.sh irexec
+ fi
}
diff --git a/abs/core/runit-scripts/runitscripts/1 b/abs/core/runit-scripts/runitscripts/1
index 9f92530..05c3707 100755
--- a/abs/core/runit-scripts/runitscripts/1
+++ b/abs/core/runit-scripts/runitscripts/1
@@ -55,4 +55,10 @@ run_hook multi_start
mountpoint -q /proc/sys/fs/binfmt_misc || mount /proc/sys/fs/binfmt_misc &>/dev/null || mount -t binfmt_misc binfmt /proc/sys/fs/binfmt_misc
/usr/lib/systemd/systemd-binfmt
+# Stop bootlogd and clean up /var/log/boot
+bootlogd_stop
+sed -i -r -e 's/\^\[\[[0-9]?;?[0-9]?[0-9]?;?[0-9]?[0-9]?[ms]//g' \
+ -e 's/\^\[(\[1?[0-9]1|%)G//g' -e 's/\^\[\[0;1//g' \
+ -e 's/\^\[(\[?[0-9]{1,})G//g' /var/log/boot
+
rm -f /run/nologin
diff --git a/abs/core/runit-scripts/runitscripts/3 b/abs/core/runit-scripts/runitscripts/3
index 062f2c6..2a9fb0d 100755
--- a/abs/core/runit-scripts/runitscripts/3
+++ b/abs/core/runit-scripts/runitscripts/3
@@ -13,6 +13,10 @@ if [ -e "$pidfile" ]; then
plypid=`cat "$pidfile"`
if [ -n "$plypid" ]; then
kill -s CONT "$plypid"
+ plymouthd --mode=shutdown --pid-file=/run/plymouthd
+ plymouth --show-splash
+ kill "$plypid"
+ add_omit_pids `cat /run/plymouthd`
fi
fi
@@ -42,6 +46,4 @@ ethtool -s eth0 wol g 2>/dev/null
ethtool -s eth1 wol g 2>/dev/null
ethtool -s eth2 wol g 2>/dev/null
-plymouth quit --retain-splash
-
/etc/rc.shutdown
diff --git a/abs/core/runit-scripts/runitscripts/services/irexec/run b/abs/core/runit-scripts/runitscripts/services/irexec/run
new file mode 100644
index 0000000..01b775a
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/irexec/run
@@ -0,0 +1,14 @@
+#!/bin/sh
+exec 2>&1
+export TERM=linux
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+. /etc/profile
+
+if [[ -z $(pidof lircd) ]]; then
+ stat_runit "No lircd process, can't start irexec"
+else
+ stat_runit "Starting irexec"
+ exec /usr/bin/irexec /etc/lircrc
+fi
diff --git a/abs/core/runit-scripts/runitscripts/services/mythexpress/run b/abs/core/runit-scripts/runitscripts/services/mythexpress/run
index 06e4a1b..05c9b17 100755
--- a/abs/core/runit-scripts/runitscripts/services/mythexpress/run
+++ b/abs/core/runit-scripts/runitscripts/services/mythexpress/run
@@ -5,4 +5,4 @@ export TERM=linux
. /etc/rc.d/functions
/usr/bin/svwaitup -s 10 /service/avahi
stat_runit "Starting MythExpress"
-exec chpst -u http node /usr/mythexpress/app.js
+exec chpst -u http node /usr/mythexpress/mythexpress.js
diff --git a/abs/core/runit-scripts/runitscripts/services/pwrstatd/run b/abs/core/runit-scripts/runitscripts/services/pwrstatd/run
new file mode 100755
index 0000000..3b9c029
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/pwrstatd/run
@@ -0,0 +1,8 @@
+#!/bin/sh
+exec 2>&1
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+stat_runit "Starting CyberPower PowerPanel Daemon"
+exec /usr/bin/pwrstatd
diff --git a/abs/core/runit-scripts/runitscripts/services/xvnc/run b/abs/core/runit-scripts/runitscripts/services/xvnc/run
new file mode 100644
index 0000000..c1ef573
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/xvnc/run
@@ -0,0 +1,17 @@
+#!/bin/sh
+exec 2>&1
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+sv start frontend || exit 1
+
+stat_runit "Starting x11vnc"
+. /etc/systemconfig
+if [ -e /etc/x11vnc.cfg ]
+then
+ . /etc/x11vnc.cfg
+ exec chpst -umythtv x11vnc $x11vnc_options
+else
+ exec chpst -umythtv x11vnc -forever -rfbport 5902 --passwd $xvncpassword
+fi