summaryrefslogtreecommitdiffstats
path: root/abs/core/squashfs-tools
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/squashfs-tools')
-rw-r--r--abs/core/squashfs-tools/PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/abs/core/squashfs-tools/PKGBUILD b/abs/core/squashfs-tools/PKGBUILD
index ddbf5df..53db5b2 100644
--- a/abs/core/squashfs-tools/PKGBUILD
+++ b/abs/core/squashfs-tools/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 65461 2012-02-21 05:55:21Z spupykin $
+# $Id: PKGBUILD 91959 2013-05-30 09:44:39Z spupykin $
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Aaron Griffin <aaron@archlinux.org>
# Original TU: Jeff Mickey <j@codemac.net>
@@ -6,24 +6,22 @@
pkgname=squashfs-tools
pkgver=4.2
-pkgrel=2
+pkgrel=4
pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
url="http://squashfs.sourceforge.net"
license=("GPL")
arch=('i686' 'x86_64')
depends=('zlib' 'lzo2' 'xz')
source=("http://downloads.sourceforge.net/sourceforge/squashfs/squashfs${pkgver}.tar.gz")
-md5sums=('1b7a781fb4cf8938842279bd3e8ee852')
build() {
cd ${srcdir}/squashfs${pkgver}/${pkgname}
- sed -i 's|^#XZ_SUPPORT = 1|XZ_SUPPORT = 1|' Makefile
- sed -i 's|^#LZO_SUPPORT = 1|LZO_SUPPORT = 1|' Makefile
- make
+ make XZ_SUPPORT=1 LZO_SUPPORT=1 LZMA_XZ_SUPPORT=1
}
package() {
cd ${srcdir}/squashfs${pkgver}/${pkgname}
- install -Dm755 mksquashfs ${pkgdir}/sbin/mksquashfs
- install -m755 unsquashfs ${pkgdir}/sbin/unsquashfs
+ install -Dm755 mksquashfs ${pkgdir}/usr/bin/mksquashfs
+ install -m755 unsquashfs ${pkgdir}/usr/bin/unsquashfs
}
+md5sums=('1b7a781fb4cf8938842279bd3e8ee852')