summaryrefslogtreecommitdiffstats
path: root/abs/core/sysvinit/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/sysvinit/PKGBUILD')
-rw-r--r--abs/core/sysvinit/PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/abs/core/sysvinit/PKGBUILD b/abs/core/sysvinit/PKGBUILD
index c3ba701..27d5a09 100644
--- a/abs/core/sysvinit/PKGBUILD
+++ b/abs/core/sysvinit/PKGBUILD
@@ -1,6 +1,5 @@
-# $Id: PKGBUILD 92996 2010-10-02 19:26:38Z eric $
+# $Id: PKGBUILD 162726 2012-06-29 06:27:09Z bluewind $
# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: judd <jvinet@zeroflux.org>
pkgname=sysvinit
pkgver=2.88
@@ -10,33 +9,43 @@ arch=('i686' 'x86_64')
url="http://savannah.nongnu.org/projects/sysvinit"
license=('GPL')
groups=('base')
-depends=('shadow' 'util-linux' 'coreutils' 'glibc' 'awk' 'poweroff-scripts')
-source=(http://download.savannah.gnu.org/releases/sysvinit/${pkgname}-${pkgver}dsf.tar.bz2 halt-init.patch)
+depends=('util-linux' 'coreutils' 'glibc' 'awk' 'poweroff-scripts')
+install=sysvinit.install
+source=(http://download.savannah.gnu.org/releases/sysvinit/${pkgname}-${pkgver}dsf.tar.bz2
+ "0001-simplify-writelog.patch"
+ "0002-remove-ansi-escape-codes-from-log-file.patch"
+ "halt_init.patch")
build() {
cd "${srcdir}/${pkgname}-${pkgver}dsf"
- patch -p0 < ${srcdir}/halt-init.patch
- make || return 1
+
+ # FS#30005
+ patch -p1 -d "src" -i "${srcdir}/0001-simplify-writelog.patch"
+ patch -p1 -d "src" -i "${srcdir}/0002-remove-ansi-escape-codes-from-log-file.patch"
+ patch -p0 < ${srcdir}/halt_init.patch
+ make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}dsf"
make ROOT="${pkgdir}" install
+ # mountpoint is now provided by util-linux instead
+ cd "${pkgdir}"
+ rm bin/mountpoint
+ rm usr/share/man/man1/mountpoint.1
+
# Rename some stuff so it does not bigfoot changes needed for runit
cd "${pkgdir}/sbin"
rm -f reboot poweroff
- #These will be created in the poweroff-scripts post-install section
- #This should be removed when moving to 64 and we have no legacy to worry about
- #ln -s halt.init reboot.init
- #ln -s halt.init poweroff.init
-
-
-
mv halt halt.init
mv shutdown shutdown.init
+
+
}
md5sums=('6eda8a97b86e0a6f59dabbf25202aa6f'
- 'cd4c5767f63ca5881e3e1f1c4f10f896')
+ 'e3e82a3a38415518f52f78a622ef0262'
+ '04f0ab28340df08bb47d066669bc4519'
+ 'aec0de91c1d2f56e78393d400fd238a7')