summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/LinHES-config/PKGBUILD4
-rwxr-xr-xabs/core/LinHES-config/mv_install.py2
-rw-r--r--abs/core/bash/PKGBUILD2
-rw-r--r--abs/core/gmp/PKGBUILD2
-rw-r--r--abs/core/heimdal/PKGBUILD2
-rw-r--r--abs/core/imagemagick/PKGBUILD7
-rw-r--r--abs/core/libgcrypt/PKGBUILD2
-rw-r--r--abs/core/linux-firmware/PKGBUILD2
-rw-r--r--abs/core/pacman/PKGBUILD10
-rw-r--r--abs/core/pacman/__changelog1
-rw-r--r--abs/core/pacman/pacman.conf2
-rw-r--r--abs/core/readline/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mdadm/run10
-rw-r--r--abs/core/tar/PKGBUILD2
-rw-r--r--abs/core/wget/PKGBUILD2
-rw-r--r--abs/core/xorg-apps/PKGBUILD84
-rw-r--r--abs/core/xorg-x11perf/PKGBUILD23
-rw-r--r--abs/core/xorg-xcursorgen/PKGBUILD23
-rw-r--r--abs/core/xorg-xcursorgen/xorg-xkill/PKGBUILD23
-rw-r--r--abs/core/xorg-xpr/PKGBUILD26
-rw-r--r--abs/core/xorg-xpr/copyright.patch75
-rw-r--r--abs/core/xorg-xwd/PKGBUILD23
-rw-r--r--abs/core/xorg-xwud/PKGBUILD23
24 files changed, 250 insertions, 104 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index cb88b63..880f707 100644
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.2
-pkgrel=10
+pkgrel=11
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -101,7 +101,7 @@ build() {
install -m 0755 issue $startdir/pkg/etc/issue
}
-md5sums=('c2362d1b5d0f2c64a2d0b32877ce8236'
+md5sums=('0f2d8f75fa96f9a1acbdca582560e889'
'1a4694fcd694b362c339bda781ed0f3e'
'e36da536dd651ef182e7642337889e77'
'985891a43f7c4c983eb2a362162f1a0f'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index ac6aa7d..1bacdd4 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -508,6 +508,8 @@ def copy_it(install_type):
runcmd(cmd)
cmd = "rm %s/etc/mkinitcpio.d/larch*" %(data_config.MOUNTPOINT)
runcmd(cmd)
+ cmd = "rm %s/etc/rc.d/functions.d/*larch*" %(data_config.MOUNTPOINT)
+ runcmd(cmd)
logging.debug("__End of copy_it__")
def create_fstab(extralines):
diff --git a/abs/core/bash/PKGBUILD b/abs/core/bash/PKGBUILD
index 96c24a1..7c7eaca 100644
--- a/abs/core/bash/PKGBUILD
+++ b/abs/core/bash/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=bash
_patchlevel=007 #prepare for some patches
pkgver=4.1.$_patchlevel
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Bourne Again shell"
arch=('i686' 'x86_64')
license=('GPL')
diff --git a/abs/core/gmp/PKGBUILD b/abs/core/gmp/PKGBUILD
index 0eee2df..1a0d9c3 100644
--- a/abs/core/gmp/PKGBUILD
+++ b/abs/core/gmp/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gmp
pkgver=5.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A free library for arbitrary precision arithmetic"
arch=('i686' 'x86_64')
url="http://gmplib.org/"
diff --git a/abs/core/heimdal/PKGBUILD b/abs/core/heimdal/PKGBUILD
index 2074973..6fcf6a5 100644
--- a/abs/core/heimdal/PKGBUILD
+++ b/abs/core/heimdal/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=heimdal
pkgver=1.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="Implementation of Kerberos V5 libraries"
arch=('i686' 'x86_64')
url="http://www.h5l.org/"
diff --git a/abs/core/imagemagick/PKGBUILD b/abs/core/imagemagick/PKGBUILD
index 37fbe16..c02552b 100644
--- a/abs/core/imagemagick/PKGBUILD
+++ b/abs/core/imagemagick/PKGBUILD
@@ -3,8 +3,8 @@
# Maintainer: DAniel J Griffiths <ghost1227@archlinux.us>
pkgname=imagemagick
-pkgver=6.6.5.7
-pkgrel=3
+pkgver=6.6.5.10
+pkgrel=1
pkgdesc="An image viewing/manipulation program"
arch=('i686' 'x86_64')
url="http://www.imagemagick.org/"
@@ -55,3 +55,6 @@ package() {
md5sums=('dd8ae557c11472df1a5643c7d1e24c33'
'069980fc2590c02aed86420996259302'
'ff9974decbfe9846f8e347239d87e4eb')
+md5sums=('973d2f13d0daffa7fe2efc9d080e0b04'
+ '069980fc2590c02aed86420996259302'
+ 'ff9974decbfe9846f8e347239d87e4eb')
diff --git a/abs/core/libgcrypt/PKGBUILD b/abs/core/libgcrypt/PKGBUILD
index c262700..2f27ff0 100644
--- a/abs/core/libgcrypt/PKGBUILD
+++ b/abs/core/libgcrypt/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=libgcrypt
pkgver=1.4.6
-pkgrel=1
+pkgrel=2
pkgdesc="a general purpose crypto library based on the code used"
arch=(i686 x86_64)
url="http://www.gnupg.org"
diff --git a/abs/core/linux-firmware/PKGBUILD b/abs/core/linux-firmware/PKGBUILD
index c1a32bb..30925a4 100644
--- a/abs/core/linux-firmware/PKGBUILD
+++ b/abs/core/linux-firmware/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=linux-firmware
pkgver=20100623
-pkgrel=2
+pkgrel=3
pkgdesc="Firmware files for Linux"
arch=('any')
url="http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=summary"
diff --git a/abs/core/pacman/PKGBUILD b/abs/core/pacman/PKGBUILD
index 1f80018..2d4f776 100644
--- a/abs/core/pacman/PKGBUILD
+++ b/abs/core/pacman/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pacman
pkgver=3.4.1
-pkgrel=2
+pkgrel=3
pkgdesc="A library-based package manager with dependency support"
arch=('i686' 'x86_64')
url="http://www.archlinux.org/pacman/"
@@ -19,10 +19,6 @@ source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
pacman.conf
pacman.conf.x86_64
makepkg.conf)
-md5sums=('4e4e8e4f636d9878fbed9cf840f162cf'
- 'eda9cbdb47f85fabda2e7e63801e3e16'
- '9ba146b4fa7bcb3cc18204b06d1f6157'
- 'aef317285c7d16ac495b0e53deeb948d')
# keep an upgrade path for older installations
PKGEXT='.pkg.tar.gz'
@@ -74,3 +70,7 @@ package() {
}
# vim: set ts=2 sw=2 et:
+md5sums=('4e4e8e4f636d9878fbed9cf840f162cf'
+ '4792e61cd1b902d20046e19f97ae758d'
+ '9ba146b4fa7bcb3cc18204b06d1f6157'
+ 'aef317285c7d16ac495b0e53deeb948d')
diff --git a/abs/core/pacman/__changelog b/abs/core/pacman/__changelog
new file mode 100644
index 0000000..4d2a9e3
--- /dev/null
+++ b/abs/core/pacman/__changelog
@@ -0,0 +1 @@
+make cache dir /data/var/cache/pacman/pkg
diff --git a/abs/core/pacman/pacman.conf b/abs/core/pacman/pacman.conf
index 3a5d875..c44d2e6 100644
--- a/abs/core/pacman/pacman.conf
+++ b/abs/core/pacman/pacman.conf
@@ -11,7 +11,7 @@
# If you wish to use different paths, uncomment and update the paths.
#RootDir = /
#DBPath = /var/lib/pacman/
-#CacheDir = /var/cache/pacman/pkg/
+CacheDir = /data/var/cache/pacman/pkg/
#LogFile = /var/log/pacman.log
HoldPkg = pacman glibc
# If upgrades are available for these packages they will be asked for first
diff --git a/abs/core/readline/PKGBUILD b/abs/core/readline/PKGBUILD
index 489b22f..24126df 100644
--- a/abs/core/readline/PKGBUILD
+++ b/abs/core/readline/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=readline
_patchlevel=002 #prepare for some patches
pkgver=6.1.$_patchlevel
-pkgrel=1
+pkgrel=2
pkgdesc="GNU readline library"
arch=(i686 x86_64)
url="http://tiswww.case.edu/php/chet/readline/rltop.html"
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 174bf69..0c914f5 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=2.1.1
-pkgrel=4
+pkgrel=6
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/mdadm/run b/abs/core/runit-scripts/runitscripts/services/mdadm/run
deleted file mode 100755
index 567332e..0000000
--- a/abs/core/runit-scripts/runitscripts/services/mdadm/run
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/bash
-#
-# Start Monitoring software raid arrays
-exec 2>&1
-export TERM=linux
-. /etc/rc.conf
-. /etc/rc.d/functions
-
- stat_runit "Starting mdadm RAID Monitor"
- exec /sbin/mdadm -F -s
diff --git a/abs/core/tar/PKGBUILD b/abs/core/tar/PKGBUILD
index 9c16ddf..c7c9f74 100644
--- a/abs/core/tar/PKGBUILD
+++ b/abs/core/tar/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=tar
pkgver=1.23
-pkgrel=1
+pkgrel=2
pkgdesc="Utility used to store, backup, and transport files"
arch=('i686' 'x86_64')
license=('GPL3')
diff --git a/abs/core/wget/PKGBUILD b/abs/core/wget/PKGBUILD
index 1ef6911..eb13f03 100644
--- a/abs/core/wget/PKGBUILD
+++ b/abs/core/wget/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=wget
pkgver=1.12
-pkgrel=2
+pkgrel=3
pkgdesc="A network utility to retrieve files from the Web"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/wget/wget.html"
diff --git a/abs/core/xorg-apps/PKGBUILD b/abs/core/xorg-apps/PKGBUILD
index b36c4f3..a80ceb5 100644
--- a/abs/core/xorg-apps/PKGBUILD
+++ b/abs/core/xorg-apps/PKGBUILD
@@ -1,82 +1,16 @@
-# $Id: PKGBUILD 65057 2010-01-24 04:35:40Z eric $
+# $Id: PKGBUILD 96980 2010-10-25 20:36:12Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=xorg-apps
-pkgver=7.5
-pkgrel=3
-pkgdesc="Various X.Org applications"
-arch=(i686 x86_64)
+pkgver=7.6
+pkgrel=1
+pkgdesc="Transition package depending on various X.Org applications"
+arch=(any)
url="http://xorg.freedesktop.org/"
-license=('custom')
-depends=(libxcursor libxkbfile 'libpng>=1.4.0' libxft libfontenc libxaw)
-makedepends=(pkgconfig xbitmaps)
-source=(${url}/releases/individual/app/oclock-1.0.1.tar.bz2
- ${url}/releases/individual/app/luit-1.0.4.tar.bz2
- ${url}/releases/individual/app/xclock-1.0.4.tar.bz2
- ${url}/releases/individual/app/xpr-1.0.3.tar.bz2
- ${url}/releases/individual/app/xwd-1.0.3.tar.bz2
- ${url}/releases/individual/app/xwud-1.0.2.tar.bz2
- ${url}/releases/individual/app/x11perf-1.5.1.tar.bz2
- ${url}/releases/individual/app/xbiff-1.0.2.tar.bz2
- ${url}/releases/individual/app/xclipboard-1.1.0.tar.bz2
- ${url}/releases/individual/app/xconsole-1.0.3.tar.bz2
- ${url}/releases/individual/app/xcursorgen-1.0.3.tar.bz2
- ${url}/releases/individual/app/xeyes-1.1.0.tar.bz2
- ${url}/releases/individual/app/xkill-1.0.2.tar.bz2
- ${url}/releases/individual/app/xload-1.0.2.tar.bz2
- ${url}/releases/individual/app/xlogo-1.0.2.tar.bz2
- ${url}/releases/individual/app/xmag-1.0.3.tar.bz2
- ${url}/releases/individual/app/xmessage-1.0.2.tar.bz2
- ${url}/releases/individual/app/xcalc-1.0.3.tar.bz2
- ${url}/releases/individual/app/xman-1.1.0.tar.bz2
- ${url}/releases/individual/app/xedit-1.1.2.tar.bz2
- LICENSE)
-md5sums=('91f49547f9ed3cd0137c8b7c3183e360'
- '4e45233e310d72dce307709761cf241b'
- 'bb9fd5e00d39c348a0078b97fdf8258f'
- '1c2c540d240def3ea65ff2030f059f8a'
- '007cea1f389abde5c93162dcd5541351'
- '20bc5d85634964d4ceee77cdfcd131ed'
- '66e4aa4645f83809071eb69553ed0222'
- '1d4ad06725f9dc4b877ecd210b7b1607'
- '113eccea3ee73a1ef7b43d2291ca1e09'
- '0e1a3110bebabecc2897d67a973526b0'
- '69df079b3950a0db4e5f4e6f0e00ddee'
- '933f6d2b132d14f707f1f3c87b39ebe2'
- 'dca031355b4afcf8517a8258eeb730c3'
- 'b41ed6b4bcfc9897366c27a94d2bf150'
- '7365c0852750134119734bc1879f60ca'
- '32f7ed4c089365cadb9382f6fbd750a9'
- 'b4b561ef11fd184989a6062962e86748'
- '0b981e360b54584fcb6dc2ec4658c406'
- '5e5b3351bac26cc1f8490faf1c1402bb'
- '67193be728414d45a1922911e6437991'
- '1a3977bcff6dc0fc1086e0650fcea31a')
+license=('GPL')
+depends=('xorg-luit' 'xorg-xpr' 'xorg-xwd' 'xorg-xwud' 'xorg-x11perf' 'xorg-xcursorgen' 'xorg-xkill')
+#removed: oclock xclock xbiff xclipboard xconsole xeyes xload xlogo xmag xmessage xcalc xman xedit
build() {
- cd "${srcdir}"
- for i in *; do
- if [ -d "${i}" ]; then
- pushd "${i}"
- case "${i}" in
- x11perf*)
- sed -e 's|^LIBPATH = $(libdir)|LIBPATH = $(datadir)|' \
- -i Makefile.* || return 1
- ;;
- xedit*)
- sed -e 's|^XEDITDIR = ${libdir}|XEDITDIR = ${datadir}|' \
- -i Makefile.* || return 1
- ;;
- xcursorgen*)
- sed -e 's/libpng12/libpng14/g' -i configure
- ;;
- esac
- ./configure --prefix=/usr --disable-xprint --mandir=/usr/share/man \
- --with-localealiasfile=/usr/share/X11/locale/locale.alias
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- popd
- fi
- done
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ return 0
}
diff --git a/abs/core/xorg-x11perf/PKGBUILD b/abs/core/xorg-x11perf/PKGBUILD
new file mode 100644
index 0000000..8f5d144
--- /dev/null
+++ b/abs/core/xorg-x11perf/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-x11perf
+pkgver=1.5.2
+pkgrel=1
+pkgdesc="Simple X server performance benchmarker"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11' 'libxmu' 'libxrender' 'libxft' 'libxext')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/x11perf-${pkgver}.tar.bz2)
+sha1sums=('ca693d23cd343df51baac76e693e769ce5ef6a30')
+
+build() {
+ cd "${srcdir}/x11perf-${pkgver}"
+ ./configure --prefix=/usr
+ make
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xcursorgen/PKGBUILD b/abs/core/xorg-xcursorgen/PKGBUILD
new file mode 100644
index 0000000..c2a5ba5
--- /dev/null
+++ b/abs/core/xorg-xcursorgen/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xcursorgen
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Create an X cursor file from PNG images"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11' 'libxcursor' 'libpng')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xcursorgen-${pkgver}.tar.bz2)
+sha1sums=('244c180aae8cc07175b93f314d5bbbf24171658a')
+
+build() {
+ cd "${srcdir}/xcursorgen-${pkgver}"
+ ./configure --prefix=/usr
+ make
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xcursorgen/xorg-xkill/PKGBUILD b/abs/core/xorg-xcursorgen/xorg-xkill/PKGBUILD
new file mode 100644
index 0000000..10f354d
--- /dev/null
+++ b/abs/core/xorg-xcursorgen/xorg-xkill/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xkill
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Kill a client by its X resource"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11' 'libxmu')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xkill-${pkgver}.tar.bz2)
+sha1sums=('bab7b9c7f3bc053d743eb339cf5fa496bace57e5')
+
+build() {
+ cd "${srcdir}/xkill-${pkgver}"
+ ./configure --prefix=/usr
+ make
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xpr/PKGBUILD b/abs/core/xorg-xpr/PKGBUILD
new file mode 100644
index 0000000..63a7b59
--- /dev/null
+++ b/abs/core/xorg-xpr/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xpr
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Print an X window dump from xwd"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11' 'libxmu')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xpr-${pkgver}.tar.bz2
+ copyright.patch)
+sha1sums=('9dbd0ff136b612285e00d92d0c7675a4207b1c4a'
+ 'd2649781330400b83cf3553d9cfd6e02dd93a2bd')
+
+build() {
+ cd "${srcdir}/xpr-${pkgver}"
+ patch -Np1 -i "${srcdir}/copyright.patch"
+ ./configure --prefix=/usr
+ make
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xpr/copyright.patch b/abs/core/xorg-xpr/copyright.patch
new file mode 100644
index 0000000..18e7182
--- /dev/null
+++ b/abs/core/xorg-xpr/copyright.patch
@@ -0,0 +1,75 @@
+From 11569289123fb178e23fd1aa284e9fa10e6c1e8c Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Fri, 06 Aug 2010 22:09:48 +0000
+Subject: Fill in COPYING file with copyright notices from source code
+
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+diff --git a/COPYING b/COPYING
+index 7f33cbf..0f9d8e0 100644
+--- a/COPYING
++++ b/COPYING
+@@ -1,12 +1,53 @@
+-This is a stub file. This package has not yet had its complete licensing
+-information compiled. Please see the individual source files for details on
+-your rights to use and modify this software.
+
+-Please submit updated COPYING files to the Xorg bugzilla:
++Copyright (c) 1985, 1988 X Consortium
+
+-https://bugs.freedesktop.org/enter_bug.cgi?product=xorg
++Permission is hereby granted, free of charge, to any person obtaining
++a copy of this software and associated documentation files (the
++"Software"), to deal in the Software without restriction, including
++without limitation the rights to use, copy, modify, merge, publish,
++distribute, sublicense, and/or sell copies of the Software, and to
++permit persons to whom the Software is furnished to do so, subject to
++the following conditions:
+
+-All licensing questions regarding this software should be directed at the
+-Xorg mailing list:
++The above copyright notice and this permission notice shall be included
++in all copies or substantial portions of the Software.
+
+-http://lists.freedesktop.org/mailman/listinfo/xorg
++THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
++OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
++MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
++IN NO EVENT SHALL THE X CONSORTIUM BE LIABLE FOR ANY CLAIM, DAMAGES OR
++OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++OTHER DEALINGS IN THE SOFTWARE.
++
++Except as contained in this notice, the name of the X Consortium shall
++not be used in advertising or otherwise to promote the sale, use or
++other dealings in this Software without prior written authorization
++from the X Consortium.
++
++Copyright 1986 by Marvin Solomon and the University of Wisconsin
++
++Permission to use, copy, modify, and distribute this
++software and its documentation for any purpose and without
++fee is hereby granted, provided that the above copyright
++notice appear in all copies and that both that copyright
++notice and this permission notice appear in supporting
++documentation, and that the names of Marvin Solomon and
++the University of Wisconsin not be used in
++advertising or publicity pertaining to distribution of the
++software without specific, written prior permission.
++Neither Marvin Solomon nor the University of Wisconsin
++makes any representations about the suitability of
++this software for any purpose. It is provided "as is"
++without express or implied warranty.
++
++Copyright (c) 1988 by Hewlett-Packard Company
++
++Permission to use, copy, modify, and distribute this software
++and its documentation for any purpose and without fee is hereby
++granted, provided that the above copyright notice appear in all
++copies and that both that copyright notice and this permission
++notice appear in supporting documentation, and that
++Hewlett-Packard not be used in advertising or publicity
++pertaining to distribution of the software without specific, written
++prior permission.
+--
+cgit v0.8.3-6-g21f6
diff --git a/abs/core/xorg-xwd/PKGBUILD b/abs/core/xorg-xwd/PKGBUILD
new file mode 100644
index 0000000..6586725
--- /dev/null
+++ b/abs/core/xorg-xwd/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xwd
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="X Window System image dumping utility"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xwd-${pkgver}.tar.bz2)
+sha1sums=('4ef4fd9072a507e9a1ee88ba1d28b314006cc109')
+
+build() {
+ cd "${srcdir}/xwd-${pkgver}"
+ ./configure --prefix=/usr
+ make
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/core/xorg-xwud/PKGBUILD b/abs/core/xorg-xwud/PKGBUILD
new file mode 100644
index 0000000..7ed437a
--- /dev/null
+++ b/abs/core/xorg-xwud/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xwud
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="X Window System image undumping utility"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11')
+makedepends=('xorg-util-macros')
+source=(http://xorg.freedesktop.org/archive/individual/app/xwud-${pkgver}.tar.bz2)
+sha1sums=('2e706d50c7039e3daa4963d36ab703e48aa652ed')
+
+build() {
+ cd "${srcdir}/xwud-${pkgver}"
+ ./configure --prefix=/usr
+ make
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}