summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/initscripts/PKGBUILD4
-rw-r--r--abs/core/initscripts/rc.sysinit.patch8
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD4
-rwxr-xr-xabs/core/runit-scripts/fbsplash-runit.sh24
-rwxr-xr-xabs/core/runit-scripts/runitscripts/37
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/lircd/run3
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/netfs/run3
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/nfs-common/run12
8 files changed, 41 insertions, 24 deletions
diff --git a/abs/core/initscripts/PKGBUILD b/abs/core/initscripts/PKGBUILD
index 8b22768..7796aa9 100644
--- a/abs/core/initscripts/PKGBUILD
+++ b/abs/core/initscripts/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=initscripts
pkgver=2011.06.4
-pkgrel=5
+pkgrel=6
pkgdesc="System initialization/bootup scripts"
arch=('i686' 'x86_64')
url="http://www.archlinux.org"
@@ -33,7 +33,7 @@ package() {
}
md5sums=('34cbe55f3f42069c59237db935d0511b'
'027576534885b8d5dded9be546057b12'
- 'c9a39df704ad5332ef794ea3630252e5'
+ 'cd80b66cfc84fac0d52a5601b2eb55af'
'73abaf06450104bddf16d409015f81ab'
'a166ea014a1c75860b14fc98825686cc'
'521bbd001633d14b08e5471bea584ee4')
diff --git a/abs/core/initscripts/rc.sysinit.patch b/abs/core/initscripts/rc.sysinit.patch
index c158fcc..5588313 100644
--- a/abs/core/initscripts/rc.sysinit.patch
+++ b/abs/core/initscripts/rc.sysinit.patch
@@ -1,14 +1,16 @@
--- initscripts-2011.06.4/rc.sysinit.orig 2011-08-11 19:56:03.000000000 +0000
+++ initscripts-2011.06.4/rc.sysinit 2011-08-11 20:00:05.000000000 +0000
-@@ -7,8 +7,9 @@
+@@ -7,8 +7,11@@
. /etc/rc.d/functions
echo " "
-printhl "Arch Linux\n"
-printhl "${C_H2}http://www.archlinux.org"
-+printhl "LinHES\n"
-+printhl "The Linux Home Entertainment System\n"
++echo " "
++printhl "LinHES"
++printhl "The Linux Home Entertainment System"
+printhl "${C_H2}http://www.linhes.org"
++echo " "
printsep
run_hook sysinit_start
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 4c3c8e1..ee88800 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=2.1.1
-pkgrel=30
+pkgrel=33
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
@@ -27,4 +27,4 @@ build() {
install -m0755 reboot-runit halt-runit logger $startdir/pkg/sbin
rsync -a --exclude=.svn services/* $startdir/pkg/etc/sv
}
-md5sums=('fdc7aee7ce323f1e55060e2da54a9534')
+md5sums=('45d0b0c6ad9b00eeaaef3341245a8d4c')
diff --git a/abs/core/runit-scripts/fbsplash-runit.sh b/abs/core/runit-scripts/fbsplash-runit.sh
index 90430dd..a9432d0 100755
--- a/abs/core/runit-scripts/fbsplash-runit.sh
+++ b/abs/core/runit-scripts/fbsplash-runit.sh
@@ -3,6 +3,9 @@
# Who is calling? #
CALLER=$0
+printhlr() {
+ printf "${C_OTHER}${PREFIX_REG} ${C_H1}${1}${C_CLEAR} \n"
+ }
# splash stuff #
if [ -e /etc/conf.d/fbsplash.conf ]
@@ -13,13 +16,19 @@ then
# Redefine the stat functions #
stat_runit() {
- printf "${C_OTHER}${PREFIX_REG} ${C_MAIN}${1}${C_CLEAR} "
- printf "${SAVE_POSITION}"
- deltext
- printf " ${C_OTHER}[${C_BUSY}BKGD${C_OTHER}]${C_CLEAR} "
+ # printf "${C_OTHER}${PREFIX_REG} ${C_MAIN}${1}${C_CLEAR} "
+ # printf "${SAVE_POSITION}"
+ # deltext
+ # printf " ${C_OTHER}[${C_BUSY}BKGD${C_OTHER}]${C_CLEAR} "a
+
+ printf ""
+ printhlr "${C_MAIN}${1}${C_CLEAR} "
+
# Load variables #
+
var_load STEP_NR MAX_STEPS RC_MULTI RC_SYSINIT RC_SHUTDOWN
# Only update the splash progress if we're in sysinit, multi, or shutdown. #
+
((SPLASH_STEP_NR++))
SPLASH_PROGRESS=$((100*${SPLASH_STEP_NR}/${SPLASH_MAX_STEPS}))
SPLASH_CURRENT_PROGRESS=${SPLASH_PROGRESS}
@@ -29,10 +38,7 @@ then
}
else
stat_runit(){
-
- printf "${C_OTHER}${PREFIX_REG} ${C_MAIN}${1}${C_CLEAR} "
- printf "${SAVE_POSITION}"
- deltext
- printf " ${C_OTHER}[${C_BUSY}BKGD${C_OTHER}]${C_CLEAR} "
+ printf ""
+ printhlr "${C_MAIN}${1}${C_CLEAR} "
}
fi
diff --git a/abs/core/runit-scripts/runitscripts/3 b/abs/core/runit-scripts/runitscripts/3
index d4b0a6a..15e4c5f 100755
--- a/abs/core/runit-scripts/runitscripts/3
+++ b/abs/core/runit-scripts/runitscripts/3
@@ -1,5 +1,10 @@
#!/bin/sh
-for i in `seq 30`
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+echo "======================================================================"
+for i in `seq 3`
do
echo " " > /dev/tty1
done
diff --git a/abs/core/runit-scripts/runitscripts/services/lircd/run b/abs/core/runit-scripts/runitscripts/services/lircd/run
index f8f24c1..966b980 100755
--- a/abs/core/runit-scripts/runitscripts/services/lircd/run
+++ b/abs/core/runit-scripts/runitscripts/services/lircd/run
@@ -31,7 +31,8 @@ else
stat_runit "Starting lirc"
#enable lirc bridge protocol
- /usr/bin/ir-keytable -p lirc &
+ printhl " lirc: ir-keytable"
+ /usr/bin/ir-keytable -p lirc > /dev/null 2>/dev/null
[ -e /etc/sv/lircd/.runtime ] || mkdir -p /etc/sv/lircd/.runtime
[ -e /var/run/lirc ] || mkdir -p /var/run/lirc
diff --git a/abs/core/runit-scripts/runitscripts/services/netfs/run b/abs/core/runit-scripts/runitscripts/services/netfs/run
index 8b6a8b1..06180c2 100755
--- a/abs/core/runit-scripts/runitscripts/services/netfs/run
+++ b/abs/core/runit-scripts/runitscripts/services/netfs/run
@@ -1,6 +1,7 @@
#!/bin/sh
exec 2>&1
+exec 1>/dev/null
sv start rpcbind
-sv start nfs-common
+sv start nfs-common
/etc/rc.d/netfs start
diff --git a/abs/core/runit-scripts/runitscripts/services/nfs-common/run b/abs/core/runit-scripts/runitscripts/services/nfs-common/run
index bf6c2a1..f0dbb6e 100755
--- a/abs/core/runit-scripts/runitscripts/services/nfs-common/run
+++ b/abs/core/runit-scripts/runitscripts/services/nfs-common/run
@@ -62,20 +62,22 @@ get_pid() {
-stat_runit "Starting $daemon_name"
+stat_runit "Starting NFS-common: $daemon_name"
svwaitup rpcbind >/dev/null 2>/dev/null
-/usr/sbin/sm-notify $SMNOTIFY_OPTS
+
+printhl " NFS-common: sm-notify"
+/usr/sbin/sm-notify $SMNOTIFY_OPTS >/dev/null 2>/dev/null
do_modprobe sunrpc
do_modprobe nfs
do_modprobe nfsd
do_mount rpc_pipefs "$PIPEFS_MOUNTPOINT" "$PIPEFS_MOUNTOPTS"
-stat_runit "Starting $IDMAPD_DAEMON_NAME"
+printhl " NFS-common: $IDMAPD_DAEMON_NAME"
$IDMAPD
-stat_runit "Starting $GSSD_DAEMON_NAME"
+printhl " NFS-common: $GSSD_DAEMON_NAME"
do_modprobe rpcsec_gss_krb5
$GSSD
-$STATD -F
+$STATD -F > /dev/null 2>/dev/null