summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/LinHES-system/system.install9
-rw-r--r--abs/core/keylaunch/example_rc2
-rw-r--r--abs/core/keylaunch/keylaunch.install4
-rw-r--r--abs/core/rsyslog/PKGBUILD4
-rw-r--r--abs/core/rsyslog/log_care.sh2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/cron/log/run5
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/cron/run2
7 files changed, 15 insertions, 13 deletions
diff --git a/abs/core/LinHES-system/system.install b/abs/core/LinHES-system/system.install
index c9950f2..7ae0616 100644
--- a/abs/core/LinHES-system/system.install
+++ b/abs/core/LinHES-system/system.install
@@ -51,14 +51,9 @@ grep -q "pam_limits.so" /etc/pam.d/su
fi
-# Update mythtv's fluxbox keys files to use the tvterm.sh script to get
-# an xterm. Then signal fluxbox to re-read the keys file.
-
-sed -i.orig 's/^Mod1 x :.*xterm.*$/Mod1 x :ExecCommand tvterm.sh/g' \
- ~mythtv/.fluxbox/keys
-pkill -HUP fluxbox
-
+# Add db entry for misc status in MythWeb
+/usr/LH/bin/misc_status_config.py
}
diff --git a/abs/core/keylaunch/example_rc b/abs/core/keylaunch/example_rc
index 3f98fa6..5dd0f59 100644
--- a/abs/core/keylaunch/example_rc
+++ b/abs/core/keylaunch/example_rc
@@ -10,7 +10,7 @@
key=*..Return:xterm -fn *-18-*
key=..*x:/usr/LH/bin/tvterm.sh
-key=..*s:sudo /usr/bin/mythtv-setup
+key=..*s:/usr/bin/mythtv-setup
key=..*u:/usr/LH/bin/unclutter-toggle.sh
key=.**u:/usr/LH/bin/unclutter-toggle.sh
key=..*h:/usr/MythVantage/bin/mythinstall -H
diff --git a/abs/core/keylaunch/keylaunch.install b/abs/core/keylaunch/keylaunch.install
index 42bc9eb..faa176b 100644
--- a/abs/core/keylaunch/keylaunch.install
+++ b/abs/core/keylaunch/keylaunch.install
@@ -13,7 +13,9 @@ post_install() {
then
echo "setting symlink for keylaunch"
ln -s /etc/keylaunchrc $MHOME/.keylaunchrc
-fi
+ fi
+ echo "updating .keylaunchrc to run mythtv-setup as user"
+ sed -i 's/key=..*s:sudo\ \/usr\/bin\/mythtv-setup/key=..*s:\/usr\/bin\/mythtv-setup/g' $MHOME/.keylaunchrc
}
# arg 1: the new package version
diff --git a/abs/core/rsyslog/PKGBUILD b/abs/core/rsyslog/PKGBUILD
index 1750341..8fa6aa7 100644
--- a/abs/core/rsyslog/PKGBUILD
+++ b/abs/core/rsyslog/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=rsyslog
pkgver=5.8.6
-pkgrel=4
+pkgrel=5
pkgdesc="An enhanced multi-threaded syslogd with a focus on security and reliability"
url="http://www.rsyslog.com/"
arch=('i686' 'x86_64')
@@ -51,4 +51,4 @@ md5sums=('c46db0496066b82faf735bd4222208d7'
'a18bbcbb6ebdaa13a6ec6d9f3d9eb2da'
'1a0cd4530dd5d1439456d5ae230574d9'
'fae023a980db26f0ee27bd2f80d3e6f2'
- '86a7e28b59ad80998b2163860d5d612a')
+ '2f795681e12f8bc43e8bea28dc020dcb')
diff --git a/abs/core/rsyslog/log_care.sh b/abs/core/rsyslog/log_care.sh
index ea1db56..9023a82 100644
--- a/abs/core/rsyslog/log_care.sh
+++ b/abs/core/rsyslog/log_care.sh
@@ -7,7 +7,7 @@ do
echo "Compressing log files"
find /var/log/$DATE* -mtime +1 -exec gzip -9 {} \;
echo "Deleting old log files"
- find /var/log/$DATE* -mtime +7 -exec rm -rf {} \;
+ find /var/log/$DATE* -mtime +12 -exec rm -rf {} \;
echo "Deleting empty directories"
find /var/log/$DATE* -depth -type d -empty -exec rm -rf {} \;
done
diff --git a/abs/core/runit-scripts/runitscripts/services/cron/log/run b/abs/core/runit-scripts/runitscripts/services/cron/log/run
new file mode 100755
index 0000000..9dd37e3
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/cron/log/run
@@ -0,0 +1,5 @@
+#!/bin/sh
+exec 2>&1
+. /etc/systemconfig
+ /usr/bin/logger -p local6.info -t cron
+
diff --git a/abs/core/runit-scripts/runitscripts/services/cron/run b/abs/core/runit-scripts/runitscripts/services/cron/run
index 0894236..3d358d3 100755
--- a/abs/core/runit-scripts/runitscripts/services/cron/run
+++ b/abs/core/runit-scripts/runitscripts/services/cron/run
@@ -6,4 +6,4 @@ stat_runit "Starting Cron"
exec 2>&1
-exec /usr/sbin/crond -f >/dev/null 2>/dev/null
+exec /usr/sbin/crond -f -M /dev/null -l info