summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/apache/PKGBUILD11
-rw-r--r--abs/core/apache/__changelog1
-rw-r--r--abs/core/lighttpd/PKGBUILD46
-rw-r--r--abs/core/lighttpd/__changelog2
-rw-r--r--abs/core/mysql/PKGBUILD6
-rw-r--r--abs/core/mysql/__changelog1
-rw-r--r--abs/core/tdb/PKGBUILD23
7 files changed, 51 insertions, 39 deletions
diff --git a/abs/core/apache/PKGBUILD b/abs/core/apache/PKGBUILD
index 6e570f1..4ba626c 100644
--- a/abs/core/apache/PKGBUILD
+++ b/abs/core/apache/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 87621 2010-08-17 13:13:14Z jgc $
+# $Id: PKGBUILD 96448 2010-10-21 09:16:04Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=apache
-pkgver=2.2.16
-pkgrel=2
+pkgver=2.2.17
+pkgrel=1
pkgdesc='A high performance Unix-based HTTP server'
arch=('i686' 'x86_64')
options=('!libtool')
@@ -34,7 +34,7 @@ source=(http://www.apache.org/dist/httpd/httpd-${pkgver}.tar.bz2
httpd.logrotate
httpd
arch.layout)
-md5sums=('c8ff2a07c884300bc7766a2e7f662d33'
+md5sums=('16eadc59ea6b38af33874d300973202e'
'db42cfcc18ae1c32aaaff2347e35b79d'
'131408ad4dc7b18547b4e062e7e495ab'
'ee488f391054d528547c3a372faa2aa7'
@@ -103,7 +103,8 @@ build() {
--with-apr-util=/usr/bin/apu-1-config \
--with-pcre=/usr \
--with-mpm=${mpm}
- make
+ make || return 1
+
if [ "${mpm}" = "prefork" ]; then
make DESTDIR="${pkgdir}" install
else
diff --git a/abs/core/apache/__changelog b/abs/core/apache/__changelog
new file mode 100644
index 0000000..bbcbdac
--- /dev/null
+++ b/abs/core/apache/__changelog
@@ -0,0 +1 @@
+update to 2.2.17
diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index ed6d01e..e85681b 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=lighttpd
-pkgver=1.4.26
-pkgrel=16
+pkgver=1.4.28
+pkgrel=1
pkgdesc='A secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -14,19 +14,14 @@ optdepends=('libxml2: mod_webdav' \
'e2fsprogs: mod_webdav' \
'libmysqlclient: mod_mysql_vhost' \
'sqlite3: mod_webdav' \
- 'gdbm: mod_trigger_b4_dl' \
- )
+ 'gdbm: mod_trigger_b4_dl')
backup=(etc/lighttpd/lighttpd.conf etc/logrotate.d/lighttpd etc/lighttpd/auth-inc.conf etc/lighttpd/conf.include etc/lighttpd/html.include)
options=('!libtool' 'emptydirs')
source=("http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.bz2" \
- 'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf' \
- 'openssl-0.9.8m.patch')
+ 'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf')
#install='lighttpd.install'
build() {
- cd $srcdir/$pkgname-$pkgver
-
- # fixed in 1.4.27
- patch -p2 -i ${srcdir}/openssl-0.9.8m.patch || return 1
+ cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr \
--libexecdir=/usr/lib/lighttpd/modules \
@@ -47,15 +42,19 @@ build() {
--with-memcache \
--with-lua || return 1
make || return 1
- make DESTDIR=$pkgdir install || return 1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install || return 1
- install -D -m755 ../lighttpd.rc.d $pkgdir/etc/rc.d/lighttpd
- install -D -m644 ../lighttpd.logrotate.d $pkgdir/etc/logrotate.d/lighttpd
- install -d -m755 -o http -g http $pkgdir/var/run/lighttpd/
- install -d -m755 -o http -g http $pkgdir/var/log/lighttpd/
+ install -D -m755 ../lighttpd.rc.d ${pkgdir}/etc/rc.d/lighttpd
+ install -D -m644 ../lighttpd.logrotate.d ${pkgdir}/etc/logrotate.d/lighttpd
+ install -d -m755 -o http -g http ${pkgdir}/var/run/lighttpd/
+ install -d -m755 -o http -g http ${pkgdir}/var/log/lighttpd/
- install -D -m644 ../lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
- install -D -m644 ../auth-inc.conf $pkgdir/etc/lighttpd/auth-inc.conf
+ install -D -m644 ../lighttpd.conf ${pkgdir}/etc/lighttpd/lighttpd.conf
+ install -D -m644 ../auth-inc.conf ${pkgdir}/etc/lighttpd/auth-inc.conf
# set sane defaults
sed -e 's|/srv/www/htdocs/|/srv/http/|' \
@@ -70,15 +69,14 @@ build() {
-e 's|#ssi.extension = ( ".shtml" )|ssi.extension = ( ".shtml" )|' \
-i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
- /bin/touch $pkgdir/etc/lighttpd/{conf,html}.include || return 1
- /bin/echo 'include "/etc/lighttpd/conf.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
- /bin/echo 'include "/etc/lighttpd/html.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
+ /bin/touch ${pkgdir}/etc/lighttpd/{conf,html}.include || return 1
+ /bin/echo 'include "/etc/lighttpd/conf.include"' >> ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+ /bin/echo 'include "/etc/lighttpd/html.include"' >> ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
- install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
}
-md5sums=('a682c8efce47a2f4263a247ba0813c9b'
+md5sums=('586eb535d31ac299652495b058dd87c4'
'bd690eee0d9e51857448770a151023b0'
'857e174643fd7761a2f0d8431a679f6c'
'11fbec7ff7ca1b0d5575445681e8f60e'
- 'c6e361131000ceec085f40b310ef4a2c'
- '84c884b8dadd724afe2bc6529e9d4485')
+ 'c6e361131000ceec085f40b310ef4a2c')
diff --git a/abs/core/lighttpd/__changelog b/abs/core/lighttpd/__changelog
index 0fe6415..71151d9 100644
--- a/abs/core/lighttpd/__changelog
+++ b/abs/core/lighttpd/__changelog
@@ -12,3 +12,5 @@ bummped to version 13 to test redmine #690
# by mihanson
Added etc/lighttpd/conf.include and etc/lighttpd/html.include to backup array
+
+upgrade to 1.4.28
diff --git a/abs/core/mysql/PKGBUILD b/abs/core/mysql/PKGBUILD
index ed65173..9602157 100644
--- a/abs/core/mysql/PKGBUILD
+++ b/abs/core/mysql/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=mysql
pkgname=('libmysqlclient' 'mysql-clients' 'mysql')
-pkgver=5.1.50
+pkgver=5.1.52
pkgrel=1
arch=('i686' 'x86_64')
license=('GPL')
@@ -38,7 +38,7 @@ build() {
--with-unix-socket-path=/var/run/mysqld/mysqld.sock \
--enable-local-infile \
--with-plugins=partition,ftexample,archive,blackhole,federated,heap,innobase,innodb_plugin,ndbcluster
- make
+ make || return 1
}
package_libmysqlclient(){
@@ -103,7 +103,7 @@ package_mysql(){
rm -rf ${pkgdir}/usr/{mysql-test,sql-bench}
rm -f ${pkgdir}/usr/lib/mysql/plugin/*.a
}
-md5sums=('23bac4a0aafd683b077dac146ce2701f'
+md5sums=('43c11ad3dded693393c4815d24e2b0a5'
'2234207625baa29b2ff7d7b4f088abce'
'175b269b665019689d786f5af0968046'
'a97e574945e19de3908575b956241026')
diff --git a/abs/core/mysql/__changelog b/abs/core/mysql/__changelog
index 3362584..96a3b29 100644
--- a/abs/core/mysql/__changelog
+++ b/abs/core/mysql/__changelog
@@ -1,2 +1,3 @@
using default arch pkgbuild
my.cnf has data dir modified to use /data/srv
+upgrade to 5.1.52
diff --git a/abs/core/tdb/PKGBUILD b/abs/core/tdb/PKGBUILD
index 4bf2af6..7739dc1 100644
--- a/abs/core/tdb/PKGBUILD
+++ b/abs/core/tdb/PKGBUILD
@@ -1,26 +1,35 @@
-# $Id: PKGBUILD 63109 2010-01-14 18:55:16Z tpowa $
+# $Id: PKGBUILD 89866 2010-09-04 14:37:32Z remy $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributorr: eric <eric@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=tdb
-pkgver=1.2.0
-pkgrel=1
+pkgver=1.2.1
+pkgrel=2
pkgdesc="A Trivia Database similar to GDBM but allows simultaneous commits"
arch=(i686 x86_64)
license=('GPL3')
url="http://tdb.samba.org/"
source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-makedepends=('python')
-optdepends=('python: for python bindings')
+makedepends=('python2' 'libxslt' 'docbook-xsl')
+optdepends=('python2: for python bindings')
options=(force)
build() {
cd ${srcdir}/${pkgname}-${pkgver}
+ sed -i 's#python2\.6\([^ ]*\)#python2.7\1 python2.6\1#' configure
+ # Use system docbook.xsl
+ _manstyle="/usr/share/xml/docbook/xsl-stylesheets-1.76.0/manpages/docbook.xsl"
+ sed -i "s#http.*xsl#$_manstyle#" tdb.mk
+
./configure --prefix=/usr \
--localstatedir=/var \
--sysconfdir=/etc/samba
make || return 1
- make DESTDIR=$pkgdir/ install
}
-md5sums=('4115849d2ef431a10bc1f1933eafb9b6')
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+md5sums=('73ea81282a82e5c959d9c082af2d0215')
+