summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/gobject-introspection/PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/abs/core/gobject-introspection/PKGBUILD b/abs/core/gobject-introspection/PKGBUILD
index 972a8a9..1d25467 100644
--- a/abs/core/gobject-introspection/PKGBUILD
+++ b/abs/core/gobject-introspection/PKGBUILD
@@ -1,22 +1,21 @@
-# $Id: PKGBUILD 157399 2012-04-28 09:26:41Z allan $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=gobject-introspection
-pkgver=1.32.1
-pkgrel=2
+pkgver=1.40.0
+pkgrel=1
pkgdesc="Introspection system for GObject-based libraries"
-url="http://live.gnome.org/GObjectInstrospection"
+url="https://live.gnome.org/GObjectIntrospection"
arch=('x86_64' 'i686')
license=('LGPL' 'GPL')
-depends=('glib2' 'python2')
+depends=('glib2' 'python2' 'python2-mako')
makedepends=('cairo')
-options=('!libtool')
-source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
-sha256sums=('44f3fb933f76e4728818cc360cb5f9e2edcbdf9bc8a8f9aded99b3e3ef5cb858')
+source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
+sha256sums=('96ea75e9679083e7fe39a105e810e2ead2d708abf189a5ba420bfccfffa24e98')
build() {
cd "$pkgname-$pkgver"
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr --disable-static
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr --disable-static --enable-doctool
make
}