summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/windowmaker/PKGBUILD6
-rw-r--r--abs/core/windowmaker/__changelog1
-rw-r--r--abs/core/windowmaker/wmaker.install37
3 files changed, 41 insertions, 3 deletions
diff --git a/abs/core/windowmaker/PKGBUILD b/abs/core/windowmaker/PKGBUILD
index 3b20bf5..e588b62 100644
--- a/abs/core/windowmaker/PKGBUILD
+++ b/abs/core/windowmaker/PKGBUILD
@@ -11,9 +11,7 @@ license=('GPL' 'custom')
depends=('libxinerama' 'libxrandr' 'libxmu' 'libpng' 'libxpm' 'libxft' 'libtiff' 'giflib')
options=('!libtool')
source=(http://windowmaker.org/pub/source/release/WindowMaker-$pkgver.tar.gz wmaker.desktop)
-md5sums=('305af9d862e853a5d7977e801cb66ca3'
- '2fba97bebfd691836b92b8f0db79ff13')
-
+install=wmaker.install
build() {
cd $srcdir/WindowMaker-$pkgver
[ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
@@ -31,3 +29,5 @@ package() {
install -D -m644 $srcdir/wmaker.desktop $pkgdir/usr/share/xsessions/wmaker.desktop
}
+md5sums=('305af9d862e853a5d7977e801cb66ca3'
+ '2fba97bebfd691836b92b8f0db79ff13')
diff --git a/abs/core/windowmaker/__changelog b/abs/core/windowmaker/__changelog
new file mode 100644
index 0000000..7f6a831
--- /dev/null
+++ b/abs/core/windowmaker/__changelog
@@ -0,0 +1 @@
+wmaker.install
diff --git a/abs/core/windowmaker/wmaker.install b/abs/core/windowmaker/wmaker.install
new file mode 100644
index 0000000..c646e13
--- /dev/null
+++ b/abs/core/windowmaker/wmaker.install
@@ -0,0 +1,37 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ ln -s /usr/share/WindowMaker /usr/local/share/WindowMaker 2>/dev/null
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}
+
+# vim:set ts=2 sw=2 et: