summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/LinHES-system/myth_status.py16
-rw-r--r--abs/core/dvb-firmware/PKGBUILD6
-rw-r--r--abs/core/dvb-firmware/dvb-firmware.tar.bz2bin13819768 -> 13836324 bytes
-rw-r--r--abs/core/dvb-firmware/xc5000.conf4
-rw-r--r--abs/core/v4l-dvb/PKGBUILD2
5 files changed, 16 insertions, 12 deletions
diff --git a/abs/core/LinHES-system/myth_status.py b/abs/core/LinHES-system/myth_status.py
index 4637b90..b4f4375 100644
--- a/abs/core/LinHES-system/myth_status.py
+++ b/abs/core/LinHES-system/myth_status.py
@@ -60,13 +60,15 @@ for i in a:
type = results[0][0]
hostname = results[0][1]
id = i
- c=be.getCurrentRecording(i)
- if c.title == None:
- current_recording = "Idle"
- else:
- current_recording = "Recording %s" %c.title
- print " Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
-
+ try:
+ c=be.getCurrentRecording(i)
+ if c.title == None:
+ current_recording = "Idle"
+ else:
+ current_recording = "Recording %s" %c.title
+ print " Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
+ except:
+ print " Tuner %s (%s) on %s : %s " %(id, type, hostname, "Tuner Error")
print ""
print "Upcoming Recordings (Next %s scheduled):" %(num_upcoming)
diff --git a/abs/core/dvb-firmware/PKGBUILD b/abs/core/dvb-firmware/PKGBUILD
index bbe5031..a9fc3e3 100644
--- a/abs/core/dvb-firmware/PKGBUILD
+++ b/abs/core/dvb-firmware/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=dvb-firmware
pkgver=1
-pkgrel=16
+pkgrel=17
pkgdesc="Firmware for DVB cards"
replaces=('hd3000firmware')
arch=('i586' 'i686' 'x86_64')
@@ -17,5 +17,5 @@ build() {
mkdir -p ${pkgdir}/etc/modprobe.d/
install -D -m644 "${srcdir}/xc5000.conf" "${pkgdir}/etc/modprobe.d/"
}
-md5sums=('32e19e3f9f849e667c6f7db1186180b9'
- 'e3e7c5da698fb79aee7a135bdb9b7c5c')
+md5sums=('2307b2e9ce2da591d64ed611b79ecf17'
+ '08c7619f37757f0d6191866701212575')
diff --git a/abs/core/dvb-firmware/dvb-firmware.tar.bz2 b/abs/core/dvb-firmware/dvb-firmware.tar.bz2
index e5b0d18..57019f5 100644
--- a/abs/core/dvb-firmware/dvb-firmware.tar.bz2
+++ b/abs/core/dvb-firmware/dvb-firmware.tar.bz2
Binary files differ
diff --git a/abs/core/dvb-firmware/xc5000.conf b/abs/core/dvb-firmware/xc5000.conf
index b1cf373..93b3ab4 100644
--- a/abs/core/dvb-firmware/xc5000.conf
+++ b/abs/core/dvb-firmware/xc5000.conf
@@ -1,4 +1,6 @@
# xc5000
# Disable power cycling and firmware reloads
#
-options xc5000 no_poweroff=1
+# When v4l-dvb is installed no_poweroff=1 is no longer needed.
+#
+#options xc5000 no_poweroff=1
diff --git a/abs/core/v4l-dvb/PKGBUILD b/abs/core/v4l-dvb/PKGBUILD
index 36e4609..ac150bb 100644
--- a/abs/core/v4l-dvb/PKGBUILD
+++ b/abs/core/v4l-dvb/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=v4l-dvb
_kernver=`uname -r`
-pkgver=20120407
+pkgver=20120828
pkgrel=1
pkgdesc="V4L-DVB device drivers (newer than those included in kernel26)"
arch=('i686' 'x86_64')