summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/community/firefox')
-rw-r--r--abs/extra-testing/community/firefox/PKGBUILD63
-rw-r--r--abs/extra-testing/community/firefox/firefox-appversion.patch11
-rw-r--r--abs/extra-testing/community/firefox/firefox-safe.desktop11
-rw-r--r--abs/extra-testing/community/firefox/firefox.desktop83
-rw-r--r--abs/extra-testing/community/firefox/firefox.install12
-rw-r--r--abs/extra-testing/community/firefox/mozbug421977.patch158
-rw-r--r--abs/extra-testing/community/firefox/mozconfig37
-rw-r--r--abs/extra-testing/community/firefox/mozilla-firefox-1.0-lang.patch12
-rw-r--r--abs/extra-testing/community/firefox/mozilla-firstrun.patch49
9 files changed, 436 insertions, 0 deletions
diff --git a/abs/extra-testing/community/firefox/PKGBUILD b/abs/extra-testing/community/firefox/PKGBUILD
new file mode 100644
index 0000000..92aec67
--- /dev/null
+++ b/abs/extra-testing/community/firefox/PKGBUILD
@@ -0,0 +1,63 @@
+# $Id: PKGBUILD 22049 2008-12-21 14:15:02Z jgc $
+# Contributor: Jakub Schmidtke <sjakub@gmail.com>
+
+pkgname=firefox
+pkgver=3.0.5
+pkgrel=1
+pkgdesc="Standalone web browser from mozilla.org"
+arch=(i686 x86_64)
+license=('MPL' 'GPL' 'LGPL')
+depends=('xulrunner=1.9.0.5' 'desktop-file-utils' 'shared-mime-info')
+makedepends=('zip' 'pkgconfig' 'diffutils' 'libgnomeui>=2.24.0' 'python' 'xorg-server')
+replaces=('firefox3')
+install=firefox.install
+url="http://www.mozilla.org/projects/firefox"
+source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/source/firefox-${pkgver}-source.tar.bz2
+ mozconfig
+ firefox.desktop
+ firefox-safe.desktop
+ mozilla-firefox-1.0-lang.patch
+ mozbug421977.patch
+ firefox-appversion.patch)
+md5sums=('19d09b2554976e207d37a164bcf43547'
+ '8b6e5f7d0a9e3f64747a024cf8f12069'
+ '68cf02788491c6e846729b2f2913bf79'
+ '5e68cabfcf3c021806b326f664ac505e'
+ 'bd5db57c23c72a02a489592644f18995'
+ '7976e3ff52e01af3388dfc3a479c4955'
+ 'c6f27fca2e6bd2a570b271ec3ce35782')
+
+build() {
+ cd ${srcdir}/mozilla
+
+ patch -Np1 -i ${srcdir}/mozilla-firefox-1.0-lang.patch || return 1
+
+ # FS#10836: fixes backgroundcolor parsing with gnome
+ patch -Np0 -i ${srcdir}/mozbug421977.patch || return 1
+
+ patch -Np1 -i ${srcdir}/firefox-appversion.patch || return 1
+
+ cp ${srcdir}/mozconfig .mozconfig
+
+ unset CFLAGS
+ unset CXXFLAGS
+
+ export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-3.0"
+
+ LD_PRELOAD="" /usr/bin/Xvfb -nolisten tcp -extension GLX :99 &
+ XPID=$!
+ export DISPLAY=:99
+
+ LD_PRELOAD="" make -j1 -f client.mk profiledbuild MOZ_MAKE_FLAGS="${MAKEFLAGS}" || return 1
+ kill $XPID
+
+ make -j1 DESTDIR=${pkgdir} -C ff-opt-obj install || return 1
+
+ rm -f ${pkgdir}/usr/lib/firefox-3.0/libjemalloc.so
+
+ install -m755 -d ${pkgdir}/usr/share/applications
+ install -m755 -d ${pkgdir}/usr/share/pixmaps
+ install -m644 ${srcdir}/mozilla/browser/branding/unofficial/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png || return 1
+ install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/ || return 1
+ install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/ || return 1
+}
diff --git a/abs/extra-testing/community/firefox/firefox-appversion.patch b/abs/extra-testing/community/firefox/firefox-appversion.patch
new file mode 100644
index 0000000..458904e
--- /dev/null
+++ b/abs/extra-testing/community/firefox/firefox-appversion.patch
@@ -0,0 +1,11 @@
+--- mozilla/browser/installer/Makefile.in.orig 2008-11-19 22:49:15.000000000 +0100
++++ mozilla/browser/installer/Makefile.in 2008-11-19 22:49:32.000000000 +0100
+@@ -43,6 +43,8 @@
+
+ include $(DEPTH)/config/autoconf.mk
+
++MOZ_APP_VERSION=3.0
++
+ NO_PKG_FILES = \
+ $(MOZ_APP_NAME)-config \
+ $(MOZ_APP_NAME)-bin.elf \
diff --git a/abs/extra-testing/community/firefox/firefox-safe.desktop b/abs/extra-testing/community/firefox/firefox-safe.desktop
new file mode 100644
index 0000000..afb4cdb
--- /dev/null
+++ b/abs/extra-testing/community/firefox/firefox-safe.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=firefox -safe-mode %u
+Icon=firefox
+Type=Application
+Terminal=false
+MultipleArgs=false
+Name=Firefox - Safe Mode
+GenericName=Web Browser - Safe Mode
+StartupNotify=false
+Categories=Application;Network;
diff --git a/abs/extra-testing/community/firefox/firefox.desktop b/abs/extra-testing/community/firefox/firefox.desktop
new file mode 100644
index 0000000..2a4b678
--- /dev/null
+++ b/abs/extra-testing/community/firefox/firefox.desktop
@@ -0,0 +1,83 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=firefox %u
+Icon=firefox
+Type=Application
+Terminal=false
+MultipleArgs=false
+Name=Firefox
+Name[bn]=ফায়ারফক্স3
+Name[eo]=Fajrovulpo3
+Name[fi]=Firefox3
+Name[pa]=ਫਾਇਰਫੋਕਸ3
+Name[tg]=Рӯбоҳи оташин3
+GenericName=Web Browser
+GenericName[af]=Web Blaaier
+GenericName[ar]=متصفح ويب
+GenericName[az]=Veb Səyyahı
+GenericName[bg]=Браузър
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[br]=Furcher ar Gwiad
+GenericName[bs]=WWW Preglednik
+GenericName[ca]=Fullejador web
+GenericName[cs]=WWW prohlížeč
+GenericName[cy]=Porydd Gwe
+GenericName[da]=Browser
+GenericName[de]=Web-Browser
+GenericName[el]=Περιηγητής Ιστού
+GenericName[eo]=TTT-legilo
+GenericName[es]=Navegador web
+GenericName[et]=Veebilehitseja
+GenericName[eu]=Web arakatzailea
+GenericName[fa]=مرورگر وب
+GenericName[fi]=WWW-selain
+GenericName[fo]=Alnótsfar
+GenericName[fr]=Navigateur web
+GenericName[gl]=Navegador Web
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hr]=Web preglednik
+GenericName[hu]=Webböngésző
+GenericName[is]=Vafri
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[ko]=웹 브라우저
+GenericName[lo]=ເວັບບຣາວເຊີ
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Web Pārlūks
+GenericName[mk]=Прелистувач на Интернет
+GenericName[mn]=Веб-Хөтөч
+GenericName[nb]=Nettleser
+GenericName[nds]=Nettkieker
+GenericName[nl]=Webbrowser
+GenericName[nn]=Nettlesar
+GenericName[nso]=Seinyakisi sa Web
+GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador Web
+GenericName[ro]=Navigator de web
+GenericName[ru]=Веб-браузер
+GenericName[se]=Fierpmádatlogan
+GenericName[sk]=Webový prehliadač
+GenericName[sl]=Spletni brskalnik
+GenericName[sr]=Веб претраживач
+GenericName[sr@Latn]=Veb pretraživač
+GenericName[ss]=Ibrawuza yeWeb
+GenericName[sv]=Webbläsare
+GenericName[ta]=வலை உலாவி
+GenericName[tg]=Тафсиргари вэб
+GenericName[th]=เว็บบราวเซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[uz]=Веб-браузер
+GenericName[ven]=Buronza ya Webu
+GenericName[vi]=Trình duyệt Web
+GenericName[wa]=Betchteu waibe
+GenericName[xh]=Umkhangeli zincwadi we Web
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_TW]=網頁瀏覽器
+GenericName[zu]=Umcingi we-Web
+MimeType=text/html
+StartupNotify=true
+Categories=Application;Network;
diff --git a/abs/extra-testing/community/firefox/firefox.install b/abs/extra-testing/community/firefox/firefox.install
new file mode 100644
index 0000000..7463b6e
--- /dev/null
+++ b/abs/extra-testing/community/firefox/firefox.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
diff --git a/abs/extra-testing/community/firefox/mozbug421977.patch b/abs/extra-testing/community/firefox/mozbug421977.patch
new file mode 100644
index 0000000..df8371a
--- /dev/null
+++ b/abs/extra-testing/community/firefox/mozbug421977.patch
@@ -0,0 +1,158 @@
+Index: browser/components/shell/src/nsGNOMEShellService.cpp
+===================================================================
+RCS file: /cvsroot/mozilla/browser/components/shell/src/nsGNOMEShellService.cpp,v
+retrieving revision 1.21
+diff -d -u -p -U 8 -r1.21 nsGNOMEShellService.cpp
+--- browser/components/shell/src/nsGNOMEShellService.cpp 1 Oct 2007 18:25:26 -0000 1.21
++++ browser/components/shell/src/nsGNOMEShellService.cpp 15 Mar 2008 07:08:47 -0000
+@@ -58,16 +58,17 @@
+ #include "nsIImage.h"
+ #include "prprf.h"
+ #ifdef MOZ_WIDGET_GTK2
+ #include "nsIImageToPixbuf.h"
+ #endif
+
+ #include <glib.h>
+ #include <glib-object.h>
++#include <gdk/gdk.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+ #include <limits.h>
+ #include <stdlib.h>
+
+ struct ProtocolAssociation
+ {
+ const char *name;
+ PRBool essential;
+@@ -442,117 +443,56 @@ nsGNOMEShellService::SetDesktopBackgroun
+ EmptyCString());
+
+ gconf->SetString(NS_LITERAL_CSTRING(kDesktopImageKey), filePath);
+ gconf->SetBool(NS_LITERAL_CSTRING(kDesktopDrawBGKey), PR_TRUE);
+
+ return rv;
+ }
+
+-// In: pointer to two characters CC
+-// Out: parsed color number
+-static PRUint8
+-HexToNum(char ch)
+-{
+- if ('0' <= ch && '9' >= ch)
+- return ch - '0';
+-
+- if ('A' <= ch && 'F' >= ch)
+- return ch - 'A';
+-
+- if ('a' <= ch && 'f' >= ch)
+- return ch - 'a';
+-
+- return 0;
+-}
+-
+-
+-// In: 3 or 6-character RRGGBB hex string
+-// Out: component colors
+-static PRBool
+-HexToRGB(const nsCString& aColorSpec,
+- PRUint8 &aRed,
+- PRUint8 &aGreen,
+- PRUint8 &aBlue)
+-{
+- const char *buf = aColorSpec.get();
+-
+- if (aColorSpec.Length() == 6) {
+- aRed = HexToNum(buf[0]) >> 4 |
+- HexToNum(buf[1]);
+- aGreen = HexToNum(buf[2]) >> 4 |
+- HexToNum(buf[3]);
+- aBlue = HexToNum(buf[4]) >> 4 |
+- HexToNum(buf[5]);
+- return PR_TRUE;
+- }
+-
+- if (aColorSpec.Length() == 3) {
+- aRed = HexToNum(buf[0]);
+- aGreen = HexToNum(buf[1]);
+- aBlue = HexToNum(buf[2]);
+-
+- aRed |= aRed >> 4;
+- aGreen |= aGreen >> 4;
+- aBlue |= aBlue >> 4;
+-
+- return PR_TRUE;
+- }
+-
+- return PR_FALSE;
+-}
++#define COLOR_16_TO_8_BIT(_c) ((_c) >> 8)
++#define COLOR_8_TO_16_BIT(_c) ((_c) << 8)
+
+ NS_IMETHODIMP
+ nsGNOMEShellService::GetDesktopBackgroundColor(PRUint32 *aColor)
+ {
+ nsCOMPtr<nsIGConfService> gconf = do_GetService(NS_GCONFSERVICE_CONTRACTID);
+
+ nsCAutoString background;
+ gconf->GetString(NS_LITERAL_CSTRING(kDesktopColorKey), background);
+
+ if (background.IsEmpty()) {
+ *aColor = 0;
+ return NS_OK;
+ }
+
+- // Chop off the leading '#' character
+- background.Cut(0, 1);
++ GdkColor color;
++ gboolean success = gdk_color_parse(background.get(), &color);
+
+- PRUint8 red, green, blue;
+- if (!HexToRGB(background, red, green, blue))
+- return NS_ERROR_FAILURE;
++ NS_ENSURE_TRUE(success, NS_ERROR_FAILURE);
+
+- // The result must be in RGB order with the high 8 bits zero.
+- *aColor = (red << 16 | green << 8 | blue);
++ *aColor = COLOR_16_TO_8_BIT(color.red) << 16 |
++ COLOR_16_TO_8_BIT(color.green) << 8 |
++ COLOR_16_TO_8_BIT(color.blue);
+ return NS_OK;
+ }
+
+-static void
+-ColorToHex(PRUint32 aColor, nsCString& aResult)
+-{
+- char *buf = aResult.BeginWriting(7);
+- if (!buf)
+- return;
+-
+- PRUint8 red = (aColor >> 16);
+- PRUint8 green = (aColor >> 8) & 0xff;
+- PRUint8 blue = aColor & 0xff;
+-
+- PR_snprintf(buf, 8, "#%02x%02x%02x", red, green, blue);
+-}
+-
+ NS_IMETHODIMP
+ nsGNOMEShellService::SetDesktopBackgroundColor(PRUint32 aColor)
+ {
+ nsCOMPtr<nsIGConfService> gconf = do_GetService(NS_GCONFSERVICE_CONTRACTID);
+
+- nsCString colorString;
+- ColorToHex(aColor, colorString);
++ GdkColor color;
++ color.red = COLOR_8_TO_16_BIT(aColor >> 16);
++ color.green = COLOR_8_TO_16_BIT((aColor >> 8) & 0xff);
++ color.blue = COLOR_8_TO_16_BIT(aColor & 0xff);
+
+- gconf->SetString(NS_LITERAL_CSTRING(kDesktopColorKey), colorString);
++ gchar *colorString = gdk_color_to_string(&color);
++ gconf->SetString(NS_LITERAL_CSTRING(kDesktopColorKey), nsDependentCString(colorString));
++ g_free (colorString);
+
+ return NS_OK;
+ }
+
+ NS_IMETHODIMP
+ nsGNOMEShellService::OpenApplication(PRInt32 aApplication)
+ {
+ nsCAutoString scheme;
diff --git a/abs/extra-testing/community/firefox/mozconfig b/abs/extra-testing/community/firefox/mozconfig
new file mode 100644
index 0000000..b40ce01
--- /dev/null
+++ b/abs/extra-testing/community/firefox/mozconfig
@@ -0,0 +1,37 @@
+. $topsrcdir/browser/config/mozconfig
+
+ac_add_options --prefix=/usr
+ac_add_options --libdir=/usr/lib
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-system-png
+ac_add_options --with-pthreads
+ac_add_options --disable-tests
+ac_add_options --disable-debug
+ac_add_options --enable-optimize
+ac_add_options --disable-installer
+ac_add_options --enable-xinerama
+ac_add_options --enable-default-toolkit=cairo-gtk2
+ac_add_options --disable-xprint
+ac_add_options --enable-strip
+ac_add_options --enable-pango
+ac_add_options --enable-system-cairo
+ac_add_options --enable-svg
+ac_add_options --enable-canvas
+ac_add_options --enable-startup-notification
+ac_add_options --enable-libxul
+ac_add_options --disable-crashreporter
+ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-1.9
+ac_add_options --enable-safe-browsing
+ac_add_options --with-branding=browser/branding/unofficial
+mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/ff-opt-obj
+mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) $(MOZ_OBJDIR)/_profile/pgo/profileserver.py'
+
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export USE_SHORT_LIBNAME=1
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
+mk_add_options USE_SHORT_LIBNAME=1
diff --git a/abs/extra-testing/community/firefox/mozilla-firefox-1.0-lang.patch b/abs/extra-testing/community/firefox/mozilla-firefox-1.0-lang.patch
new file mode 100644
index 0000000..f0f7325
--- /dev/null
+++ b/abs/extra-testing/community/firefox/mozilla-firefox-1.0-lang.patch
@@ -0,0 +1,12 @@
+--- mozilla/browser/app/profile/firefox.js.lang 2005-01-13 15:32:03.509282726 +0100
++++ mozilla/browser/app/profile/firefox.js 2005-01-13 15:33:40.220914789 +0100
+@@ -253,6 +253,9 @@
+ pref("font.language.group", "chrome://global/locale/intl.properties");
+ pref("intl.menuitems.alwaysappendaccesskeys","chrome://global/locale/intl.properties");
+
++// Use LANG environment variable to choose locale
++pref("intl.locale.matchOS", true);
++
+ // 0=lines, 1=pages, 2=history , 3=text size
+ pref("mousewheel.withcontrolkey.action",3);
+ pref("mousewheel.withshiftkey.action",2);
diff --git a/abs/extra-testing/community/firefox/mozilla-firstrun.patch b/abs/extra-testing/community/firefox/mozilla-firstrun.patch
new file mode 100644
index 0000000..3a75328
--- /dev/null
+++ b/abs/extra-testing/community/firefox/mozilla-firstrun.patch
@@ -0,0 +1,49 @@
+diff -up mozilla/browser/base/jar.mn.firstrun mozilla/browser/base/jar.mn
+--- mozilla/browser/base/jar.mn.firstrun 2008-06-15 12:39:28.000000000 -0700
++++ mozilla/browser/base/jar.mn 2008-06-15 12:39:34.000000000 -0700
+@@ -21,9 +21,6 @@ browser.jar:
+ * content/browser/browser.js (content/browser.js)
+ * content/browser/browser.xul (content/browser.xul)
+ * content/browser/credits.xhtml (content/credits.xhtml)
+-* content/browser/EULA.js (content/EULA.js)
+-* content/browser/EULA.xhtml (content/EULA.xhtml)
+-* content/browser/EULA.xul (content/EULA.xul)
+ * content/browser/metaData.js (content/metaData.js)
+ * content/browser/metaData.xul (content/metaData.xul)
+ * content/browser/pageinfo/pageInfo.xul (content/pageinfo/pageInfo.xul)
+--- mozilla/browser/components/nsBrowserGlue.js 2008-09-16 19:07:25.000000000 +0000
++++ mozilla/browser/components/nsBrowserGlue.js.new 2008-10-03 14:54:50.955760018 +0000
+@@ -175,33 +175,6 @@
+ // profile startup handler (contains profile initialization routines)
+ _onProfileStartup: function()
+ {
+- // Check to see if the EULA must be shown on startup
+-
+- var prefBranch = Cc["@mozilla.org/preferences-service;1"].
+- getService(Ci.nsIPrefBranch);
+- var mustDisplayEULA = false;
+- try {
+- mustDisplayEULA = !prefBranch.getBoolPref("browser.EULA.override");
+- } catch (e) {
+- // Pref might not exist
+- }
+-
+- // Make sure it hasn't already been accepted
+- if (mustDisplayEULA) {
+- try {
+- var EULAVersion = prefBranch.getIntPref("browser.EULA.version");
+- mustDisplayEULA = !prefBranch.getBoolPref("browser.EULA." + EULAVersion + ".accepted");
+- } catch(ex) {
+- }
+- }
+-
+- if (mustDisplayEULA) {
+- var ww2 = Cc["@mozilla.org/embedcomp/window-watcher;1"].
+- getService(Ci.nsIWindowWatcher);
+- ww2.openWindow(null, "chrome://browser/content/EULA.xul",
+- "_blank", "chrome,centerscreen,modal,resizable=yes", null);
+- }
+-
+ this.Sanitizer.onStartup();
+ // check if we're in safe mode
+ var app = Cc["@mozilla.org/xre/app-info;1"].getService(Ci.nsIXULAppInfo).