summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/xbmc-svn/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/community/xbmc-svn/PKGBUILD')
-rw-r--r--abs/extra-testing/community/xbmc-svn/PKGBUILD72
1 files changed, 43 insertions, 29 deletions
diff --git a/abs/extra-testing/community/xbmc-svn/PKGBUILD b/abs/extra-testing/community/xbmc-svn/PKGBUILD
index e583600..57efdca 100644
--- a/abs/extra-testing/community/xbmc-svn/PKGBUILD
+++ b/abs/extra-testing/community/xbmc-svn/PKGBUILD
@@ -5,7 +5,7 @@
# for his xbmc-vdpau-vdr PKGBUILD at https://archvdr.svn.sourceforge.net/svnroot/archvdr/trunk/archvdr/xbmc-vdpau-vdr/PKGBUILD
pkgname=xbmc-svn
-pkgver=20449
+pkgver=20948
pkgrel=1
pkgdesc="XBMC Media Center from SVN (linuxport branch)"
provides=('xbmc')
@@ -13,10 +13,12 @@ conflicts=('xbmc' 'xbmc-smoothvideo' 'xbmc-vdpau')
arch=('i686' 'x86_64')
url="http://xbmc.org"
license=('GPL' 'LGPL')
-depends=('alsa-lib' 'curl' 'enca' 'faac' 'freetype2' 'fribidi' 'gawk' 'glew' \
- 'hal' 'jasper' 'libgl' 'libjpeg>=6b-5' 'libmad' 'libmysqlclient' \
- 'libxinerama' 'libxrandr' 'lzo2' 'sdl_image' 'sdl_mixer' 'sqlite3' \
- 'tre' 'unzip' 'libcdio' 'libsamplerate' 'python')
+depends=('alsa-lib' 'curl' 'enca' 'faac' 'freetype2' 'fribidi' 'gawk' 'glew'
+ 'hal' 'jasper' 'libgl' 'libjpeg>=6b-5' 'libmad' 'libmysqlclient'
+ 'libxinerama' 'libxrandr' 'lzo2' 'sdl_image' 'sdl_mixer' 'sqlite3'
+ 'tre' 'unzip' 'libcdio' 'libsamplerate' 'python' 'avahi' 'libmad'
+ 'a52dec' 'libdca' 'faad2' 'libmpeg2' 'libvorbis' 'libogg'
+ 'libmpcdec' 'flac' 'wavpack' 'xorg-utils')
makedepends=('subversion' 'autoconf' 'automake' 'boost' 'cmake' 'gcc' 'gperf'
'libtool>=2.2.6a-1' 'make' 'nasm' 'patch' 'pkgconfig' 'zip' 'flex' 'bison')
optdepends=('lirc: remote controller support'
@@ -24,17 +26,14 @@ optdepends=('lirc: remote controller support'
'smbclient: access windows shares'
'unrar: access compressed files without unpacking them')
install=("${pkgname}.install")
-source=('libcurl-not-in-lib64.patch' \
- 'libfaad2-enable-AC_PROG_CXX.patch' \
+source=('libcurl-not-in-lib64.patch'
'xbmc-safe-fullscreen.patch'
'Lircmap.xml')
-noextract=('libcurl-not-in-lib64.patch' \
- 'libfaad2-enable-AC_PROG_CXX.patch' \
- 'xbmc-safe-fullscreen.patch')
-
-md5sums=('96636ee964e37b78ca62235eb10d29c1'
- '6864778d6adc3ccc79130c294f2fffd9'
- 'c4d53522773846d8670884cc38f94aa0'
+noextract=('libcurl-not-in-lib64.patch'
+ 'xbmc-safe-fullscreen.patch'
+ 'Lircmap.xml')
+md5sums=('ac1244a5b4aad0e7d59e86a0d318df1b'
+ '809c684287b68621d3b19923bb57adfe'
'3f93186f1ea4aad73011d00754c7265a')
options=(!makeflags)
@@ -60,36 +59,48 @@ build() {
# Experimental safe fullscreen patch from the forums (by motd2k)
msg "Patching with xbmc-safe-fullscreen.patch"
- patch --quiet -p0 < "$srcdir/xbmc-safe-fullscreen.patch" || return 1
+ patch -p0 < "$srcdir/xbmc-safe-fullscreen.patch" || return 1
# Arch's libcurl lives in /usr/lib, not /usr/lib64 - fix the path:
msg "Patching with libcurl-not-in-lib64.patch"
- patch --quiet -p0 < "$srcdir/libcurl-not-in-lib64.patch" || return 1
-
- # libfaad2 complains about a missing AC_PROG_CXX - add it and bootstrap:
- msg "Patching with libfaad2-enable-AC_PROG_CXX.patch"
- patch --quiet -p0 < "$srcdir/libfaad2-enable-AC_PROG_CXX.patch" || return 1
- autoreconf -vif xbmc/cores/dvdplayer/Codecs/libfaad2
-
- # libass needs a bootstrap due to newer autotools in Arch Linux
- autoreconf -vif xbmc/lib/libass
-
- # Another autotools mismatch between Arch and Ubuntu (xbmc-linuxport is developed against Ubuntu)
- autoreconf -vif "$srcdir/$_svnmod/xbmc/cores/dvdplayer/Codecs/libdvd/libdvdcss"
+ patch -p0 < "$srcdir/libcurl-not-in-lib64.patch" || return 1
# Goom also needs a fixup due to newer autotools
cd "$srcdir/$_svnmod/xbmc/visualizations/Goom/goom2k4-0"
aclocal
libtoolize --copy --force
./autogen.sh --enable-static --with-pic
-
+
# Configure XBMC
+ #
+ # Note on external-libs:
+ # - We cannot use external python because Arch's python was built with
+ # UCS2 unicode support, whereas xbmc expects UCS4 support
+ # - We cannot use external ffmpeg as we would loose VDPAU functionality
+ # because Arch's ffmpeg package does not support VDPAU
+ # - We don't want to rely on AUR packages, so we also don't use libass
+ # as long as it's in AUR
+ msg "Configuring XBMC"
cd "$srcdir/$_svnmod"
make distclean
./configure --prefix=${_prefix} \
+ --enable-external-libmad \
+ --enable-external-liba52 \
+ --enable-external-libdts \
+ --enable-external-libfaad \
+ --enable-external-libmpeg2 \
+ --enable-external-libvorbis \
+ --enable-external-libogg \
+ --enable-external-libmpcdec \
+ --enable-external-libflac \
+ --enable-external-libwavpack \
+ --disable-external-libass \
+ --disable-external-python \
+ --disable-external-ffmpeg \
--disable-debug || return 1
# Fix false negative detections of realloc that happens some times
+ msg "Fixing false negative detections of realloc"
if grep -q 'HAVE_REALLOC 0' config.h; then
sed -e 's|#define HAVE_REALLOC 0|#define HAVE_REALLOC 1|' \
-e 's|#define realloc rpl_realloc|/* #define realloc rpl_realloc */|' \
@@ -97,11 +108,14 @@ build() {
fi
# XBMCTex will segfault on systems with nvidia installed if linked to OpenGL
+ msg "Fixing XBMCTex on systems using the nvidia driver blob"
sed -e 's/-lGLU -lGLEW -lGL//' \
-i ${srcdir}/$_svnmod/tools/XBMCTex/Makefile
# Now (finally) build
+ msg "Running make"
make || return 1
+ msg "Running make install"
make prefix=${pkgdir}${_prefix} install || return 1
# Install
@@ -127,5 +141,5 @@ build() {
done
# Use custom Lircmap to support StreamZap remote
- cp $srcdir/Lircmap.xml ${pkgdir}${_prefix}/share/xbmc/system/Lircmap.xml
+ cp ${srcdir}/Lircmap.xml ${pkgdir}${_prefix}/share/xbmc/system/Lircmap.xml
}