summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/cvs
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/cvs')
-rw-r--r--abs/extra-testing/cvs/PKGBUILD28
-rw-r--r--abs/extra-testing/cvs/cvs-1.11.23-getline64.patch34
-rw-r--r--abs/extra-testing/cvs/cvs.install20
3 files changed, 0 insertions, 82 deletions
diff --git a/abs/extra-testing/cvs/PKGBUILD b/abs/extra-testing/cvs/PKGBUILD
deleted file mode 100644
index 26b95db..0000000
--- a/abs/extra-testing/cvs/PKGBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# $Id: PKGBUILD 75326 2010-04-01 10:25:20Z allan $
-# Contributor: dorphell <dorphell@archlinux.org>
-
-pkgname=cvs
-pkgver=1.11.23
-pkgrel=5
-pkgdesc="Concurrent Versions System - a source control system"
-arch=(i686 x86_64)
-url="http://cvs.nongnu.org"
-license=('GPL')
-depends=('heimdal>=1.3.1')
-optdepends=('openssh: for using cvs over ssh' 'inetutils: for using cvs over rsh')
-install=cvs.install
-source=(ftp://ftp.gnu.org/non-gnu/cvs/source/stable/$pkgver/$pkgname-$pkgver.tar.bz2
- cvs-1.11.23-getline64.patch)
-sha256sums=('400f51b59d85116e79b844f2d5dbbad4759442a789b401a94aa5052c3d7a4aa9'
- '9126d7992ace943980ad8a10d5a09aeb6f1eeeb9b921fc796fe31de7b1c220cf')
-
-build() {
- cd $srcdir/$pkgname-$pkgver
- unset EDITOR VISUAL
-
- patch -Np1 -i $srcdir/cvs-1.11.23-getline64.patch || return 1
- ./configure --prefix=/usr
- make || return 1
- make DESTDIR=$pkgdir install
- rm ${pkgdir}/usr/share/info/dir
-}
diff --git a/abs/extra-testing/cvs/cvs-1.11.23-getline64.patch b/abs/extra-testing/cvs/cvs-1.11.23-getline64.patch
deleted file mode 100644
index 99942e0..0000000
--- a/abs/extra-testing/cvs/cvs-1.11.23-getline64.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- cvs-1.11.23/lib/getline.c 2005-04-04 22:46:05.000000000 +0200
-+++ cvs-1.11.23/lib/getline.c.old 2008-06-03 19:06:25.000000000 +0200
-@@ -154,7 +154,7 @@
- return ret;
- }
-
--int
-+ssize_t
- getline (lineptr, n, stream)
- char **lineptr;
- size_t *n;
-@@ -163,7 +163,7 @@
- return getstr (lineptr, n, stream, '\n', 0, GETLINE_NO_LIMIT);
- }
-
--int
-+ssize_t
- getline_safe (lineptr, n, stream, limit)
- char **lineptr;
- size_t *n;
---- cvs-1.11.23/lib/getline.h 2005-04-04 22:46:05.000000000 +0200
-+++ cvs-1.11.23/lib/getline.h.old 2008-06-03 19:06:27.000000000 +0200
-@@ -11,9 +11,9 @@
-
- #define GETLINE_NO_LIMIT -1
-
--int
-+ssize_t
- getline __PROTO ((char **_lineptr, size_t *_n, FILE *_stream));
--int
-+ssize_t
- getline_safe __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
- int limit));
- int
diff --git a/abs/extra-testing/cvs/cvs.install b/abs/extra-testing/cvs/cvs.install
deleted file mode 100644
index f1cdd1f..0000000
--- a/abs/extra-testing/cvs/cvs.install
+++ /dev/null
@@ -1,20 +0,0 @@
-infodir=/usr/share/info
-filelist=(cvs.info cvs-info-1 cvs-info-2 cvsclient.info)
-
-post_install() {
- for file in ${filelist[@]}; do
- install-info $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- for file in ${filelist[@]}; do
- install-info --delete $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-# vim:set ts=2 sw=2 et: