summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/dnsmasq
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/dnsmasq')
-rw-r--r--abs/extra-testing/dnsmasq/PKGBUILD41
-rwxr-xr-xabs/extra-testing/dnsmasq/rc.dnsmasq36
2 files changed, 0 insertions, 77 deletions
diff --git a/abs/extra-testing/dnsmasq/PKGBUILD b/abs/extra-testing/dnsmasq/PKGBUILD
deleted file mode 100644
index f888ccd..0000000
--- a/abs/extra-testing/dnsmasq/PKGBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# $Id: PKGBUILD 66607 2010-02-01 01:42:17Z giovanni $
-# Maintainer: Paul Mattal <paul@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-
-pkgname=dnsmasq
-pkgver=2.55
-pkgrel=1
-pkgdesc="Lightweight, easy to configure DNS forwarder and DHCP server"
-url="http://www.thekelleys.org.uk/dnsmasq/doc.html"
-arch=('i686' 'x86_64')
-license=('GPL')
-depends=('glibc' 'bash')
-makedepends=('libcap>=2.16')
-backup=('etc/dnsmasq.conf')
-install=
-source=("http://www.thekelleys.org.uk/$pkgname/$pkgname-$pkgver.tar.gz"
- 'rc.dnsmasq')
-
-build() {
- cd $srcdir/$pkgname-$pkgver
-
- # Build
- make || return 1
-
- # Install
- install -d $pkgdir/etc/rc.d || return 1
- make PREFIX=/usr DESTDIR=$pkgdir install || return 1
-
- install -D -m755 \
- $srcdir/rc.dnsmasq $pkgdir/etc/rc.d/dnsmasq || return 1
- install -D -m644 \
- dnsmasq.conf.example $pkgdir/etc/dnsmasq.conf || return 1
-
- # Make the Required Directories for DHCP Server Default Directories
- install -d $pkgdir/var/db || return 1
- install -d $pkgdir/var/lib/misc || return 1
-}
-
-# vim: ts=2 sw=2 et ft=sh
-md5sums=('b093d7c6bc7f97ae6fd35d048529232a'
- 'e956eee1ec24212a3254d2b168187495')
diff --git a/abs/extra-testing/dnsmasq/rc.dnsmasq b/abs/extra-testing/dnsmasq/rc.dnsmasq
deleted file mode 100755
index 1676072..0000000
--- a/abs/extra-testing/dnsmasq/rc.dnsmasq
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/sbin/dnsmasq`
-case "$1" in
- start)
- stat_busy "Starting DNS/DHCP daemon"
- [ -z "$PID" ] && /usr/sbin/dnsmasq
- if [ $? -gt 0 ] ; then
- stat_fail
- else
- add_daemon dnsmasq # create the 'state' dir
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping DNS/DHCP daemon"
- [ "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon dnsmasq # remove the 'state' dir
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 5
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0