summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/gconf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/gconf/PKGBUILD')
-rw-r--r--abs/extra-testing/gconf/PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/abs/extra-testing/gconf/PKGBUILD b/abs/extra-testing/gconf/PKGBUILD
index 001c9e2..0fc2fb0 100644
--- a/abs/extra-testing/gconf/PKGBUILD
+++ b/abs/extra-testing/gconf/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 13038 2008-09-25 19:45:37Z jgc $
+# $Id: PKGBUILD 22335 2008-12-26 13:57:57Z jgc $
# Maintainer: Jan de Groot <jan@archlinux.org>
pkgname=gconf
pkgver=2.24.0
-pkgrel=1
+pkgrel=2
pkgdesc="A configuration database system"
arch=(i686 x86_64)
license=('LGPL')
@@ -18,22 +18,22 @@ source=(http://ftp.gnome.org/pub/gnome/sources/GConf/2.24/GConf-${pkgver}.tar.bz
gconf-reload.patch)
md5sums=('4971d96f5ba94fe4a69396267bd5afe8'
'1412bafb06f7d8a9601c8f1c4d72cc06'
- '0a43077786fe85ee10002b753752379a'
+ 'b745f04b4121d8724c002b14a4c110b6'
'cfcc8e15be7b8a48de4aa34336ff6090')
build() {
- cd ${startdir}/src/GConf-${pkgver}
- patch -Np1 -i ${startdir}/src/gconf-reload.patch || return 1
+ cd "${srcdir}/GConf-${pkgver}"
+ patch -Np1 -i "${srcdir}/gconf-reload.patch" || return 1
libtoolize --force --copy || return 1
aclocal || return 1
autoconf || return 1
automake --add-missing || return 1
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --libexecdir=/usr/lib/GConf \
- --disable-static || return 1
+ --disable-static --enable-defaults-service || return 1
make pkglibdir=/usr/lib/GConf || return 1
- make DESTDIR=${startdir}/pkg install || return 1
- install -m755 ${startdir}/src/gconf-merge-schema ${startdir}/pkg/usr/bin/ || return 1
- install -d -m755 ${startdir}/pkg/usr/sbin
- install -m755 ${startdir}/src/gconfpkg ${startdir}/pkg/usr/sbin/ || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 "${srcdir}/gconf-merge-schema" "${pkgdir}/usr/bin/" || return 1
+ install -d -m755 "${pkgdir}/usr/sbin"
+ install -m755 "${srcdir}/gconfpkg" "${pkgdir}/usr/sbin/" || return 1
}