summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libxcb
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/libxcb')
-rw-r--r--abs/extra-testing/libxcb/PKGBUILD34
-rw-r--r--abs/extra-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch12
-rw-r--r--abs/extra-testing/libxcb/libxcb-1.1-sloppy-lock.patch12
3 files changed, 58 insertions, 0 deletions
diff --git a/abs/extra-testing/libxcb/PKGBUILD b/abs/extra-testing/libxcb/PKGBUILD
new file mode 100644
index 0000000..c61df23
--- /dev/null
+++ b/abs/extra-testing/libxcb/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 8004 2008-08-05 18:11:40Z jgc $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=libxcb
+pkgver=1.1.90.1
+pkgrel=1
+pkgdesc="X11 client-side library"
+arch=(i686 x86_64)
+url="http://xcb.freedesktop.org/"
+depends=('xcb-proto>=1.2' 'libxdmcp' 'libxau')
+makedepends=('pkgconfig' 'libxslt' 'python')
+options=('!libtool')
+license=('custom')
+source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2
+ libxcb-1.1-no-pthread-stubs.patch
+ libxcb-1.1-sloppy-lock.patch)
+md5sums=('c4b67c5576ed58e2fd4a2855c0b21aa6'
+ 'a53f09ab3ec5cbfc1b0848bd137c535a'
+ '4b3fbedc471d7ab336a18f1d0f853ddd')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np1 -i ${srcdir}/libxcb-1.1-no-pthread-stubs.patch || return 1
+ patch -Np1 -i ${srcdir}/libxcb-1.1-sloppy-lock.patch || return 1
+ libtoolize --force --copy || return 1
+ aclocal || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+ ./configure --prefix=/usr --enable-xinput || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+}
diff --git a/abs/extra-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch b/abs/extra-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch
new file mode 100644
index 0000000..67a09f2
--- /dev/null
+++ b/abs/extra-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch
@@ -0,0 +1,12 @@
+diff -up libxcb-1.1/configure.ac.pthread-stubs libxcb-1.1/configure.ac
+--- libxcb-1.1/configure.ac.pthread-stubs 2007-11-04 18:17:11.000000000 -0500
++++ libxcb-1.1/configure.ac 2007-11-12 10:27:06.000000000 -0500
+@@ -31,7 +31,7 @@ AC_SUBST(HTML_CHECK_RESULT)
+
+ # Checks for pkg-config packages
+ PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.1)
+-NEEDED="pthread-stubs xau >= 0.99.2"
++NEEDED="xau >= 0.99.2"
+ PKG_CHECK_MODULES(NEEDED, $NEEDED)
+
+ have_xdmcp="no"
diff --git a/abs/extra-testing/libxcb/libxcb-1.1-sloppy-lock.patch b/abs/extra-testing/libxcb/libxcb-1.1-sloppy-lock.patch
new file mode 100644
index 0000000..130890e
--- /dev/null
+++ b/abs/extra-testing/libxcb/libxcb-1.1-sloppy-lock.patch
@@ -0,0 +1,12 @@
+diff -up libxcb-1.1/src/xcb_conn.c.jx libxcb-1.1/src/xcb_conn.c
+--- libxcb-1.1/src/xcb_conn.c.jx 2007-10-28 16:11:18.000000000 -0400
++++ libxcb-1.1/src/xcb_conn.c 2008-04-22 11:58:05.000000000 -0400
+@@ -63,7 +63,7 @@ static int _xcb_xlib_init(_xcb_xlib *xli
+ {
+ xlib->lock = 0;
+ #ifndef NDEBUG
+- xlib->sloppy_lock = (getenv("LIBXCB_ALLOW_SLOPPY_LOCK") != 0);
++ xlib->sloppy_lock = 1;
+ #endif
+ pthread_cond_init(&xlib->cond, 0);
+ return 1;